Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 23:58
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Сохранение цен  (Прочитано 1126 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн edmynt

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-01-13
  • Сайт: 
  • Профессия: Ученик 1С
Добрый вечер. Ни где не смог найти соответствующие статьи. Есть два документа приход товара, и соответственно возврат. Как лучше реализовать хранение истории цен и автозаполнение последней актуальной ценой? Начал делать, создав регистр сведений, но зашел в тупик, так как автозаполнение из регистров отсутствует. Есть мысль, что последнюю цену записывать в справочник, но есть сомнения, например при перепроведении тогда может быть не актуальная цена.  1с 8.3


Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Re: Сохранение цен
« Ответ #1: 24 Июл 2015, 17:31 »
Начал делать, создав регистр сведений
Правильной дорогой идете товарищи.

так как автозаполнение из регистров отсутствует
А что это за зверь такой? типа нажал на кнопочку и оно само куда-то подставилось?


Оффлайн edmynt

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-01-13
  • Сайт: 
  • Профессия: Ученик 1С
Re: Сохранение цен
« Ответ #2: 24 Июл 2015, 17:37 »

так как автозаполнение из регистров отсутствует
А что это за зверь такой? типа нажал на кнопочку и оно само куда-то подставилось?
[/quote]

Ну всмысле ввод на основании

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Re: Сохранение цен
« Ответ #3: 24 Июл 2015, 17:42 »
Ну и что что ввод на основании? вод на основании в любом случае прописывать надо.
Запрос - решение всех проблем.

Оффлайн edmynt

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-01-13
  • Сайт: 
  • Профессия: Ученик 1С
Re: Сохранение цен
« Ответ #4: 24 Июл 2015, 17:47 »
Ну и что что ввод на основании? вод на основании в любом случае прописывать надо.
Запрос - решение всех проблем.

Уже иду в этом направлении:

&НаСервере
Процедура ТабличнаяЧасть1НаименованиеПриИзмененииНаСервере()
"ВЫБРАТЬ
| ЦеныОпт.Номенклатура,
| ЦеныОпт.Цена
|ИЗ
| РегистрСведений.ЦеныОпт КАК ЦеныОпт"
КонецПроцедуры


Вот что то получилось...только он скорее всего все записи выберет. А как сделать последнюю актуальную по дате регистратора? В конструкторе есть выбор первой записи, а последней нет

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Re: Сохранение цен
« Ответ #5: 24 Июл 2015, 17:52 »
Регистр должен быть периодическим + использовать виртуальную таблицу среза последних

Оффлайн edmynt

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-01-13
  • Сайт: 
  • Профессия: Ученик 1С
Re: Сохранение цен
« Ответ #6: 24 Июл 2015, 18:15 »
Регистр должен быть периодическим + использовать виртуальную таблицу среза последних

Вот что получилось:

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ЦеныОптСрезПоследних.Номенклатура,
| ЦеныОптСрезПоследних.Цена
|ИЗ
| РегистрСведений.ЦеныОпт.СрезПоследних КАК ЦеныОптСрезПоследних
|ГДЕ
| ЦеныОптСрезПоследних.Номенклатура = &Номенклатура";

Запрос.УстановитьПараметр("Номенклатура", Номенклатура);

РезультатЗапроса = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
// Вставить обработку выборки ВыборкаДетальныеЗаписи
КонецЦикла;

//}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА


И ошибка при компиляции : {Документ.ПриходТовара.Форма.ФормаДокумента.Форма(48,44)}: Переменная не определена (Номенклатура)
   Запрос.УстановитьПараметр("Номенклатура", <<?>>Номенклатура); (Проверка: Сервер)

Добавлено: 24 Июл 2015, 19:01

Разобрался,
вот код.работает :

&НаКлиенте
Процедура ТабличнаяЧасть1НаименованиеПриИзменении(Элемент)
Цена = 0;
СтрокаТЧ=Элементы.ТабличнаяЧасть1.ТекущиеДанные;
Номенклатура = СтрокаТЧ.Номенклатура;
ТабличнаяЧасть1НаименованиеПриИзмененииНаСервере(Номенклатура, Цена);
СтрокаТЧ.Цена = Цена;


КонецПроцедуры

&НаСервере
Процедура ТабличнаяЧасть1НаименованиеПриИзмененииНаСервере(Номенклатура, Цена)
//{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
// Данный фрагмент построен конструктором.
// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!


Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ЦеныОптСрезПоследних.Номенклатура,
| ЦеныОптСрезПоследних.Цена
|ИЗ
| РегистрСведений.ЦеныОпт.СрезПоследних КАК ЦеныОптСрезПоследних
|ГДЕ
| ЦеныОптСрезПоследних.Номенклатура = &Номенклатура";

Запрос.УстановитьПараметр("Номенклатура",Номенклатура);

РезультатЗапроса = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
// Вставить обработку выборки ВыборкаДетальныеЗаписи
Цена=ВыборкаДетальныеЗаписи.Цена;
КонецЦикла;

//}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА


КонецПроцедуры

Добавлено: 24 Июл 2015, 19:01

Большое спасибо

Последний раз редактировалось: edmynt; 24 Июл 2015, 19:01. Причина: Объединение сообщений


 

Сохранение документов в формате *.pdf с компьютеров, подключенных к серверу через удаленное подключение к рабочему столу

Автор NeutrinoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 693
Последний ответ 20 Июл 2016, 15:59
от Neutrino
Управляемые формы. Сохранение настроек отчета конфигурации с нуля, одинаковых для всех пользователей

Автор sergeysРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 292
Последний ответ 03 Авг 2017, 04:46
от sergeys
Сохранение сгенерированных колонок и данных их ячеек в таблице значений документа

Автор LonerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1868
Последний ответ 06 Мар 2014, 07:48
от sdilshod
Как при сохранение одного документа, менять идентичный реквизит в другом документе

Автор kipishioРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 20
Просмотров: 6271
Последний ответ 20 Фев 2015, 21:23
от vitasw
сохранение изменений данных справочнике в регистре сведений

Автор primusРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 10
Просмотров: 7218
Последний ответ 25 Авг 2011, 16:07
от primus

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
184 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
50 Сообщений
andron81_81
41 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 218
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal