Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Май 2018, 18:35
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проблема с "Полем картинки" в мобильной платформе  (Прочитано 2471 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн TreeDogNight

  • ***
  • Сообщений: 203
  • РЕПУТАЦИЯ: 28
  • КПД: 14%
  • Регистрация: 2013-10-16
    • Skype: treedognight3
  • Сайт: www.avars.uz
  • Профессия: Программист 1С
Здравствуйте люди! На прошлой неделе начал разрабатывать конфигурацию для мобильной платфоры. Одно из требований к функционалу - прикрепление фотографии в элементы справочника.
Проблема заключается в том, что у меня не получается сохранить любую картинку в реквизит формы с типом "Картинка".

Сначала, используя объект "СредстваМультимедиа", пробовал сделать фото, и запихать его двоичные данные в поле картинки:
&НаКлиенте
Процедура НовоеФото(Команда)

#Если МобильноеПриложениеКлиент Тогда
ДанныеМультимедиа = СредстваМультимедиа.СделатьФотоснимок(ТипКамерыУстройства.Задняя);
Фото = Новый Картинка(ДанныеМультимедиа.ПолучитьДвоичныеДанные());
#КонецЕсли   

КонецПроцедуры
В результате этой команды мобильное приложение вылетает.

Потом попробовал записать в поле картинки, картинку из библиотеки:
&НаКлиенте
Процедура НовоеФото(Команда)

Фото = БиблиотекаКартинок.БизнесПроцесс;

КонецПроцедуры
Реакция команды такая же - приложение вылетает.
Сталкивался ли кто-нибудь с данной проблемой?
Cегодня не все могут провести завтрашним числом. Вернее, не только лишь все - мало кто может это сделать.


Оффлайн TreeDogNight

  • ***
  • Сообщений: 203
  • РЕПУТАЦИЯ: 28
  • КПД: 14%
  • Регистрация: 2013-10-16
    • Skype: treedognight3
  • Сайт: www.avars.uz
  • Профессия: Программист 1С
Всё, нашёл решение!
Создал реквизит формы СсылкаНаКартинку с типом "Строка", вытащил на форму и указал в свойствах элемента "Поле картинки".
Обработчик фотографирования сделал такой:
&НаКлиенте
Процедура НовоеФото(Команда)
   
    #Если МобильноеПриложениеКлиент Тогда

        ДанныеМультимедиа = СредстваМультимедиа.СделатьФотоснимок();
        Если Не ДанныеМультимедиа = Неопределено Тогда
            Попытка
                ДвоичныеДанные        = ДанныеМультимедиа.ПолучитьДвоичныеДанные();
                АдресХранилища         = ПоместитьВоВременноеХранилище(ДвоичныеДанные, УникальныйИдентификатор);
                СсылкаНаКартинку     = АдресХранилища;
            Исключение
                Сообщить(ОписаниеОшибки());   
            КонецПопытки;
        КонецЕсли;
    #КонецЕсли

   
КонецПроцедуры
Cегодня не все могут провести завтрашним числом. Вернее, не только лишь все - мало кто может это сделать.


 

Проблема с развертыванием окон и сохранением окон

Автор SokresРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3130
Последний ответ 09 Дек 2015, 14:09
от pavl_vs
Программ конвертации с 77 в 8 при конвертации вырубается - проблема в файле backend.dll

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 864
Последний ответ 24 Ноя 2016, 06:18
от cska-fanat-kz
Проблема при проведении реализации УТ 11 - сообщение дата оплаты меньше даты документа

Автор AndreyBlacksmithРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 3238
Последний ответ 05 Фев 2015, 11:53
от AndreyBlacksmith
Формирование остатков на дату: проблема с параметром <Момент времени> как Дата

Автор SevishРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 11161
Последний ответ 15 Окт 2013, 11:49
от MuI_I_Ika
Проблема с выгрузкой изображений при обмене с сайтом в 1С: Управление небольшой фирмой

Автор balansuserРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4087
Последний ответ 12 Мар 2014, 16:17
от espero2000

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
165 Сообщений
alex0402
78 Сообщений
oleg-x
69 Сообщений
AIFrame AIFrame
63 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
39 Сообщений
ilyay ilyay
39 Сообщений
KOI8-R
36 Сообщений
Анюта17
33 Сообщений
Alter
29 Сообщений

* Кто онлайн

  • Точка Гостей: 331
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal