Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 02:47
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Пытаюсь увеличить шрифт программно. Выдает ошибка  (Прочитано 801 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн 50schaps

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-07-22
  • Сайт: 
  • Профессия: Бухгалтер
Я не программист , но очень уэ хочется изменить шрифт в сторону увеличения, и не только текста, но и меню
Нашел в Интернете и начал с этого
В КОНФИГУРАТОРЕ:Бузгалтерия 2.0.64.30

1) Добавить регистр сведений "СтилиПользователей"
   Непериодический, независимый
   Измерения:
     - Пользователь ,тип СправочникСсылка.Пользователи
   Ресурсы:
     - НомерСтиля   ,тип Число 1.0 –ЗДЕСЬ НЕПОНЯЛ ГДЕ !.0 ПОСТАВИТЬ ?

2) В ветке "Общие - Стили" скопировать стиль "Основной" в "Основной1".
   В стиле "Основной1" изменить Шрифт текста на Verdana,8
   (путем проб можно другой подобрать, я остановился на этом)
----------------------------------------------------------------------
// ПРОЦЕДУРЫ ГЛОБАЛЬНОГО КОНТЕКСТА
// Процедура - обработчик события "При завершением работы системы".
процедура ПриЗавершенииРаботыСистемы()
3) В модуле обычного приложения добавить функцию ПолучитьНомерСтиляПользователя()
   и вызов ее в процедуре ПередНачаломРаботыСистемы()
ВСТАВЛЯЮ ЭТО

//+ASG
Функция ПолучитьНомерСтиляПользователя()
   
   
Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    |    СтилиПользователей.НомерСтиля
    |ИЗ
    |    РегистрСведений.СтилиПользователей КАК СтилиПользователей
    |ГДЕ
    |    СтилиПользователей.Пользователь = &Пользователь";
   
    Запрос.УстановитьПараметр("Пользователь", ПараметрыСеанса.ТекущийПользователь);
    Результат = Запрос.Выполнить().Выбрать();
    Если Результат.Следующий() Тогда
        Возврат Результат.НомерСтиля;   
    Иначе
        Возврат 0;
    КонецЕсли;

КонецФункции // ПолучитьНомерСтиляПользователя

// Процедура - обработчик события "Перед началом работы системы".
//
Процедура ПередНачаломРаботыСистемы(Отказ)
   
    УправлениеПользователями.ПроверитьВозможностьРаботыПользователя(Отказ);   
   
    ГлавныйСтиль = БиблиотекаСтилей.Получить(ПолучитьНомерСтиляПользователя()); //+ASG
   
КонецПроцедуры

ПРИ ЗАГРУЗКИ КОНФИГУРАЦИИ ВЫДАЕТ ТАКУЮ ОШИБКУ
{МодульОбычногоПриложения(115,11)}: Процедура или функция с указанным именем уже определена (ПередНачаломРаботыСистемы)
Процедура <<?>>ПередНачаломРаботыСистемы(Отказ)
ГДЕ ТО Я НАКУРАЛЕСИЛ. ПОДСКАЖИТЕ !
=========================================================


Теги:
 

При открытии обр-ки в "Предприятии" есть ошибка, а в "Отладке" нет

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4527
Последний ответ 21 Сен 2011, 17:35
от proofet
ошибка "Невозможно обработать параметр "ПрофильПолномочийПользователя""

Автор lindeluРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 6080
Последний ответ 06 Июн 2012, 09:15
от lindelu
Синтаксическая ошибка "В" Номенклатура.Ссылка = <<?>> В ИЕРАРХИИ(&Ссылка)

Автор maskitoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4195
Последний ответ 28 Апр 2014, 15:53
от maskito
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8488
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 8556
Последний ответ 26 Апр 2012, 23:08
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 234
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal