Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Сен 2020, 20:19
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите разобраться документом ГТД...  (Прочитано 1719 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Бестия

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-09-28
  • Сайт: 
Всем привет, помогите разобраться, комплексная конфигурация, документ ГТД. Формируются проводки не так как бы хотелось. Необходимо чтобы в проводке 281-632, по 281 счету в проводке было указано субконто 1, субконто 2 ну и + количество. Вроде и в плане счетов все предусмотрено, а проводки формируются итоговыми суммами по документу (а надо грубо говоря в цикле по строкам), соответственно тогда и в 281 нет аналитики по субконто. Может где то есть какая то загвоздочка и можно быстро решить мою проблему, вместо того чтобы изобретать заново велосипед?
про обработку ЭП_ФормированиеПроводокТорговля

текОперация.Дебет.Счет = текСчетД; 
Если ПустоеЗначение(текСчетД) = 0 Тогда
Для Инд = 1 по 3 Цикл
//Если текСчетД.ВидСубконто(Инд) = ВидыСубконто.Партии Тогда
// раскомментировать, если необходимо формирование поводок по счетам учета товаров с аналитикой
// нужно найти или создать партию
спПартия = тбПроводки.ПолучитьЗначение(тбПроводки.НомерСтроки, "СубконтоД"+Инд);
ЗначениеСубк = 0;
Если ТипЗначенияСтр(спПартия)="СписокЗначений" Тогда
глПолучитьПартию(ЗначениеСубк,спПартия.Получить("ТМЦ"),спПартия.Получить("Партия"));
КонецЕсли;
Иначе
ЗначениеСубк = тбПроводки.ПолучитьЗначение(тбПроводки.НомерСтроки, "СубконтоД"+Инд);
КонецЕсли;
КонецЦикла;

Так вот в чем дело: когда я раскоментировала необходимые строки для ведения аналитики по товарам, ничего не произошло, такие же проводки как были такие и остались, как заставить программу видеть 281 счет по товарам.

и ещё один вопрос:
Справочник ЭП_Проводки

Если ПустоеЗначение(ВидСубконто) = 0 Тогда
Если (ТипЗначенияСтр(Счет) = "Счет") и ((Лев(Сч.Код,2) = "28") или (Лев(Сч.Код,2) = "66")) Тогда
// для счетов 28х и 66х запрещено редактирование субконто
Форма.ПолучитьАтрибут(Субконто).Видимость(0);
Форма.ПолучитьАтрибут(тСубконто).Заголовок("Пустое субконто");
Форма.ПолучитьАтрибут(тСубконто).Видимость(1);
Форма.ПолучитьАтрибут(АвтоСубконто).Доступность(0);
Форма.ПолучитьАтрибут(Параметр).Доступность(0);
ИначеЕсли (ТипЗначенияСтр(Счет) = "Справочник")
и (Лев(Сч.Код,2) = "28") Тогда
// для доп.параметров "Счет учета товаров", "Счет учета товаров в рознице"
// и "Счет учета товаров, отданных на комиссию"
// запрещено редактирование субконто
Форма.ПолучитьАтрибут(Субконто).Видимость(0);
Форма.ПолучитьАтрибут(тСубконто).Заголовок("Определяется автоматически");
Форма.ПолучитьАтрибут(тСубконто).Видимость(1);
Форма.ПолучитьАтрибут(АвтоСубконто).Доступность(0);
Форма.ПолучитьАтрибут(Параметр).Доступность(0);
Иначе
........
и т.д.

почему ЗАПРЕЩЕНО РЕДАКТИРОВАНИЕ СУБКОНТО по 28 счету?


Последний раз редактировалось: AdminProg; 22 Ноя 2010, 02:05


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
72 Сообщений
LexaK
33 Сообщений
oooo800
32 Сообщений
Дмитрий Джей Дмитрий Джей
28 Сообщений
IL2016
25 Сообщений
antoneus antoneus
21 Сообщений
DmitriyF DmitriyF
18 Сообщений
Ann_
16 Сообщений
SoOliateR
15 Сообщений
мадам брошкина
13 Сообщений

* Кто онлайн

  • Точка Гостей: 288
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal