Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 04:49
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Ошибка при удалении и создании первой строки  (Прочитано 576 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dart909

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-07-09
  • Сайт: 
  • Профессия: Разработчик 1С
Добрый день. Есть документ с табличной частью Маршруты. У табчасти есть два реквизита ПунктВыезда, ПунктПрибытия. Есть след. маеханизм:
При создании новой строки в табчасти значению ПунктВыезда присваевается значение ПунктПрибытия предыдущей строки. Код:

Процедура МаршрутыПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)
   ПеременнаяСтрока = Элементы.Маршруты.ТекущаяСтрока;
   Строчка = Элементы.Маршруты.ТекущиеДанные.НомерСтроки;
   
    Если Элементы.Маршруты.ТекущаяСтрока=0 тогда
     Если Элементы.Маршруты.ТекущаяСтрока = 0 Тогда
        Возврат
     КонецЕсли;
    Если Элементы.Маршруты.ТекущаяСтрока<>0 Тогда
    ПунктВыезда = Объект.Маршруты.НайтиПоИдентификатору(Элементы.Маршруты.ТекущаяСтрока).ПунктПрибытия;
     Элемент.ТекущиеДанные.ПунктВыезда = ПунктВыезда;
 КонецЕсли;
 КонецЕсли
КонецПроцедуры
Заполнение в Новой строке не происходит, подскажите что не так?


Оффлайн KrivosheevEV

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 35
  • КПД: 17%
  • Регистрация: 2014-01-20
  • Сайт: 
  • Профессия: Программист 1С
Процедура МаршрутыПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)
   ПеременнаяСтрока = Элементы.Маршруты.ТекущаяСтрока;
   Строчка = Элементы.Маршруты.ТекущиеДанные.НомерСтроки;
   
    Если Элементы.Маршруты.ТекущаяСтрока=0 тогда        // Если ТекущаяСтрока = 0 Тогда ..
     Если Элементы.Маршруты.ТекущаяСтрока = 0 Тогда     // .. а, Тогда происходит ..
        Возврат                                        //  .. Возврат.
     КонецЕсли;
    Если Элементы.Маршруты.ТекущаяСтрока<>0 Тогда
    ПунктВыезда = Объект.Маршруты.НайтиПоИдентификатору(Элементы.Маршруты.ТекущаяСтрока).ПунктПрибытия;
     Элемент.ТекущиеДанные.ПунктВыезда = ПунктВыезда;
 КонецЕсли;
 КонецЕсли
КонецПроцедуры


Теги:
 

При открытии обр-ки в "Предприятии" есть ошибка, а в "Отладке" нет

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4527
Последний ответ 21 Сен 2011, 17:35
от proofet
ошибка "Невозможно обработать параметр "ПрофильПолномочийПользователя""

Автор lindeluРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 6080
Последний ответ 06 Июн 2012, 09:15
от lindelu
Синтаксическая ошибка "В" Номенклатура.Ссылка = <<?>> В ИЕРАРХИИ(&Ссылка)

Автор maskitoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4195
Последний ответ 28 Апр 2014, 15:53
от maskito
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 8556
Последний ответ 26 Апр 2012, 23:08
от Dethmontt
Синтаксическая ошибка "ИЗ"

Автор kulkriseРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4567
Последний ответ 26 Янв 2014, 19:33
от kulkrise

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 221
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal