Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Май 2018, 09:19
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: ЗначениеИзСтрокиВнутр  (Прочитано 980 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн 1cwiki

  • Модератор
  • *****
  • Сообщений: 8287
  • РЕПУТАЦИЯ: 14
  • КПД: 0%
  • Регистрация: 2014-08-05
  • Сайт: 
  • Профессия: Программист 8.1
Раздел:
Глобальный контекст
Подразделы:
Процедуры и функции сохранения значений
Синтаксис:

ЗначениеИзСтрокиВнутр(<Строка>)
Параметры:

<Строка> (обязательный)

Тип: Строка.
Системное представление значения в строковом виде.
Возвращаемое значение:

Тип: Произвольный.
Значение, полученное из строкового системного представления.
Описание:

Преобразует значение из строкового системного представления во внутреннее.

Доступность:

Сервер, толстый клиент, внешнее соединение.
Примечание:

Строковое представление данных имеет специальный системный формат, использующий идентификацию данных внутри одной информационной базы.
Используется для сохранения функциональной совместимости с 1С:Предприятием 7.7. Использовать для других целей не рекомендуется.
Пример:

Файл = Новый ЧтениеXML;
Файл.ОткрытьФайл(ИмяФайла);
Пока Файл.Прочитать() Цикл
    Если (Файл.ТипУзла = ТипУзлаXML.НачалоЭлемента) И
        (Файл.Имя = "СоответствиеСчетов") Тогда
        // ...
    ИначеЕсли (Файл.ТипУзла = ТипУзлаXML.Текст) Тогда
        Если (ИмяЭлемента = "СчетХозрасчетный") Тогда
            // ...
        ИначеЕсли ИмяЭлемента = "ЗначениеТип" Тогда
            ТипЗнач = ЗначениеИзСтрокиВнутр(Файл.Значение);
        КонецЕсли;
    // ...
    Иначе
        ИмяЭлемента = Файл.Имя;
    КонецЕсли;
КонецЦикла;



Теги:
 


* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
164 Сообщений
alex0402
72 Сообщений
oleg-x
63 Сообщений
AIFrame AIFrame
54 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
41 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
KOI8-R
31 Сообщений

* Кто онлайн

  • Точка Гостей: 191
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal