Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Май 2018, 05:37
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вывод и сравнение двух дат  (Прочитано 529 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн xDee

  • *
  • Сообщений: 35
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-09
  • Сайт: 
  • Профессия: Программист 7.7
Доброго времени суток ! Подскажите пожалуйста как вывести дни рождения детей в таблицу где уже отобраны дни рождения родителей ,что то никак не получается у меня.
Пока Выборка.Следующий() Цикл
ОблЭлемент.Параметры.Заполнить(Выборка);
ДатаР = Формат(Выборка.ДР, "ДФ=M");
ДатаРР = Формат(Выборка.ДРР, "ДФ=M");
ДатаРР2 = Формат(Выборка.ДРР2, "ДФ=M");
ДатаРР3 = Формат(Выборка.ДРР3, "ДФ=M");
МесяцВыбора = Формат(Месяц(ТекущаяДата()), "ДФ=M");

Если ДатаР = МесяцВыбора Тогда
ОблЭлемент.Параметры.ДатаР = Формат(Выборка.ДР, "ДЛФ =D");
Если ДатаРР = МесяцВыбора Тогда
ОблЭлемент.Параметры.ДатаРР = Формат(Выборка.ДРР, "ДЛФ =D");
ТабДок.Вывести(ОблЭлемент);
   КонецЕсли;
   КонецЕсли;
КонецЦикла;
В таком виде выводится только родитель у которого совпадает месяц рождения с ребенком, а мне нужно чтобы выводились все родители у которых в этом месяце ДР.


Оффлайн Rasty

  • *****
  • Сообщений: 997
  • РЕПУТАЦИЯ: 141
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
Сравнивайте их месяца, вроде все просто, или через Найти(Колонка,Значение), вернет строку ТЧ
Добавлено: 21 Июл 2015, 16:33

дополните таб док нужными данными и выводите на печать
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)


Теги:
 

Вывод комментария в документ "Расходная накладная" из документа "Заказ покупателя"

Автор ОльгаПлРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 480
Последний ответ 07 Окт 2017, 19:03
от Norfolk
Вывод результата запроса через условие другого запроса

Автор jonik_jokerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3295
Последний ответ 16 Окт 2013, 15:08
от jonik_joker
Вывод линейной таблицы посредством СКД в виде "шахматки"

Автор VdegРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 11403
Последний ответ 19 Апр 2011, 11:12
от Klyacksa
Вывод набора данных "объединение" скд в дерево значений

Автор Gae4kaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1805
Последний ответ 02 Июн 2015, 12:19
от Gae4ka
Как добавить вывод ДоговораКонтрагента в печатную форму "Счет на оплату"

Автор ValentusРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 14213
Последний ответ 09 Июн 2010, 15:25
от Karamelkina

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
161 Сообщений
alex0402
76 Сообщений
oleg-x
68 Сообщений
AIFrame AIFrame
61 Сообщений
buketov.av buketov.av
44 Сообщений
wise wise
39 Сообщений
KOI8-R
35 Сообщений
Анюта17
29 Сообщений
ilyay ilyay
29 Сообщений
Alter
29 Сообщений

* Кто онлайн

  • Точка Гостей: 202
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal