Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 13:34
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите со справочником  (Прочитано 1400 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Абылайхан

  • **
  • Сообщений: 70
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-02-25
  • Сайт: 
  • Профессия: Ученик 1С
Хочу создать простой справочник с БИН и Наименованиями контрагентов, заполнить их с помощью файла Excel. Как это сделать с помощью импорта экспорта фала excel&


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
ну взять стандартную обработку
подготовить эксельку нужной структуры и вперед
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Абылайхан

  • **
  • Сообщений: 70
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-02-25
  • Сайт: 
  • Профессия: Ученик 1С
ну взять стандартную обработку
подготовить эксельку нужной структуры и вперед

Создал Справочник с 2 реквизитами БИН и наименование и добавил 2 кнопки Обзор и Заполнить, теперь не получается забить информацией эти реквизиты.Не знаю как в цикле задать запись в этот справочник.

Перем   ПутьКФайлу;
Процедура ДействияФормыОбзор(Кнопка)
Режим = РежимДиалогаВыбораФайла.Открытие;
ДиалогОткрытияФайла = новый ДиалогВыбораФайла(Режим);
ДиалогОткрытияФайла.ПолноеИмяФайла = "";
Фильтр = "Текст(*,xls)|*.xls";
ДиалогОткрытияФайла.Фильтр = Фильтр;
ДиалогОткрытияФайла.МножественныйВыбор = Ложь;
ДиалогОткрытияФайла.Заголовок = "Выберите файл";
Если ДиалогОткрытияФайла.Выбрать() Тогда

ПутьКФайлу=ДиалогОткрытияФайла.ПолноеИмяФайла;

КонецЕсли;
КонецПроцедуры

Процедура ДействияФормыЗаполнить(Кнопка)
//Если ПустаяСтрока(ИмяФайла) Тогда
//  Предупреждение("Для запуска обработки необходимо предварительно выбрать файл Microsoft Excel.");
//  Возврат;
//КонецЕсли;
имяФайла= ПутьКФайлу;
Попытка
// Загрузка Microsoft Excel
Состояние("Загрузка Microsoft Excel...");
ExcelПриложение = Новый COMОбъект("Excel.Application");
Исключение
Сообщить("Ошибка при загрузке Microsoft Excel." + Символы.ПС + ОписаниеОшибки(), СтатусСообщения.Внимание);
Возврат;
КонецПопытки;

Попытка
// Открытие файла Microsoft Excel
Состояние("Открытие файла Microsoft Excel...");
ExcelФайл = ExcelПриложение.WorkBooks.Open(имяФайла);
Исключение
Сообщить("Ошибка открытия файла Microsoft Excel." + ИмяФайла + Символы.ПС + ОписаниеОшибки(), СтатусСообщения.Внимание);
КонецПопытки;

Попытка
// Обработка файла Microsoft Excel
Состояние("Обработка файла Microsoft Excel...");
// Читаем данные первого листа книги
ExcelЛист = ExcelФайл.Sheets(1);

// Определить количество строк и колонок выбранного листа книги Excel
xlCellTypeLastCell = 11;
ExcelПоследняяСтрока = ExcelЛист.Cells.SpecialCells(xlCellTypeLastCell).Row;
ExcelПоследняяКолонка = ExcelЛист.Cells.SpecialCells(xlCellTypeLastCell).Column;
Исключение
Сообщить("Ошибка открытия листа №1 Microsoft Excel." + Символы.ПС + ОписаниеОшибки(), СтатусСообщения.Внимание);
// Закрыть COM соединение для экономии памяти
ExcelПриложение.Quit();
КонецПопытки;

// Создание описателя типов для таблицы значений
КЧ = Новый КвалификаторыЧисла(15,2);
КС = Новый КвалификаторыСтроки(300);
КД = Новый КвалификаторыСтроки(15);

Массив = Новый Массив;
Массив.Добавить(Тип("Строка"));
ОписаниеТиповС = Новый ОписаниеТипов(Массив, , КС);
Массив.Очистить();
Массив.Добавить(Тип("Число"));
ОписаниеТиповЧ = Новый ОписаниеТипов(Массив, , ,КЧ);
Массив.Добавить(Тип("Дата"));
ОписаниеТиповД = Новый ОписаниеТипов(Массив, , ,КД);

ТаблСпр = Новый ТаблицаЗначений;
// Очистить предыдущие значения
//ТаблицаДокумента.Очистить();
//ТаблицаДокумента.Колонки.Очистить();

// Создать колонки табличного документа
//ТаблСпр.Колонки.Добавить("БИН",ОписаниеТиповС,"БИН",15);
//ТаблСпр.Колонки.Добавить("Наименование",ОписаниеТиповС,"Наименование",300);
//
zz=0;
// Последовательное чтение строк с выбранного листа
Для Строка = 1 По ExcelПоследняяСтрока Цикл

// Обработка нажатия Ctrl + Break
ОбработкаПрерыванияПользователя();

// Добавить данные в табличную часть экранной формы
//если zz=0 тогда
Стр=ТаблСпр.Добавить();
//Стр.Номер = Строка;

Попытка
//ББ=ПреобразоватьВСтроку(ExcelЛист.Cells(Строка, 1).Value);
// ББ=ПреобразоватьЧисло(ExcelЛист.Cells(Строка, 1).Value);
ББ=ExcelЛист.Cells(Строка, 1).Value;
Стр.БИН = ББ;
Стр.Наименование = ExcelЛист.Cells(Строка, 2).Value;

//сообщить("zz="+zz+" "+строка);
zz=1;
Исключение
// Не редко происходит ошибка конвертации отдельной ячейки документа
Сообщить("Ошибка чтения строки файла Microsoft Excel." + Строка + Символы.ПС + ОписаниеОшибки(), СтатусСообщения.Внимание);
КонецПопытки;

// Отобразить информацию о ходе выполнения обработки
Состояние("Обработка файла Microsoft Excel : "
+ "строка " + Строка + " из " + ExcelПоследняяСтрока);

КонецЦикла;

// Закрыть COM соединение для экономии памяти
ExcelПриложение.Quit();

КонецПроцедуры

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
О! теперь другой колинкор... значит что-то умеете.

Для Каждого ТекСтрока Из ТаблСпр Цикл
    СпрОб=Справочники.<ИмяВашегоСправочника>.СоздатьЭлемент();
    СпрОб.Наименование=ТекСтрока.Наименование;
    СпрОб.БИН=ТекСтрока.БИН;
    СпрОб.Записать();
КонецЦикла

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
зачем что-то писать?
если в стандартной обработке ЗагрузкаДанныхИзТабличногоДокумента (название по памяти) есть режим загрузки в справочник.
надо только правильно настроить соответствие колонок Экселя и реквизитов справочника!
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
или у вас спортивный интерес самому написать обработку?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Абылайхан

  • **
  • Сообщений: 70
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-02-25
  • Сайт: 
  • Профессия: Ученик 1С
О! теперь другой колинкор... значит что-то умеете.


Спасибо, получилось)
Добавлено: 22 Июл 2015, 06:39

зачем что-то писать?
если в стандартной обработке ЗагрузкаДанныхИзТабличногоДокумента (название по памяти) есть режим загрузки в справочник.
надо только правильно настроить соответствие колонок Экселя и реквизитов справочника!

Да я бы с радостью использовал, если бы знал что такая обработка есть) Кстати не нашел что-то такой обработки( Видите ли недостаток знаний приходится замещать копипастированием чужого кода и переделывания)

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Диски ИТС не приходят?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Абылайхан

  • **
  • Сообщений: 70
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-02-25
  • Сайт: 
  • Профессия: Ученик 1С
Диски ИТС не приходят?

Спасибо, я недавно начал заниматься 1С, буду иметь ввиду.


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4293
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5552
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5890
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4370
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1980
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
181 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 771
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal