Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 06:16
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Регистр накоплений - себестоимость, не записываются движения документа "Реализация товаров"  (Прочитано 2840 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ekaterinka87

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-07-14
  • Сайт: 
  • Профессия: Программист 1С
Всем доброго времени суток. Попробую объяснить ситуацию.
По обучающим урокам создается регистр накоплений - Себестоимость товаров. Регистраторы - Документы: "Поступление товаров" и "Реализация товаров". В "Поступление товаров" - движения/коструктор/добавляется регистр (приход), заполняется табличная часть и все в порядке. А вот по "Реализация" - в модуле объекта в процедуре - ОбработкаПроведения создается "Конструктор запроса с обработкой результата", затем код дописывается вручную и при проведении докуменда - реализация - в регистраторе должны появиться данные. Они не появляются. Вот какой код используется в уроках - и там все работает.
Цитировать
Процедура ОбработкаПроведения(Отказ, Режим)
   //Тут сначала идут другие регистры

   Движения.СебестоимостьТоваров.Записывать = Истина;
            
   Запрос = Новый Запрос;
   Запрос.Текст =
         "ВЫБРАТЬ
         |   СебестоимостьТоваровОстатки.Номенклатура,
         |   СебестоимостьТоваровОстатки.СуммаОстаток КАК Сумма,
         |   СебестоимостьТоваровОстатки.КоличествоОстаток КАК Количество
         |ИЗ
         |   РегистрНакопления.СебестоимостьТоваров.Остатки(
         |         &МоментВремени,
         |         Номенклатура В
         |            (ВЫБРАТЬ
         |               РеализацияТоваровИУслугТовары.Товар
         |            ИЗ
         |               Документ.РеализацияТоваровИУслуг.Товары КАК РеализацияТоваровИУслугТовары
         |            ГДЕ
         |               РеализацияТоваровИУслугТовары.Ссылка = &Ссылка)) КАК СебестоимостьТоваровОстатки";
            
      Запрос.УстановитьПараметр("МоментВремени", МоментВремени());
      Запрос.УстановитьПараметр("Ссылка", Ссылка);
            
      РезультатЗапроса =  Запрос.Выпо лнить() ; //пробел в слове стоит, потому что слово выпол нить отображается какими то кодами тут =)
            
      ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать() ;
            
      Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
               
         Если ВыборкаДетальныеЗаписи.Количество <> 0 Тогда
            СебестоимостьЕдиницы = ВыборкаДетальныеЗаписи.Сумма / ВыборкаДетальныеЗаписи.Количество;
         Иначе
            СебестоимостьЕдиницы = 0;
         КонецЕсли;
               
         СтрокаТЧ = Товары.Найти(ВыборкаДетальныеЗаписи.Номенклатура, "Товар");
                  
         Движение = Движения.СебестоимостьТоваров.Добавить();
         Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
         Движение.Период = Дата;    
         Движение.Номенклатура = ВыборкаДетальныеЗаписи.Номенклатура;
         Движение.Количество = СтрокаТЧ.Количество;
         Движение.Сумма = СебестоимостьЕдиницы * СтрокаТЧ.Количество;
               
      КонецЦикла;
      КонецЕсли;
КонецПроцедуры
Документы "Поступление" отображаются (все функции - регистр накоплений - себестоимость товаров):

Документы "Реализация" проводятся. но :
http://s008.radikal.ru/i304/1507/70/52f1df48e0d2.jpg

1С:Предприятие 8.3, учебная версия (8.3.5.1248)
Учебные лекции ведутся на 1С:Предприятие 8.2

Код скопировала с лекции точно. Проверила несколько раз.
Подскажите пожалуйста, что не так?:dfbsdfbsdf:

Поняла пока только то, что не работает цикл Пока. По отладке видно как шагая (F10) по коду в цикл не заходит - сразу на конец прыгает красный кружок.

Не буду удалять тему, но сразу после наисания на форум - оно заработало :xfbnsdfb: Честное слово, ничего не меняла и не переделывала.


Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
Шайтан 1С машина.
на самом деле в 1С есть такие странные, не прозрачные вещи, которые можно копать долго долго, но проще написать по другому.
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн Luzer1C

  • ****
  • Сообщений: 411
  • РЕПУТАЦИЯ: 41
  • КПД: 10%
  • Регистрация: 2014-02-17
  • Сайт: 
  • Профессия: Программист 1С
Может в цикле добавить ещё одну строчку?
Движение.Записывать = Истина;
Помочь мне очень сложно. Но можно.
Помогаю просто так...
Матёрый разработчик УПП + Бит Финанс

Оффлайн ferrari314

  • ***
  • Сообщений: 174
  • РЕПУТАЦИЯ: 6
  • КПД: 3%
  • Главное - не есть желтый снег.
  • Регистрация: 2015-02-09
  • Сайт: 
Движение.Записать();
Luzer1C, опередил.
Да и выборку если пустая, попробуйте: Выборка = Запрос.Выполнить().Выгрузить();


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4489
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15970
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4212
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 646
Последний ответ 10 Май 2017, 20:44
от ilnur75
Заполнение столбца табличной части документа по умолчанию и выборка из табличной части.

Автор marshalbratskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1598
Последний ответ 25 Май 2016, 19:38
от marshalbratsk

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
62 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 233
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal