Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 11:38
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: День  (Прочитано 488 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн 1cwiki

  • Модератор
  • *****
  • Сообщений: 8287
  • РЕПУТАЦИЯ: 12
  • КПД: 0%
  • Регистрация: 2014-08-05
  • Сайт: 
  • Профессия: Программист 8.1
День
« Первое сообщение: 19 Июл 2015, 12:38 »
Раздел:
Глобальный контекст
Подразделы:
Функции работы со значениями типа Дата
День (Day)
Синтаксис:

День(<Дата>)
Параметры:

<Дата> (обязательный)

Тип: Дата.
Исходная дата.
Возвращаемое значение:

Тип: Число.
День в указанной дате.
Описание:

Определяет календарный день в указанной дате.

Доступность:

Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение, мобильное приложение(клиент), мобильное приложение(сервер).
Пример:

Процедура ПолучитьСтажЗаПериод(Знач ДатаОкончанияПериода, 
            Знач ДатаНачалаПериода,
            Лет=0, Месяцев=0, Дней=0) Экспорт
    Если ДатаОкончанияПериода >= ДатаНачалаПериода тогда
        Лет1 = Год(ДатаОкончанияПериода);
        Месяцев1 = Месяц(ДатаОкончанияПериода);
        Если НачалоДня(ДатаОкончанияПериода) <> НачалоДня(КонецМесяца(ДатаОкончанияПериода)) Тогда
            Дней1 = День(ДатаОкончанияПериода);
        Иначе
            Дней1 = 30;//В каждом месяце ровно 30 дней
        КонецЕсли;     

        Лет2 = Год(ДатаНачалаПериода);
        Месяцев2 = Месяц(ДатаНачалаПериода);
        Если НачалоДня(ДатаНачалаПериода) <> НачалоДня(КонецМесяца(ДатаНачалаПериода)) Тогда
            Дней2 = День(ДатаНачалаПериода);
        Иначе
            Дней2 = 30;//В каждом месяце ровно 30 дней
        КонецЕсли;

        Лет = Лет1 - Лет2;
        Месяцев = Месяцев1 - Месяцев2;
        Дней = Дней1 - Дней2 + 1; //1 день на увольнение
    Иначе
        Лет = 0;
        Месяцев = 0;
        Дней = 0;
    КонецЕсли;   
КонецПроцедуры //ПолучитьСтажЗаПериод


Теги:
 

Добрый день Необходимо на основании типовой конфигурации бухгалтерии сделать обработку, которая будет переносить остатки со счета расчетов 62.01 с одной организации в документ ввода начальных

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 223
Последний ответ 18 Авг 2017, 11:57
от ZSS
Перенос контактов в "нет в базе" на следующий день.

Автор IsodemosРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1745
Последний ответ 25 Июн 2014, 16:28
от Isodemos
Добрый день! В ЗУП 8.3 не записывает производственный календарь за 2012, ставлю 2012 а сохраняется как 2016

Автор КодексРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 909
Последний ответ 28 Июн 2016, 15:24
от pavl_vs
Если компания в один день продала или купила товар у разных поставщиков, она может составить сводную счет-фактуру

Автор newsРаздел Новости

Ответов: 0
Просмотров: 1254
Последний ответ 14 Янв 2015, 14:48
от news
Физлицо может провести регистрацию ИП и приобрести патент в один день и работать по ПСН до конца календарного года

Автор newsРаздел Новости

Ответов: 0
Просмотров: 996
Последний ответ 13 Май 2014, 11:41
от news

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
181 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 1030
  • Точка Скрытых: 0
  • Точка Пользователей: 15
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal