Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 04:47
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: ИНН организации задан неверно!  (Прочитано 7623 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн хайрулло

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-09-22
  • Сайт: 
1С 8.1 Бухгалтерия предприятия ввожу свою ИНН организации "630010546" а там ошибка ИНН организации задан нерверно!
Гляжу в модул а там такое нимойму. Как делать что мое пошло.Зарание спасибо..
// Проверяет соответствие ИНН требованиям
// Параметры:
//      ИНН - строка - проверяемый индивидуальный номер налогоплательщика,
//      ВладелецИНН - ПеречислениеСсылка.ЮрФизЛицо - тип владельца ИНН: физлицо или юрлицо
Функция ИННСоответствуетТребованиям(Знач ИНН, ВладелецИНН) Экспорт

   ИНН = СокрЛП(ИНН);
   ДлинаИНН =  СтрДлина(ИНН);

   Если НЕ ОбщегоНазначения.ТолькоЦифрыВСтроке(ИНН) Тогда
      Возврат Ложь;
   КонецЕсли;

   Если ДлинаИНН = 10  и ВладелецИНН = Перечисления.ЮрФизЛицо.ЮрЛицо Тогда

      КонтрольнаяСумма = 0;

      Для Н = 1 По 9 Цикл

         Если      Н = 1 Тогда
            Множитель = 2;
         ИначеЕсли Н = 2 Тогда
            Множитель = 4;
         ИначеЕсли Н = 3 Тогда
            Множитель = 10;
         ИначеЕсли Н = 4 Тогда
            Множитель = 3;
         ИначеЕсли Н = 5 Тогда
            Множитель = 5;
         ИначеЕсли Н = 6 Тогда
            Множитель = 9;
         ИначеЕсли Н = 7 Тогда
            Множитель = 4;
         ИначеЕсли Н = 8 Тогда
            Множитель = 6;
         ИначеЕсли Н = 9 Тогда
            Множитель = 8;
         КонецЕсли;
         
         Цифра = Число(Сред(ИНН,Н,1));
         КонтрольнаяСумма = КонтрольнаяСумма + Цифра * Множитель;
         
      КонецЦикла;
      
      КонтрольныйРазряд = (КонтрольнаяСумма %11) %10;
      
      Если КонтрольныйРазряд <> Число(Сред(ИНН,10,1)) Тогда
         Возврат Ложь;
      КонецЕсли;
      
   ИначеЕсли ДлинаИНН =12 и ВладелецИНН = Перечисления.ЮрФизЛицо.ФизЛицо Тогда
      
      КонтрольнаяСумма11 = 0;
      КонтрольнаяСумма12 = 0;
      
      Для Н=1 По 11 Цикл
         
         // Расчет множителя для 11-го и 12-го разрядов
         Если Н = 1 Тогда
            Множитель11 = 7;
            Множитель12 = 3;
         ИначеЕсли Н = 2 Тогда
            Множитель11 = 2;
            Множитель12 = 7;
         ИначеЕсли Н = 3 Тогда
            Множитель11 = 4;
            Множитель12 = 2;
         ИначеЕсли Н = 4 Тогда
            Множитель11 = 10;
            Множитель12 = 4;
         ИначеЕсли Н = 5 Тогда
            Множитель11 = 3;
            Множитель12 = 10;
         ИначеЕсли Н = 6 Тогда
            Множитель11 = 5;
            Множитель12 = 3;
         ИначеЕсли Н = 7 Тогда
            Множитель11 = 9;
            Множитель12 = 5;
         ИначеЕсли Н = 8 Тогда
            Множитель11 = 4;
            Множитель12 = 9;
         ИначеЕсли Н = 9 Тогда
            Множитель11 = 6;
            Множитель12 = 4;
         ИначеЕсли Н = 10 Тогда
            Множитель11 = 8;
            Множитель12 = 6;
         ИначеЕсли Н = 11 Тогда
            Множитель11 = 0;
            Множитель12 = 8;
         КонецЕсли;
         
         Цифра = Число(Сред(ИНН,Н,1));
         КонтрольнаяСумма11 = КонтрольнаяСумма11 + Цифра * Множитель11;
         КонтрольнаяСумма12 = КонтрольнаяСумма12 + Цифра * Множитель12;
         
      КонецЦикла;
      
      КонтрольныйРазряд11 = (КонтрольнаяСумма11 %11) %10;
      КонтрольныйРазряд12 = (КонтрольнаяСумма12 %11) %10;
      
      Если КонтрольныйРазряд11 <> Число(Сред(ИНН,11,1))
         ИЛИ КонтрольныйРазряд12 <> Число(Сред(ИНН,12,1)) Тогда
         Возврат Ложь;
      КонецЕсли;
      
   Иначе
      
      Возврат Ложь;
      
   КонецЕсли;
   
   Возврат Истина;
   
КонецФункции

// Проверяет соответствие ИНН требованиям.
// Используется в тех случаях, когда невозможно определить тип владельца ИНН.
// Во всех остальных случаях следует использовать функцию ИННсоответствуетТребованиям(Знач ИНН, ВладелецИНН)
// Параметры:
//      ИНН - строка - проверяемый индивидуальный номер налогоплательщика
Функция ИННСоответствуетТребованиямБезТипа(Знач ИНН) Экспорт
   
   ИННСтр = СокрЛП(ИНН);
   ДлинаИНН =  СтрДлина(ИННСтр);
   
   Если ДлинаИНН = 10 Тогда
      ВладелецИНН = Перечисления.ЮрФизЛицо.ЮрЛицо;
   ИначеЕсли ДлинаИНН = 12 Тогда
      ВладелецИНН = Перечисления.ЮрФизЛицо.ФизЛицо;
   Иначе
      Возврат Ложь;
   КонецЕсли;
   
   Возврат ИННСоответствуетТребованиям(ИНН, ВладелецИНН);
   
КонецФункции

   


Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
В обеих функциях вариации длины ИНН 10 и 12 символов. А у тебя 9. Вот они и возвращают не соответствие.
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать


Теги:
 

Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 267
Последний ответ 12 Окт 2017, 14:02
от wise
Синхронизация подразделений и подразделений организации

Автор a.nikulnikovaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 819
Последний ответ 27 Июн 2016, 13:16
от Kironten
Добрый день Необходимо на основании типовой конфигурации бухгалтерии сделать обработку, которая будет переносить остатки со счета расчетов 62.01 с одной организации в документ ввода начальных

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 223
Последний ответ 18 Авг 2017, 11:57
от ZSS
Не могу найти в 1С8.3 справочник "Организации"

Автор ГюзельРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 13607
Последний ответ 17 Сен 2014, 11:18
от Гюзель
Отчет "Списки сотрудников организации" ЗУП

Автор НовенькаяРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2313
Последний ответ 28 Ноя 2014, 08:36
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 230
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal