Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Сен 2020, 19:48
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Новичок. Процедура ОбработкаПроведения()  (Прочитано 7206 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Nodir2525

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-09-22
  • Сайт: 
У меня кроме этого на Конфигурации ничего нету!!!
Конфигурация
- Справочники
- Контрагент      
- Фамилия  - Свойства Реквизита(Периодический, Изменяется Документами)               
- Имя
- Отчество
- ДокументНомер
------------------------------------
Данный вожу через Документ ВВодНовыхКлиентов.Реквизиты(Фамилия,Имя,Отчество,ДокументНомер)
Модуль Документа- Документ.ВводНовыхКлиентов
---------------------------
Процедура ОбработкаПроведения()
СпрК=СоздатьОбъект("Справочник.Контрагент");
СпрК.Новый();
СпрК.Фамилия=Фамилия;
СпрК.Имя=Имя;
СпрК.Отчество=Отчество;
СпрК.ДокументНомер=ДокументНомер;
СпрК.ДокументДатаВыдачи=ДокументДатаВыдачи;
СпрК.ДокументКемВыдан=ДокументКемВыдан;
СпрК.Наименование=СокрЛП(СпрК.Фамилия)+" "+СокрЛП(СпрК.Имя)+" "+СокрЛП(СпрК.Отчество);
СпрК.Записать();
КонецПроцедуры
-----------------------------------------
Но У меня база выдает ошибку!!!
СпрК.Записать();
{Документ.ВводНовыхКлиентов.Модуль Документа(14)}: Не определена дата! Элемент не может быть записан! :dfbsdfbsdf:
------------------------------------------------
Что Я хочу!!!
Данный будит водится через Документ-ВводНовыхКлиентов и изменятся будить только Документ-ИзменениеДанныхКлиентов.



Оффлайн Tatitutu

СпрК.ИспользоватьДату(ДатаДок); например это почему выдается ошибка
только вот код проведения немного странноватенький
что будет если Вы сделаете документ непроведенным и заново проведете ?
то справочник начнет засорятся и задваиваться
нужно как минимум делать проверку на наличие такого элемента

*  MAGAZKA - лучшая программа для розничного магазина (с) *

Оффлайн Nodir2525

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-09-22
  • Сайт: 
Мне надо добавит-? "СпрК.ИспользоватьДату(ДатаДок);"

Оффлайн Tatitutu

СпрК=СоздатьОбъект("Справочник.Контрагент");
СпрК.ИспользоватьДату(ДатаДок);
СпрК.Новый();

*  MAGAZKA - лучшая программа для розничного магазина (с) *

Оффлайн Nodir2525

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-09-22
  • Сайт: 
СпрК=СоздатьОбъект("Справочник.Контрагент");
СпрК.ИспользоватьДату(ДатаДок);
СпрК.Новый();

Спасибо!!! Работает!!!
Но. У меня опят Вопрос?
Если отменит проведение и опят проводит документ, тогда у меня Справочник-Контрагенте дублируется. Что добавит, чтобы повторно не создавался.

Оффлайн Tatitutu

именно про это я тебе и говорил
Цитировать
то справочник начнет засорятся и задваиваться
поставь проверку
(но опять же говорю ,создавать новые элементы при проведение - это не есть хорошо!!!)

Процедура ОбработкаПроведения()
СпрК=СоздатьОбъект("Справочник.Контрагент");
НовНаименование=СокрЛП(СпрК.Фамилия)+" "+СокрЛП(СпрК.Имя)+" "+СокрЛП(СпрК.Отчество);
Если СпрК.НайтиПоНаименованию(НовНаименование,0,1)=0 Тогда
СпрК.Новый();
СпрК.Фамилия=Фамилия;
СпрК.Имя=Имя;
СпрК.Отчество=Отчество;
СпрК.ДокументНомер=ДокументНомер;
СпрК.ДокументДатаВыдачи=ДокументДатаВыдачи;
СпрК.ДокументКемВыдан=ДокументКемВыдан;
СпрК.Наименование=НовНаименование;
СпрК.Записать();
КонецЕсли;
КонецПроцедуры

*  MAGAZKA - лучшая программа для розничного магазина (с) *


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
72 Сообщений
LexaK
33 Сообщений
oooo800
32 Сообщений
Дмитрий Джей Дмитрий Джей
28 Сообщений
IL2016
25 Сообщений
antoneus antoneus
21 Сообщений
DmitriyF DmitriyF
18 Сообщений
Ann_
16 Сообщений
SoOliateR
15 Сообщений
мадам брошкина
13 Сообщений

* Кто онлайн

  • Точка Гостей: 296
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal