Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 05:25
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Некорректное открытие текстового файла  (Прочитано 1055 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн gamograff

  • *
  • Сообщений: 27
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2015-07-16
  • Сайт: 
  • Профессия: Программист 1С
Добрый день. Процедура должна открывать файл .txt и обрабатывать текст. Сам файл находит правильно, но при попытке открыть выдаётся ошибка:
ТФ.Открыть(Запр);
{Глобальный модуль(49)}: Неверное имя файла!
При записи вместо "Запр" полного пути также не открывается. На 7.7 совсем недавно, поэтому прошу прощения за возможно глупый вопрос.
	фс.УстТекКаталог("C:\Message"); 

Запр = фс.НайтиПервыйФайл("Запрос*.txt");

Пока фс.СуществуетФайл (Запр) = 1 цикл
 
сообщить(Запр);
                         
  ТФ = СоздатьОбъект ("Текст");

  ТФ.Открыть(Запр);
 
  СтрФайла = СтрПолучитьСтроку(ТФ,1) + СтрПолучитьСтроку(ТФ,2) + СтрПолучитьСтроку(ТФ,3);
 
  сообщить(СтрФайла); //здесь выводится только слово "Текст"
 
КК = Найти (СтрФайла, "Код клиента") + 2;
КФ = Найти (СтрФайла, "Код фирмы") + 2;
КТ = Найти (СтрФайла, "Код товара") + 2;

КодФирмы   = Сред(СтрФайла, КФ, 4);
КодКлиента = Сред(СтрФайла, КК, 4);
КодТовара  = Сред(СтрФайла, КТ, 4);
                                 
Результат = глСоздатьНовыйСчет(КодФирмы, КодКлиента, КодТовара);

КодПисьма = Сред(Запр, 7, 15);
                         
ТФ.ДобавитьСтроку(Результат);
ТФ.Записать("Счёт" + КодПисьма + ".txt"); //Этот файл не записывается, мне кажется, из-за некорректного открытия "Запр"

фс.ПереименоватьФайл(Запр,"$"+Запр, 1);

  Запрос = фс.НайтиСледующийФайл();

  КонецЦикла;


Оффлайн fipolaz

  • *
  • Сообщений: 47
  • РЕПУТАЦИЯ: 8
  • КПД: 17%
  • Регистрация: 2015-03-29
    • Skype: fipolaz
  • Компания: ИП
  • Профессия: Программист 7.7
Процедура Сформировать()
ТФ=СоздатьОбъект("Текст");
ФС.УстТекКаталог("C:\Message");
Запр=ФС.НайтиПервыйФайл("Запрос*.txt");
Пока ФС.СуществуетФайл(Запр)=1 Цикл
// Сообщить(Запр);
  ТФ.Открыть(Запр);
  // СтрФайла=СтрПолучитьСтроку(ТФ,1) + СтрПолучитьСтроку(ТФ,2) + СтрПолучитьСтроку(ТФ,3);
  СтрФайла=ТФ.ПолучитьСтроку(1)+ТФ.ПолучитьСтроку(2)+ТФ.ПолучитьСтроку(3);
  // Сообщить(СтрФайла); //здесь выводится только слово "Текст"
  КК=Найти(СтрФайла,"Код клиента")+2;
КФ=Найти(СтрФайла,"Код фирмы")+2;
КТ=Найти(СтрФайла,"Код товара")+2;

КодФирмы   =Сред(СтрФайла,КФ,4);
КодКлиента =Сред(СтрФайла,КК,4);
КодТовара  =Сред(СтрФайла,КТ,4);
                                 
Результат=глСоздатьНовыйСчет(КодФирмы,КодКлиента,КодТовара);

КодПисьма = Сред(Запр,7,15);
                         
ТФ.ДобавитьСтроку(Результат);
ТФ.Записать("Счёт"+КодПисьма+".txt"); //Этот файл не записывается, мне кажется, из-за некорректного открытия "Запр"

ФС.ПереименоватьФайл(Запр,"$"+Запр,1);

// Запрос = фс.НайтиСледующийФайл();
Запр=ФС.НайтиСледующийФайл();
КонецЦикла;
КонецПроцедуры


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
27 Сообщений
Golickoff Golickoff
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 232
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal