Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 10:42
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проблемы с оператором Перем  (Прочитано 2752 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ekaterinka87

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-07-14
  • Сайт: 
  • Профессия: Программист 1С
Добрый день. Возникла такая очень странная проблема.
Есть 1с8.3 - учебная версия. В модуле управляемого приложения создается любой простейший код, например:

Перем СчастливоеЧисло;

Процедура УсловныеОператоры()
   
   Если СчастливоеЧисло=777 Тогда
      Сообщить("777");
   ИначеЕсли СчастливоеЧисло=999 Тогда
      Сообщить("999");
   Иначе
      Сообщить("Все пропало!");
   КонецЕсли;

КонецПроцедуры

СчастливоеЧисло=777

Не работает оператор "Перем" внутри процедуры. Если внутрь процедуры добавить  СчастливоеЧисло=777 - нужный ответ в 1с появится, если работать с Перем - ответ будет - Все пропало, то есть процедура не видит переменную.  Пробовала разные коды и везде такая проблема. Может кто сталкивался? Оператор то пустячный =( как такое может быть?


Оффлайн Luzer1C

  • ****
  • Сообщений: 411
  • РЕПУТАЦИЯ: 41
  • КПД: 10%
  • Регистрация: 2014-02-17
  • Сайт: 
  • Профессия: Программист 1С
Может сделать так?
Перем СчастливоеЧисло Экспорт;
Помочь мне очень сложно. Но можно.
Помогаю просто так...
Матёрый разработчик УПП + Бит Финанс

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
где вы эту процедуру вызываете?
запихнул вашу процедуру в модуль упр. прил.
нормально все, на входе у СчастливоеЧисло значение 777...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Может сделать так?
Перем СчастливоеЧисло Экспорт;

применительно к теме - не поможет.
вернее, отношения не имеет.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн ekaterinka87

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-07-14
  • Сайт: 
  • Профессия: Программист 1С
где вы эту процедуру вызываете?
запихнул вашу процедуру в модуль упр. прил.
нормально все, на входе у СчастливоеЧисло значение 777...

В модуле управляемого приложения. Просто повторяю все за видео уроками. Наверное баг с самой программой случился, потому что перед этим у меня учебная версия ругалась, что превышено количество подключений к ИБ, затем отошло, а оператор не работает

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
сходите к кому нибудь в бухгалтерию и испытайте на нормальной 1С )))

кстати что за платформа? версия?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн KrivosheevEV

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 35
  • КПД: 17%
  • Регистрация: 2014-01-20
  • Сайт: 
  • Профессия: Программист 1С
Добавьте в блок "Иначе":
Сообщить(СчастливоеЧисло);
Станет яснее.

Оффлайн ekaterinka87

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-07-14
  • Сайт: 
  • Профессия: Программист 1С
где вы эту процедуру вызываете?
запихнул вашу процедуру в модуль упр. прил.
нормально все, на входе у СчастливоеЧисло значение 777...

В модуле управляемого приложения. Просто повторяю все за видео уроками. Наверное баг с самой программой случился, потому что перед этим у меня учебная версия ругалась, что превышено количество подключений к ИБ, затем отошло, а оператор не работает

Поправка. Проверила то же на другом компьютере рядом. Не работает.
Может ли быть проблема в версии платформы ? Конфигурацию для обучения создаю новую пустую. :dfbsdfbsdf:
Добавлено: 15 Июл 2015, 09:50

сходите к кому нибудь в бухгалтерию и испытайте на нормальной 1С )))

кстати что за платформа? версия?

Учебная версия платформа 3,0, скачана с оф сайта. В видеоуроках тоже все делается на учебной версии но 2,0

Добавлено: 15 Июл 2015, 09:52

Добавьте в блок "Иначе":
Сообщить(СчастливоеЧисло);
Станет яснее.

****

Перем СчастливоеЧисло;

Процедура УсловныеОператоры()
   
   Если СчастливоеЧисло=777 Тогда
      Сообщить("777");
   ИначеЕсли СчастливоеЧисло=999 Тогда
      Сообщить("999");
   Иначе
      Сообщить("Все пропало!");
  КонецЕсли;
  Сообщить (СчастливоеЧисло);

КонецПроцедуры

УсловныеОператоры();
СчастливоеЧисло=777

Вот что выходит


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
8.3 в смысле?
а по точнее?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн ekaterinka87

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-07-14
  • Сайт: 
  • Профессия: Программист 1С
И кстати, в видеоуроке парень говорит, что это должно работать, но не запускает 1с и не показывает, работает ли оно у него. Этот код с "Перем":kmtu:
Добавлено: 15 Июл 2015, 09:56

8.3 в смысле?
а по точнее?

1С:Предприятие 8.3, учебная версия (8.3.5.1248)


Теги:
 

Закрытие 97 счета, проблемы с закрытием 97 счета в НУ

Автор LisenokkРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 6848
Последний ответ 20 Июн 2011, 20:39
от Lisenokk
БГУ - проблемы с отчетом "ЖурналОпераций0504071"

Автор burbonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4255
Последний ответ 12 Окт 2011, 12:42
от burbon
Управление торговлей и управление складом. Проблемы обмена данными.

Автор CabinetonlineРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3030
Последний ответ 12 Мар 2013, 12:54
от Slin
Обмен данными. Правила обмена данными. Проблемы с повторной выгрузкой.

Автор 1cdpРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 5354
Последний ответ 02 Авг 2011, 18:29
от 1cdp
С этого года УСН (доходы-расходы), проблемы с формированием книги, помогите.

Автор LapkaРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2399
Последний ответ 16 Фев 2013, 07:16
от SoloSpirit

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
172 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 859
  • Точка Скрытых: 0
  • Точка Пользователей: 11
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal