Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Июн 2018, 07:20
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Отбор работает некорректно  (Прочитано 728 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dart909

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-07-09
  • Сайт: 
  • Профессия: Разработчик 1С
Добрый день может кто подскажет.

&НаСервере
 Процедура  СделатьОтборПоПринятым()
         
     ТекОтбор = Список.Отбор.Элементы;
     ТекОтбор.Очистить();
     УсловиеОтбора = ТекОтбор.Добавить(тип("ЭлементОтбораКомпоновкиДанных"));
     УсловиеОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Статус");
     УсловиеОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.ВСписке;
     УсловиеОтбора.ПравоеЗначение = перечисления.СтатусСотрудника.Принят   ;   
 КонецПроцедуры   
 
 &НаСервере
Процедура  СделатьОтборПоУволенным()
   
     ТекОтбор = Список.Отбор.Элементы;
     ТекОтбор.Очистить();
     УсловиеОтбора = ТекОтбор.Добавить(тип("ЭлементОтбораКомпоновкиДанных"));
     УсловиеОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Статус");
     УсловиеОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
     УсловиеОтбора.ПравоеЗначение = перечисления.СтатусСотрудника.Уволен;   
 КонецПроцедуры   

&НаКлиенте
Процедура ОтобратьПринятых(Команда)
     Элементы.Посмотреть.ПодчиненныеЭлементы.ОтобратьПринятых.Пометка = Не Проверка;
     Проверка = Не Проверка;
     СделатьОтборПоПринятым();
     Если Элементы.Посмотреть.ПодчиненныеЭлементы.ОтобратьПринятых.Пометка = Ложь Тогда
         Список.Отбор.Элементы.Очистить()
     КонецЕсли;     
     Если Элементы.Посмотреть.ПодчиненныеЭлементы.ОтобратьПринятых.Пометка = Ложь И Элементы.Посмотреть.ПодчиненныеЭлементы.ОтобратьУволенных.Пометка = Ложь Тогда
          ОтменаОтбора(Команда)
     КонецЕсли     
 КонецПроцедуры


&НаКлиенте
Процедура ОтобратьУволенных(Команда)
    Элементы.Посмотреть.ПодчиненныеЭлементы.ОтобратьУволенных.Пометка = Не ПроверкаУволенных;
    ПроверкаУволенных = Не ПроверкаУволенных;
    СделатьОтборПоУволенным();
    Если Элементы.Посмотреть.ПодчиненныеЭлементы.ОтобратьУволенных.Пометка = Ложь И Элементы.Посмотреть.ПодчиненныеЭлементы.ОтобратьПринятых.Пометка = Ложь Тогда
         ОтменаОтбора(Команда)
    КонецЕсли     
КонецПроцедуры

Процедура ПриОткрытии(Отказ)
     
     Элементы.Посмотреть.ПодчиненныеЭлементы.ОтобратьПринятых.Пометка = Ложь;
     Проверка = Ложь;
     ПроверкаУволенных = Ложь;
 КонецПроцедуры

Как сделать, чтобы можно было сделать отбор и по принятым и по уволенным? и Соответственно отменять отбор по принятым или уволенным, а не полностью его очищать?


Оффлайн KrivosheevEV

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 35
  • КПД: 17%
  • Регистрация: 2014-01-20
  • Сайт: 
  • Профессия: Программист 1С
Обратить внимание на это:

&НаСервере
 Процедура  СделатьОтборПоПринятым()
         
     ТекОтбор = Список.Отбор.Элементы;
     ТекОтбор.Очистить();
     УсловиеОтбора = ТекОтбор.Добавить(тип("ЭлементОтбораКомпоновкиДанных"));
     УсловиеОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Статус");
     УсловиеОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.ВСписке;
     УсловиеОтбора.ПравоеЗначение = перечисления.СтатусСотрудника.Принят   ;   
 КонецПроцедуры


Теги:
 

Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 688
Последний ответ 21 Сен 2017, 10:33
от Insider
Программный отбор в "Документы"

Автор SeolkinРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4590
Последний ответ 06 Окт 2012, 18:08
от Seolkin
Отбор при "быстром выборе"

Автор Gregory78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3788
Последний ответ 15 Фев 2015, 12:13
от Gregory78
Не работает структура подчиненности документов "Требование-накладная" и "Передач

Автор sv_stas_svРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 4393
Последний ответ 10 Мар 2011, 07:36
от sv_stas_sv
Отбор по номенклатуре в отчете "ВЕдомость выдачи мц"

Автор notaSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 2972
Последний ответ 08 Авг 2015, 15:40
от ppkmlite

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
125 Сообщений
AIFrame AIFrame
125 Сообщений
alexandr_ll
59 Сообщений
pavl_vs
50 Сообщений
alex0402
30 Сообщений
buketov.av buketov.av
27 Сообщений
ilyay ilyay
25 Сообщений
magnifico61
21 Сообщений
wise wise
20 Сообщений
trialex3
15 Сообщений

* Кто онлайн

  • Точка Гостей: 217
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal