Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 16:50
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Перенос справочника Склад (КД2)  (Прочитано 1933 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн gliokker

  • ***
  • Сообщений: 231
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-04-30
  • Сайт: 
  • Профессия: Ученик 1С
Всем привет переношу справочник склады из 7-ки в ут 10.3
Мне нужно условие.
В ПКС источника нету, приёмник ВидСклада(это реквизит справочника Склады)
перед выгрузкой пишу
Если Источник.РозничныйСклад = 1 ТОгда
   Значение = ПеречислениеСсылка.ВидыСкладов.Розничный;
Иначе
   Значение = ПеречислениеСсылка.ВидыСкладов.Оптовый;
КонецЕсли;
РозничныйСклад это реквизит справочка в 7-ке, Тип число.
При выгрузке выдаёт ошибку
Ошибка получения значения свойства объекта
   Объект: Хранение НБ ООО  "НФПревент", свойство: ВидСклада.
Подскажите что делаю не так?



Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Выражение="ПеречислениеСсылка.ВидыСкладов.Розничный";

Оффлайн gliokker

  • ***
  • Сообщений: 231
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-04-30
  • Сайт: 
  • Профессия: Ученик 1С
Выражение="ПеречислениеСсылка.ВидыСкладов.Розничный";
Не помогло

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Сорри.
Выражение="Перечисления.ВидыСкладов.Розничный";

Оффлайн gliokker

  • ***
  • Сообщений: 231
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-04-30
  • Сайт: 
  • Профессия: Ученик 1С
Сорри.
Выражение="Перечисления.ВидыСкладов.Розничный";
Если Источник.РозничныйСклад = 1 ТОгда
   Выражение = "Перечисления.ВидыСкладов.Розничный";
Иначе
   Выражение = "Перечисления.ВидыСкладов.Оптовый";
КонецЕсли;
вот что получилось, ошибка та же, не чего не изменилось, пробывал так
Если Источник.РозничныйСклад = 1 тогда
Значение = "Розничный";
Иначе
Значение= "Оптовый";
КонецЕсли;
Тоже не работает, пол дня с этой ерундой сижу.

Добавлено: 13 Июл 2015, 17:28

Ещё раз, ПКО Склады, источник-СправочникиСклады,Приёмник-СправочникСклады
Для этого ПКО Создаю ПКС
Источник пусто, приёмник ВидСклада(Реквизит справочника Склады, тип перечисленияВидыСкладов)
ПРИ выгрузки код
Если Источник.РозничныйСклад = 1 ТОгда
   Выражение = "Перечисления.ВидыСкладов.Розничный";
Иначе
   Выражение = "Перечисления.ВидыСкладов.Оптовый";
КонецЕсли;
Может где нибудь надо галочку какую нибудь поставить?

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Как бы прям теряюсь в догадках. у меня подобное работает на ура (см. скрин)
Добавлено: 13 Июл 2015, 17:37

Вы код обработки 7.7 не забываете менять?

Оффлайн gliokker

  • ***
  • Сообщений: 231
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-04-30
  • Сайт: 
  • Профессия: Ученик 1С
Как бы прям теряюсь в догадках. у меня подобное работает на ура (см. скрин)
Добавлено: 13 Июл 2015, 17:37

Вы код обработки 7.7 не забываете менять?
Всё меняю
Вот скрины, я сам не понимаю почему не работает

Добавлено: 13 Июл 2015, 17:49

Как бы прям теряюсь в догадках. у меня подобное работает на ура (см. скрин)
Добавлено: 13 Июл 2015, 17:37

Вы код обработки 7.7 не забываете менять?
Всё меняю
Вот скрины, я сам не понимаю почему не работает
Возможно надо ещё и 3-е значение добавить, в перечисление 3 значения

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Стоп! так у вас же ошибка отсутствия функции!!! Естественно ничего не выгружает. Разгребайте куда делась функция.
Какой релиз КД?
Выгружать коды из 7.7 в 8 - лучше не стоит.

Оффлайн gliokker

  • ***
  • Сообщений: 231
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-04-30
  • Сайт: 
  • Профессия: Ученик 1С
Стоп! так у вас же ошибка отсутствия функции!!! Естественно ничего не выгружает. Разгребайте куда делась функция.
Какой релиз КД?
Выгружать коды из 7.7 в 8 - лучше не стоит.
Конвертация данных, редакция 2.1 (2.1.8.2)

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Новье. Попробуйте прописать ручками эту функцию,хотя на самом деле странно, что она отсутствуют. Судя по хелпу обрпботчиков, данный обработчик должен вызываться как для 7.7 так и для 8.


Теги:
 

Как вызвать "Анализ субконто" из справочника "Контрагенты"

Автор EnigManРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 6489
Последний ответ 06 Фев 2012, 10:46
от cska-fanat-kz
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4195
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 620
Последний ответ 10 Май 2017, 20:44
от ilnur75
Как сделать, чтобы поле в документе имело тип "ссылка на поле справочника"?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2029
Последний ответ 05 Мар 2017, 14:36
от Igor100500
Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 266
Последний ответ 12 Окт 2017, 14:02
от wise

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
168 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
48 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 788
  • Точка Скрытых: 0
  • Точка Пользователей: 13
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal