Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
19 Ноя 2018, 19:13
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Подскажите,пожалуйста,в чём может быть ошибка  (Прочитано 2016 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Glikeria

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 3
  • КПД: 7%
  • Регистрация: 2010-08-11
  • Сайт: 
В чём может быть ошибка в процедуре?При проверке оказалось,что она неправильно вычитает.Спасибо.
роцедура НадписьВычитаниеРеглНажатие(Элемент)
             
         Запрос=Новый Запрос;
         Запрос.Текст=
         "ВЫБРАТЬ
         |    ВзаиморасчетыСРаботникамиОрганизацийОстатки.Физлицо,
         |    ВзаиморасчетыСРаботникамиОрганизацийОстатки.СуммаВзаиморасчетовОстаток КАК СуммаВзаиморасчетов
         |ИЗ
         |    РегистрНакопления.ВзаиморасчетыСРаботникамиОрганизаций.Остатки(&Дата, &МассивФизлицо) КАК ВзаиморасчетыСРаботникамиОрганизацийОстатки";
         Запрос.УстановитьПараметр("Дата",Дата);
         МассивФизлицо=Зарплата.ВыгрузитьКолонку("Физлицо");
         Запрос.УстановитьПараметр("МассивФизлицо",МассивФизлицо);
         Результат=Запрос.Выполнить();
         ВыборкаПоСотрудникам=Результат.Выбрать();
         Ответ=Вопрос("Вычесть регламетированную сумму из общей? ",РежимДиалогаВопрос.ДаНет);
         Если Ответ=КодВозвратаДиалога.Да Тогда
         Пока ВыборкаПоСотрудникам.Следующий() Цикл
         Для Каждого Строка Из Зарплата Цикл
             Если  Строка.Физлицо=ВыборкаПоСотрудникам.Физлицо Тогда
                 Строка.Сумма= Строка.Сумма-ВыборкаПоСотрудникам.СуммаВзаиморасчетов;
             КонецЕсли;
             КонецЦикла;
         КонецЦикла;
     КонецЕсли;
 КонецПроцедуры


Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
На первый взгляд все хорошо. Конкретней - где не так считает, с конкретными остатками и цифрами. Отладку смотрели? Что в запросе получается. Как вариант - может быть нужно устанавливать параметр КонецДня(Дата) вместо Дата
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн Glikeria

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 3
  • КПД: 7%
  • Регистрация: 2010-08-11
  • Сайт: 
Когда я убираю параметры процедура вычитает нужную мне сумму,я проверяла.Если оставить параметры,то вычитаются сразу такая сумма,как та,которая указана в колонке Все платежи в расчётном листке организации.

Оффлайн Glikeria

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 3
  • КПД: 7%
  • Регистрация: 2010-08-11
  • Сайт: 
А почему при отладке запрос может оставаться пустым?

Оффлайн Vit1501

  • ****
  • Сообщений: 360
  • РЕПУТАЦИЯ: 60
  • КПД: 17%
  • Регистрация: 2010-06-05
  • Сайт: 
  • Профессия: Программист 1С
попробуй в ксловии поставить не знак равенства, а оператор "В".


Теги:
 

Ошибка "Неправильный псевдоним "Т.Ссылка" <<?>> Т.Ссылка как номенклатура"

Автор Андрей БулановРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 220
Последний ответ 13 Окт 2018, 21:51
от Андрей Буланов
При открытии обр-ки в "Предприятии" есть ошибка, а в "Отладке" нет

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 5327
Последний ответ 21 Сен 2011, 17:35
от proofet
ошибка "Невозможно обработать параметр "ПрофильПолномочийПользователя""

Автор lindeluРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 7103
Последний ответ 06 Июн 2012, 09:15
от lindelu
Синтаксическая ошибка "В" Номенклатура.Ссылка = <<?>> В ИЕРАРХИИ(&Ссылка)

Автор maskitoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 5111
Последний ответ 28 Апр 2014, 15:53
от maskito
УТ 10.3 При провеедении реализации выходит ошибка "состояние договора отличается от "договор есть, документы есть", документ подсвечивается серым цветом

Автор MilaZzerberРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 140
Последний ответ 25 Сен 2018, 13:32
от MilaZzerber

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
70 Сообщений
AIFrame AIFrame
64 Сообщений
wise wise
50 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
46 Сообщений
alexandr_ll
46 Сообщений
alex0402
44 Сообщений
BuhRust
28 Сообщений
andron81_81
24 Сообщений
byte777
21 Сообщений
LexaK
21 Сообщений

* Кто онлайн

  • Точка Гостей: 321
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal