Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 08:37
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Подскажите,пожалуйста,в чём может быть ошибка  (Прочитано 1792 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Glikeria

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 3
  • КПД: 7%
  • Регистрация: 2010-08-11
  • Сайт: 
В чём может быть ошибка в процедуре?При проверке оказалось,что она неправильно вычитает.Спасибо.
роцедура НадписьВычитаниеРеглНажатие(Элемент)
             
         Запрос=Новый Запрос;
         Запрос.Текст=
         "ВЫБРАТЬ
         |    ВзаиморасчетыСРаботникамиОрганизацийОстатки.Физлицо,
         |    ВзаиморасчетыСРаботникамиОрганизацийОстатки.СуммаВзаиморасчетовОстаток КАК СуммаВзаиморасчетов
         |ИЗ
         |    РегистрНакопления.ВзаиморасчетыСРаботникамиОрганизаций.Остатки(&Дата, &МассивФизлицо) КАК ВзаиморасчетыСРаботникамиОрганизацийОстатки";
         Запрос.УстановитьПараметр("Дата",Дата);
         МассивФизлицо=Зарплата.ВыгрузитьКолонку("Физлицо");
         Запрос.УстановитьПараметр("МассивФизлицо",МассивФизлицо);
         Результат=Запрос.Выполнить();
         ВыборкаПоСотрудникам=Результат.Выбрать();
         Ответ=Вопрос("Вычесть регламетированную сумму из общей? ",РежимДиалогаВопрос.ДаНет);
         Если Ответ=КодВозвратаДиалога.Да Тогда
         Пока ВыборкаПоСотрудникам.Следующий() Цикл
         Для Каждого Строка Из Зарплата Цикл
             Если  Строка.Физлицо=ВыборкаПоСотрудникам.Физлицо Тогда
                 Строка.Сумма= Строка.Сумма-ВыборкаПоСотрудникам.СуммаВзаиморасчетов;
             КонецЕсли;
             КонецЦикла;
         КонецЦикла;
     КонецЕсли;
 КонецПроцедуры


Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
На первый взгляд все хорошо. Конкретней - где не так считает, с конкретными остатками и цифрами. Отладку смотрели? Что в запросе получается. Как вариант - может быть нужно устанавливать параметр КонецДня(Дата) вместо Дата
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн Glikeria

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 3
  • КПД: 7%
  • Регистрация: 2010-08-11
  • Сайт: 
Когда я убираю параметры процедура вычитает нужную мне сумму,я проверяла.Если оставить параметры,то вычитаются сразу такая сумма,как та,которая указана в колонке Все платежи в расчётном листке организации.

Оффлайн Glikeria

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 3
  • КПД: 7%
  • Регистрация: 2010-08-11
  • Сайт: 
А почему при отладке запрос может оставаться пустым?

Оффлайн Vit1501

  • ****
  • Сообщений: 360
  • РЕПУТАЦИЯ: 60
  • КПД: 17%
  • Регистрация: 2010-06-05
  • Сайт: 
  • Профессия: Программист 1С
попробуй в ксловии поставить не знак равенства, а оператор "В".


Теги:
 

При открытии обр-ки в "Предприятии" есть ошибка, а в "Отладке" нет

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4527
Последний ответ 21 Сен 2011, 17:35
от proofet
ошибка "Невозможно обработать параметр "ПрофильПолномочийПользователя""

Автор lindeluРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 6082
Последний ответ 06 Июн 2012, 09:15
от lindelu
Синтаксическая ошибка "В" Номенклатура.Ссылка = <<?>> В ИЕРАРХИИ(&Ссылка)

Автор maskitoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4195
Последний ответ 28 Апр 2014, 15:53
от maskito
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8491
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 8558
Последний ответ 26 Апр 2012, 23:08
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
172 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 528
  • Точка Скрытых: 1
  • Точка Пользователей: 11
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal