Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 23:41
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Заполнение табличной части результатом запроса  (Прочитано 1508 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Абылайхан

  • **
  • Сообщений: 70
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-02-25
  • Сайт: 
  • Профессия: Ученик 1С
Есть такой запрос:
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ТиповойДвиженияССубконто.СубконтоДт1,
| ТиповойДвиженияССубконто.СубконтоКт1,
| ТиповойДвиженияССубконто.Сумма
|ИЗ
| РегистрБухгалтерии.Типовой.ДвиженияССубконто КАК ТиповойДвиженияССубконто
|ГДЕ
| ТиповойДвиженияССубконто.Период МЕЖДУ &ДатаНачала И &ДатаОкончания
| И ТиповойДвиженияССубконто.СчетДт.Родитель = &Счет";

Запрос.УстановитьПараметр("ДатаНачала", НачалоПериода);
Запрос.УстановитьПараметр("ДатаОкончания", КонецПериода);

Запрос.УстановитьПараметр("Счет", Счет);

Результат = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = Результат.Выбрать();

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
// Вставить обработку выборки ВыборкаДетальныеЗаписи


КонецЦикла;

как теперь мне заполнить Табл часть в этом документе данными из запроса?



Оффлайн KrivosheevEV

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 35
  • КПД: 17%
  • Регистрация: 2014-01-20
  • Сайт: 
  • Профессия: Программист 1С
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
    НоваяСтрока = ТаблицаЗначений.Добавить();
    НоваяСтрока.Параметр1 = ВыборкаДетальныеЗаписи.Параметр1;
    НоваяСтрока.Параметр2 = ВыборкаДетальныеЗаписи.Параметр2;
КонецЦикла;

Оффлайн BotMan

  • *
  • Сообщений: 45
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2014-06-05
  • Сайт: 
  • Профессия: Ученик 1С


    Пока ВыборкаДетальныеЗаписи.Следующий() =1 Цикл
    // Вставить обработку выборки ВыборкаДетальныеЗаписи
        тз.новаястрока();
        тз.статьязатрат = ТиповойДвиженияССубконто.СубконтоДт1;
        тз.поставщик = ТиповойДвиженияССубконто.СубконтоКт1;
        тз.сумма = ТиповойДвиженияССубконто.Сумма;       
    КонецЦикла;
Жми спасибо, если подсказал 8)

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Код: [Выделить]

    Пока ВыборкаДетальныеЗаписи.Следующий() =1 Цикл
    // Вставить обработку выборки ВыборкаДетальныеЗаписи
        тз.новаястрока();
        тз.статьязатрат = ТиповойДвиженияССубконто.СубконтоДт1;
        тз.поставщик = ТиповойДвиженияССубконто.СубконтоКт1;
        тз.сумма = ТиповойДвиженияССубконто.Сумма;       
    КонецЦикла;

Вооще молодец! Советуете использовать семерочный код в восьмерке?

Оффлайн Rasty

  • *****
  • Сообщений: 989
  • РЕПУТАЦИЯ: 139
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
А может
Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    |    ТиповойДвиженияССубконто.СубконтоДт1 КАК СтатьиЗатрат,
    |    ТиповойДвиженияССубконто.СубконтоКт1 КАК Поставщики,
    |    ТиповойДвиженияССубконто.Сумма
    |ИЗ
    |    РегистрБухгалтерии.Типовой.ДвиженияССубконто КАК ТиповойДвиженияССубконто
    |ГДЕ
    |    ТиповойДвиженияССубконто.Период МЕЖДУ &ДатаНачала И &ДатаОкончания
    |    И ТиповойДвиженияССубконто.СчетДт.Родитель = &Счет";

    Запрос.УстановитьПараметр("ДатаНачала", НачалоПериода);
    Запрос.УстановитьПараметр("ДатаОкончания", КонецПериода);

    Запрос.УстановитьПараметр("Счет", Счет);

     ВашаТЧ.Загрузить(Запрос.Выполнить().Выгрузить());

   
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)


Теги:
 

Из запроса не выводятся значения полей - выводятся пустые значения

Автор Alex1111Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 24
Просмотров: 12246
Последний ответ 14 Июн 2012, 17:44
от Alex1111
заполнение закладки "Материалы" в документе "Поступление из переработки"

Автор Sasa1CРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3597
Последний ответ 10 Июн 2013, 22:34
от Sasa1C
"Уникальность" строки таблиной части документа

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1951
Последний ответ 20 Авг 2014, 12:22
от has
Работа с табличной частью в документе. Или Работа с ШАПКОЙ документа

Автор gorbach178500Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3063
Последний ответ 30 Сен 2011, 20:01
от gorbach178500
Заполнение поля справочника из подчиненного справочника

Автор Space_minusРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 1268
Последний ответ 19 Авг 2016, 05:01
от Space_minus

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
51 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 189
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal