Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 02:29
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Автозаполнение табличной части документа  (Прочитано 6940 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Nostro51

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-07-09
  • Сайт: 
Здравствуйте, есть документ "цены на номенклатуру" и в нём реквизит "вид номенклатуры", как сделать так что бы при выборе вида номенклатуры, табличная часть документа автозаполнялась всей номенклатурой этого вида?


Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
ну это же элементарно! необходимо написать обработку/процедуру по заполнению табличной части.
пользователь выбирает "вид номенклатуры" и нажимает кнопку Заполнить.
Связанная с этой кнопкой процедура делает запрос к базе, получает в результате Номенклатуру с указанным Видом и помещает ее в табличную часть. Вот и все. :ooifh:
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн KrivosheevEV

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 35
  • КПД: 17%
  • Регистрация: 2014-01-20
  • Сайт: 
  • Профессия: Программист 1С
Или привязать эту обработку к событию поля формы.

Оффлайн Nostro51

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-07-09
  • Сайт: 
Я не знаю как написать процедуру, можете написать примерно как?

Оффлайн BotMan

  • *
  • Сообщений: 45
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2014-06-05
  • Сайт: 
  • Профессия: Ученик 1С
напишите устный пример чего вы хотите?

выбрали Номенклатуру (стулья)
нажали заполнить и заполнилась вся таблица из подраздела стулья?

стул деревянный
стул железный

так ?
Жми спасибо, если подсказал 8)

Оффлайн Nostro51

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-07-09
  • Сайт: 

Оффлайн BotMan

  • *
  • Сообщений: 45
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2014-06-05
  • Сайт: 
  • Профессия: Ученик 1С
процедура заполнить()
//элемент формы где вы выбираете группу номенклатуры пусть называется ЭлементФормы или идентификатор из диалогового окна формы.

СпрСотр = Справочники.Номенклатура;
ГруппаНоменклатуры = СпрСотр.НайтиПоНаименованию(ЭлементФормы);
Выборка = СпрСотр.Выбрать(ГруппаНоменклатуры);
Пока Выборка.Следующий() = 1 Цикл
   //действия с очередным элементом
   Сообщить(Выборка.Наименование);
 //или ТЗ.Наименование = Выборка.Наименование;
КонецЦикла;
конецпроцедуры

ну как то так, в общих чертах!
Жми спасибо, если подсказал 8)

Оффлайн Nostro51

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-07-09
  • Сайт: 
А как эту процедуру привязать к кнопке?

Оффлайн Rasty

  • *****
  • Сообщений: 989
  • РЕПУТАЦИЯ: 139
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
у кнопки есть такая штука как действие, в не пишите
Процедура Выполнить(Нажатие)
Заполнить();
КонецПроцедуры

процедура заполнить()
//элемент формы где вы выбираете группу номенклатуры пусть называется ЭлементФормы или идентификатор из диалогового окна формы.

СпрСотр = Справочники.Номенклатура;
ГруппаНоменклатуры = СпрСотр.НайтиПоНаименованию(ЭлементФормы);
Выборка = СпрСотр.Выбрать(ГруппаНоменклатуры);
Пока Выборка.Следующий() = 1 Цикл
   //действия с очередным элементом
   Сообщить(Выборка.Наименование);
 //или ТЗ.Наименование = Выборка.Наименование;
КонецЦикла;

Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн Nostro51

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-07-09
  • Сайт: 
Не могу разобраться как делать, посмотрите пожалуйста что не так в конфигурации


 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4486
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7760
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4792
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8559
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Фамилия руководителя в печатных формах документа "Акт сверки", "Акт об оказании"

Автор MKozzlikРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 7350
Последний ответ 03 Фев 2012, 17:27
от Dinah

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
61 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 154
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal