Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 14:01
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите разобраться с ошибками новичку.  (Прочитано 1059 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Bornito

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Доброго времени суток! Не так давно начал изучение 1С с вот этого вот курса:
http://nnm-club.me/forum/viewtopic.php?t=912111

Повторял всё за автором, но в один момент возникла ошибка, причину которой я найти так и не смог, и очень прошу помочь в этом разобраться, ибо теперь эта ошибка совершенно не дает мне покоя..

Сам код ДокументПриходнаяНакладная:ФормаДокумента:

&НаКлиенте
Процедура ТоварыЦенаПриИзменении(Элемент)
// Сумма = Количество * Цена для таблицы  ТОВАРЫ и выделенной строки
Элементы.Товары.ТекущиеДанные.Сумма = Элементы.Товары.ТекущиеДанные.Количество * Элементы.Товары.ТекущиеДанные.Цена; 
КонецПроцедуры


&НаКлиенте
Процедура ТоварыКоличествоПриИзменении(Элемент)
СтрокаРасчета = Элементы.Товары.ТекущиеДанные;
СтрокаРасчета.Сумма = СтрокаРасчета.Количество * СтрокаРасчета.Цена;
КонецПроцедуры

&НаКлиенте
Процедура ТоварыНоменклатураПриИзменении(Элемент)
СтрокаРасчета = Элементы.Товары.ТекущиеДанные;
СтрокаРасчета.Цена = ПолучитьЦену(СтрокаРасчета.Номенклатура);
ТоварыЦенаПриИзменении(Элемент);
КонецПроцедуры

&НаСервере
Функция ПолучитьЦену(НоменклатураИзДокумента)
СтруктураПоиска = Новый Структура();
СтруктураПоиска.Вставить("Номенклатура", НоменклатураИзДокумента);
СтруктураПоиска.Вставить("Контрагент", Объект.Контрагент);
СтруктураПоиска.Вставить("Договор", Объект.Договор);
РезультатПоиска=РегистрыСведений.ЦеныПоставщиков.Получить(СтруктураПоиска);
Возврат РезультатПоиска.Цена;

КонецФункции

Ошибка появляется при попытке изменить поле Номенклатура табличной части Приходной накладной:
"Поле объекта не обнаружено(Контрагент)"

В чем может быть проблема?

Конфигурацию прикладываю во вложения.

Заранее всем большое спасибо, кто решит помочь!

п.с. Если вдруг кто-то будет смотреть уроки - то код показывается в 3 файле, время 5:07


Оффлайн Kironten

  • *****
  • Сообщений: 906
  • РЕПУТАЦИЯ: 185
  • КПД: 20%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Скорее всего у Вас Контрагент и Договор добавлены как РеквизитыФормы, а не РеквизитыОбъекта.
Проще говоря, если раскроете дерево конфигурации, документ приходная накладная, то реквизитов контрагент и договор, Вы скорее всего в ней не обнаружите.

Оффлайн Bornito

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Скорее всего у Вас Контрагент и Договор добавлены как РеквизитыФормы, а не РеквизитыОбъекта.
Проще говоря, если раскроете дерево конфигурации, документ приходная накладная, то реквизитов контрагент и договор, Вы скорее всего в ней не обнаружите.

Благодарю за попытку помочь! Но оба реквизита есть..
http://s017.radikal.ru/i416/1507/93/290e300058ac.png

Оффлайн Kironten

  • *****
  • Сообщений: 906
  • РЕПУТАЦИЯ: 185
  • КПД: 20%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Странная конструкция.
Ну так где ваше вложение с конфигурацией?

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С

Оффлайн Bornito

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Ой, прошу прощения, в начальном сообщении не добавил-таки базу.

Добавляю сейчас. И еще раз спасибо, что пытаетесь помочь!

Оффлайн Kironten

  • *****
  • Сообщений: 906
  • РЕПУТАЦИЯ: 185
  • КПД: 20%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Ой, прошу прощения, в начальном сообщении не добавил-таки базу.

Добавляю сейчас. И еще раз спасибо, что пытаетесь помочь!

Названия реквизитов сравните
Контрагент <> Контрганет

Оффлайн Bornito

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Цитировать
Названия реквизитов сравните
Контрагент <> Контрганет

ай яй яй, вот я дундук, большое спасибо Вам за помощь! Даже стыдно как-то, что ошибка в опечатке.. :fdbsdfbsd:


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4295
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5554
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5892
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4378
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1981
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
156 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 275
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal