Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 05:28
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как вычесть регламентированную сумму из общей?  (Прочитано 1854 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Glikeria

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 3
  • КПД: 7%
  • Регистрация: 2010-08-11
  • Сайт: 
Здравствуйте!Подскажите,пожалуйста,как можно решить следующую проблему.Я написала следующую процедуру,для того,чтобы в документе ЗарплатаКВыплате из Суммы вычиталась регламентированная сумма из регистра накопления:
 Процедура НадписьВычитаниеРеглНажатие(Элемент)
         
       Запрос=Новый Запрос;
       Запрос.Текст=
       "ВЫБРАТЬ
       |   ВзаиморасчетыСРаботникамиОрганизаций.СуммаВзаиморасчетов КАК СуммаВзаиморасчетов,
       |   ВзаиморасчетыСРаботникамиОрганизаций.Физлицо КАК Физлицо
       |ИЗ
       |   РегистрНакопления.ВзаиморасчетыСРаботникамиОрганизаций КАК ВзаиморасчетыСРаботникамиОрганизаций
       |      ЛЕВОЕ СОЕДИНЕНИЕ Документ.ЗарплатаКВыплате.Зарплата КАК ЗарплатаКВыплатеЗарплата
       |      ПО ВзаиморасчетыСРаботникамиОрганизаций.Регистратор = ЗарплатаКВыплатеЗарплата.Ссылка";
       Результат=Запрос.Выгрузить();
       ВыборкаПоСотрудникам=Результат.Выбрать();
         Ответ=Вопрос("Вычесть регламетированную сумму из общей? ",РежимДиалогаВопрос.ДаНет);
    Если Ответ=КодВозвратаДиалога.Да Тогда
         
       Для Каждого Строка Из Зарплата Цикл
          Если  Строка.Физлицо=ВыборкаПоСотрудникам.Физлицо Тогда
             Строка.Сумма= Строка.Сумма-ВыборкаПоСотрудникам.СуммаВзаиморасчетов;
          КонецЕсли;
       КонецЦикла;
    КонецЕсли;
 КонецПроцедуры


Оффлайн Glikeria

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 3
  • КПД: 7%
  • Регистрация: 2010-08-11
  • Сайт: 
Но окзалось,что для регистра накопления ВзаиморасчетыСРаботникамиОрганизаций документ не является регистратором.Можно всё же как-нибудь сделать так,чтобы нужная мне сумма вычиталась?

Оффлайн ms

  • **
  • Сообщений: 60
  • РЕПУТАЦИЯ: 8
  • КПД: 13%
  • Регистрация: 2010-04-14
  • Сайт: 
наверно надо соединяться по физ.лицам

если хотите ответ, нужно правильно вопрос задать (какая конфа или структура данных участвующих в выборке, какая задача и т.д. и т.п.)

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Замечание по-мелочи - лучше уж в начале спрашивать, "Вычесть регламетированную сумму из общей? ", а потом уже выборку делать. А то может статься, выборка была зря...
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать


Теги:
 

Учитываем сумму торгового сбора при УСН "доходы"

Автор newsРаздел Новости

Ответов: 0
Просмотров: 464
Последний ответ 01 Апр 2016, 09:52
от news
"Платёжное поручение входящее" списывает большую сумму задолженности

Автор malaxitРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1382
Последний ответ 23 Окт 2014, 13:53
от malaxit
Какая категория индивидуальных предпринимателей может уменьшить единый «упрощенный» налог на всю сумму уплаченных «за себя» страховых взносов?

Автор newsРаздел Новости

Ответов: 0
Просмотров: 655
Последний ответ 28 Май 2015, 17:12
от news
Предприниматель, получающий доход свыше 300 тысяч рублей без наемных работников, может уменьшить сумму страховых отчислений

Автор newsРаздел Новости

Ответов: 0
Просмотров: 2999
Последний ответ 28 Мар 2014, 13:08
от news
Доход от продажи квартиры, купленной по ипотечному кредиту, может быть уменьшен на сумму выплаченных процентов

Автор newsРаздел Новости

Ответов: 0
Просмотров: 727
Последний ответ 07 Июл 2015, 10:06
от news

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
50 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 128
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal