Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 15:24
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите к кодом  (Прочитано 1123 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Lasbro

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-07-06
  • Сайт: 
  • Профессия: Программист 8.1
Всем привет. Только начал изучение 1с. Подскажите пожалуйста как внешнюю обработку, которая в справочнике "Номенклатура" заполнит значение реквизита "Наименование полное" (НаименованиеПолное) по формату:
     <Наименование>+", "(запятая+пробел)+<ОсновнаяЕдиницаИзмерения>+", "+(запятая + пробел)+"("+<ТипНоменклатуры>+")"
     Пример: Куртка демисезонная, шт, (Товар).


Оффлайн pavl_vs

  • *****
  • Сообщений: 1068
  • РЕПУТАЦИЯ: 168
  • КПД: 16%
  • Регистрация: 2011-05-09
  • Сайт: 
  • Профессия: Программист 7.7
Re: Помогите к кодом
« Ответ #1: 06 Июл 2015, 15:16 »
Lasbro, Вы хоть что-нибудь свое предложите и если не получается, покажите и Вам помогут.

Оффлайн Lasbro

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-07-06
  • Сайт: 
  • Профессия: Программист 8.1
Re: Помогите к кодом
« Ответ #2: 06 Июл 2015, 15:53 »
Вот именно что я не знаю с чего начать. С конфигурациями и данными уже разобрался. Теперь пора приступать к коду, и немножко запутался.

Оффлайн TinaSam

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 4
  • КПД: 50%
  • Регистрация: 2015-07-06
  • Сайт: 
  • Профессия: Программист 1С
Re: Помогите к кодом
« Ответ #3: 06 Июл 2015, 16:11 »
Выборка = Справочники.Номенклатура.Выбрать();
Пока Выборка.Следующий() цикл
    Если Выборка.ЭтоГруппа тогда
       Продолжить;
    КонецЕсли;
    Спр_Объект = Выборка.Ссылка.ПолучитьОбъект();
    СпрОбъект.НаименованиеПолное = СокрЛП(Выборка.Наименование)+", "+...
    СпрОбъект.Записать();
КонецЦикла;

Оффлайн Rasty

  • *****
  • Сообщений: 988
  • РЕПУТАЦИЯ: 139
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
Re: Помогите к кодом
« Ответ #4: 06 Июл 2015, 16:14 »
Выборка = Справочники.Номенклатура.Выбрать();
Пока Выборка.Следующий() цикл
    Если Выборка.ЭтоГруппа тогда
       Продолжить;
    КонецЕсли;
    Спр_Объект = Выборка.Ссылка.ПолучитьОбъект();
    СпрОбъект.НаименованиеПолное = СокрЛП(Выборка.Наименование)+", "+...
    СпрОбъект.Записать();
КонецЦикла;
Это если все сразу надо
а если надо именно сразу в элементе, то там есть событие ПриИзменении
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн pavl_vs

  • *****
  • Сообщений: 1068
  • РЕПУТАЦИЯ: 168
  • КПД: 16%
  • Регистрация: 2011-05-09
  • Сайт: 
  • Профессия: Программист 7.7
Re: Помогите к кодом
« Ответ #5: 06 Июл 2015, 16:26 »
Lasbro, если нет возможности или желания воспользоваться известными книгами, то для начала воспользуйтесь этим:

http://1c-pro.ru/threads/texnologija-sozdanija-vneshnix-pechatnyx-form-obrabotok-otchetov-dlja-upravljaemogo-rezhima-8-2.20351/
http://howknow1c.ru/programmirovanie-1c/obrabotki-1s.html
http://novichok1c.ru/sozdanie-vneshney-pechatnoy-formy

Либо закажите поиск в Yandex или Google строчкой типа "создание внешних обработок 1с 8.2" (или что у Вас - 8.1, 8.3, обычные/управляемые формы).

PS Ну а далее можно воспользоваться предложениями двух предшествующих постов.


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4291
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5547
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5883
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4361
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1975
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
168 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 997
  • Точка Скрытых: 0
  • Точка Пользователей: 14
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal