Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 03:54
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Доступ к значению табличной части справочника, подсчет кол-ва строк  (Прочитано 1092 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн scully-wolf

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 1
  • КПД: 33%
  • Регистрация: 2015-07-05
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте! Весь день маюсь с этой проблемой, я только учусь работе с 1С и не понимаю некоторых задач.
У меня есть Справочник(Контрагенты) с реквизитами: Контрагент(вместо Наименование), КоличествоКонтактныхЛиц. Также у него есть табличная чать(КонтактныеЛица) с реквизитами: ФИО, телефон, должность.
Есть документ События с реквизитами Перезвонить(тип дата) и табличной частью(СписокСобытий)с реквизитами: Сотрудник(выбор из справочника Сотрудники), Контрагент(выбор из справочника Контрагенты), КонтактноеЛицо, ОписаниеЗвонка.
Как сделать так, чтобы при выборе значения в поле ТЧ Контрагент автоматически заполнялась поле ТЧ КонтактноеЛицо( бралсь первая запись ТЧти КонтактныеЛица ФИО выбранного Контрагента из справочника Контрагенты). ???
Пытаюсь сделать так:

Процедура СписокСобытийКонтрагентПриИзменении(Элемент)
строка1=Элементы.СписокСобытий.ТекущиеДанные;
    строка1.КонтактноеЛицо=ПолучитьКонтактноеЛицоКонтрагенты(строка1.Контрагент);

КонецПроцедуры

 &НаСервереБезКонтекста
 Функция ПолучитьКонтактноеЛицоКонтрагенты(Контрагент)
Возврат Контрагент.КонтактныеЛица.ФИО
КонецФункции
И вот ошибка:
Цитировать
{Документ.События.Форма.ФормаДокумента.Форма(16)}: Поле объекта не обнаружено (ФИО)
       Возврат Наименование.КонтактныеЛица.ФИО

Как сделать правильно?

Также, как подсчитать количество записей табличной части справочника и потом передать в реквизит справочника? значение я умею передавать, но подсчитать не знаю как.(
Помогите пожалуйста!.


Оффлайн KrivosheevEV

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 35
  • КПД: 17%
  • Регистрация: 2014-01-20
  • Сайт: 
  • Профессия: Программист 1С
Цитировать
Также, как подсчитать количество записей табличной части справочника и потом передать в реквизит справочника? значение я умею передавать, но подсчитать не знаю как.(
Помогите пожалуйста!.


Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
scully-wolf, у вас, кот здесь ошибка
&НаСервереБезКонтекста
 Функция ПолучитьКонтактноеЛицоКонтрагенты(Контрагент)
     Возврат Контрагент.КонтактныеЛица.ФИО
КонецФункции


Если вы правильно, описали структуру вашего справочника,
КонтактныеЛица - это табличная часть через точку (.) вы не получите значение поля,
вам необходимо сначала указать из какой строки вы хотите получить значение поля, обращение к строке можно сделать например так КонтактныеЛица[0]
иногда бывает что табличная часть не заполнена, поэтому надо проверять есть ли в ней данные (строки). в общем ваша функция выглядела бы так,

&НаСервереБезКонтекста
Функция ПолучитьКонтактноеЛицоКонтрагенты(Контрагент)

    Если Контрагент.КонтактныеЛица.Количество() > 0 Тогда
        //есть данные о Контактных лицах, берем первого
        Возврат Контрагент.КонтактныеЛица[0].ФИО;
    Иначе
        //нет данные о Контактных лицах,
        Возврат Неопределено;
    ЕонецЕсли;

КонецФункции

попробуйте, возможны синтаксические ошибки, исправьте.
Помогло? - Нажми СПАСИБО!!!
                       :)


Теги:
 

Как вызвать "Анализ субконто" из справочника "Контрагенты"

Автор EnigManРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 6496
Последний ответ 06 Фев 2012, 10:46
от cska-fanat-kz
Как сделать, чтобы поле в документе имело тип "ссылка на поле справочника"?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2035
Последний ответ 05 Мар 2017, 14:36
от Igor100500
Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 270
Последний ответ 12 Окт 2017, 14:02
от wise
Работа с формой Справочника "Физ.Лица" в ЗУП 2.5

Автор Митя_Просто_МитяРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3889
Последний ответ 15 Дек 2011, 00:04
от Vit1501
Чистка справочника "Налоги и взносы"

Автор dim3740Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 401
Последний ответ 17 Май 2017, 17:55
от Геннадий ОбьГЭС

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
175 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 175
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal