Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 07:31
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: как просуммировать значения полей в документе  (Прочитано 813 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн alla_92

  • *
  • Сообщений: 0
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-07-05
  • Сайт: 
  • Профессия: Ученик 1С
Уважаемые знатоки! помогите, пожалуйста!
 Тема - оценка кредитоспособности заемщика.
создаю документ "Проверка", в нем поля заполняются из справочников, например справочник "пол" значения у него "мужской" и "женский", к каждому из которых в справочнике присвоена "оценка".
в документе "проверка" внизу создаю поле "результат проверки", в него необходимо записать сумму всех ранее выбранных значений. в коде вообще не шарю, помогите, пожалуйста!


Оффлайн scully-wolf

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 1
  • КПД: 33%
  • Регистрация: 2015-07-05
  • Сайт: 
  • Профессия: Ученик 1С
Я делала так:
Справочник КаталогЛекарств с реквизитами Наименование, Количество, Цена
Документ ПродажиПрепаратов с реквизитами СуммаПоДокументу и ТаблЧасть(Продажа) с реквизитами Наименование, Цена, Количество, Сумма.



&НаКлиенте
Процедура ПродажаНаименованиеПриИзменении(Элемент)
Стр = Элементы.Продажа.ТекущиеДанные;
Стр.Цена =  ПолучитьЦенаКаталогЛекарств(Стр.Наименование);
ПродажаКоличествоПриИзменении(Элемент);
ПродажаЦенаПриИзменении(Элемент);
КонецПроцедуры

 &НаСервереБезКонтекста
Функция ПолучитьЦенаКаталогЛекарств(Наименование)
Возврат Наименование.Цена;
КонецФункции

   &НаКлиенте
Процедура ПродажаКоличествоПриИзменении(Элемент)

СтрокаТабличнойЧасти = Элементы.Продажа.ТекущиеДанные;
СтрокаТабличнойЧасти.Сумма =  СтрокаТабличнойЧасти.Цена * СтрокаТабличнойЧасти.Количество;

КонецПроцедуры

&НаКлиенте
Процедура ПродажаЦенаПриИзменении(Элемент)
СтрокаТабличнойЧасти = Элементы.Продажа.ТекущиеДанные;
СтрокаТабличнойЧасти.Сумма =  СтрокаТабличнойЧасти.Цена * СтрокаТабличнойЧасти.Количество;
КонецПроцедуры


&НаКлиенте
Процедура ПродажаПриИзменении(Элемент)
РасчетСуммыПоДокументу();
КонецПроцедуры


Процедура РасчетСуммыПоДокументу()
Объект.СуммаПоДокументу = Объект.Продажа.Итог("Сумма");
КонецПроцедуры 




В последних 2 процедурах выполняется суммирование поля Сумма и передача значения в реквизит СуммаПоДокументу. -ПродажаПриИзменении --- тут мы обращаемся в целом к ТаблЧасти как только в ней начнут меняться значения.
Так же тут цена заночится автоматически и обрабатывается случай при указании количества сумма меняется9 умножение цены на количество)


Теги:
 

Значения некоторых колонок являются суммами некоторых колонок, которые в свою очередь так же являются суммами других. Как упорядочить?

Автор acces969Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 275
Последний ответ 26 Июн 2017, 14:32
от AsadRoman
Что быстрее: Загрузить табличную часть в запрос и там добавить колонки, или пробежаться циклом по ТЧ и добавить значения в колонки

Автор ZeedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 977
Последний ответ 11 Июл 2016, 09:00
от vitasw
заполнение закладки "Материалы" в документе "Поступление из переработки"

Автор Sasa1CРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3589
Последний ответ 10 Июн 2013, 22:34
от Sasa1C
Заполнение табличной части при выборе реквизита другой табличной части в документе.

Автор Vlad-93Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 309
Последний ответ 25 Окт 2017, 14:15
от Vlad-93
УТ 11.В документе "Заявка на расходование денежных средств" нет кнопки "Печать"!

Автор Valery3103Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3755
Последний ответ 29 Июн 2012, 18:37
от LexaK

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
167 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 314
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal