Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 10:50
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Данные из таблицы в печатную форму  (Прочитано 2473 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн keramik

  • ***
  • Сообщений: 161
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2014-10-03
  • Сайт: 
  • Профессия: Программист 1С
Добрый день, 1С 8.2, "Управление торговлей", редакция 10.3 (10.3.7.9).

Вопрос следующий, как передать в печатную форму данные из ячейки таблицы?

Есть таблица ЗаказанныеРаботы с колонкой ЗаказРаботы. Туда пользователь из списка выбирает виды работ.
В печатной форме есть поле <ЗаказанныеРаботы>, которое должно заполняться данными из таблицы. Для этого использую следующий код:
	ОбластьМакета = Макет.ПолучитьОбласть("Причина");
ОбластьМакета.Параметры.ЗаказанныеРаботы = СокрЛП(ЭтотОбъект.Ссылка.ЗаказанныеРаботы);
ТабДокумент.Вывести(ОбластьМакета);
Но вместо данных выводится строка: ДокументТабличнаяЧасть.АС_ЗаявкаНаРемонт.ЗаказанныеРаботы

Когда речь шла о заполнении печатной части полями из формы, то вопросов не было. А вот с данными из таблицы я пока не могу справиться.
Подскажите, пожалуйста, в какую сторону искать?


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
раз таблица - значит может быть несколько строк. значит надо вывести работы через запятую? так?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
Судя по всему, речь о табличной части документа. Чтобы вывести данные из ТЧ можно, например, пробежать по строкам в цикле, выводя данные в табличный документ.

Оффлайн keramik

  • ***
  • Сообщений: 161
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2014-10-03
  • Сайт: 
  • Профессия: Программист 1С
Нагляднее будет вывести в столбик.
Цикл. Это идея, покурю мануалы, как это можно реализовать.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
подсказка: цикл "Для каждого..."
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн keramik

  • ***
  • Сообщений: 161
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2014-10-03
  • Сайт: 
  • Профессия: Программист 1С
Изменил немного названия ТабличнойЧасти и атрибутов, чтобы самому не путаться.
В итоге есть Табличная Часть - ПричинаОбр, в ней атрибут ПричинаНазвание.
В процедуре, вызывающей печатную форму, добавил код:
	
ОбластьМакета = Макет.ПолучитьОбласть("Причина");
Для Каждого ПричинаНазвание из ПричинаОбр Цикл
ТекРаботы = ЭтотОбъект.Ссылка.ПричинаОбр;
КонецЦикла;
ОбластьМакета.Параметры.ЗаказанныеРаботы = ТекРаботы;
Но этот вариант не работает, данные не выводятся. Я что-то не то выбираю.

Оффлайн Kironten

  • *****
  • Сообщений: 899
  • РЕПУТАЦИЯ: 185
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Изменил немного названия ТабличнойЧасти и атрибутов, чтобы самому не путаться.
В итоге есть Табличная Часть - ПричинаОбр, в ней атрибут ПричинаНазвание.
В процедуре, вызывающей печатную форму, добавил код:
	
ОбластьМакета = Макет.ПолучитьОбласть("Причина");
Для Каждого ПричинаНазвание из ПричинаОбр Цикл
ТекРаботы = ЭтотОбъект.Ссылка.ПричинаОбр;
КонецЦикла;
ОбластьМакета.Параметры.ЗаказанныеРаботы = ТекРаботы;
Но этот вариант не работает, данные не выводятся. Я что-то не то выбираю.
Если уж "столбиком", попробуйте типо того:
ТекРаботы = "";
Для Каждого Стр Из ПричинаОбр Цикл
    ТекРаботы = ТекРаботы + СокрЛП(Стр.ПричинаНазвание) + Символы.ПС;
КонецЦикла
ОбластьМакета.Параметры.ЗаказанныеРаботы = ТекРаботы;

Оффлайн keramik

  • ***
  • Сообщений: 161
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2014-10-03
  • Сайт: 
  • Профессия: Программист 1С
Отлично! Просто отлично. Выводятся данные. Спасибо :)


 

Как перенести данные из 7.7 типовая УСН 1.3 в 1С 8 типовая бухгалтерия

Автор Александр бухгалтерРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 4831
Последний ответ 13 Фев 2010, 07:58
от Александр бухгалтер
"Лишние" данные в зарплате

Автор Мария_ХРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 3781
Последний ответ 05 Апр 2014, 11:11
от Славянка
"Данные по коду не найдены"

Автор elteawРаздел Пользователям "1С - Предприятие 8"

Ответов: 6
Просмотров: 8084
Последний ответ 03 Дек 2015, 13:58
от Timofey Gurubanov
Куда сохраняются данные в режиме работы клиент при выгрузке данных обработкой "Универсальный обмен данными в формате XML"

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 6941
Последний ответ 13 Ноя 2014, 08:23
от cska-fanat-kz
Как открыть программно открыть форму контрагента?

Автор VzonderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1332
Последний ответ 18 Янв 2017, 12:32
от sertak

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal