Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 08:29
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Сбой  (Прочитано 2191 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dasha4

  • **
  • Сообщений: 62
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-03-10
  • Сайт: 
  • Профессия: Программист 1С
Сбой
« Первое сообщение: 02 Июл 2015, 15:20 »
Здравствуйте. Я вообще-то уже обращалась с этой темой, но у меня похоже произошел какой-то сбой и она упорно не хочет считать
Если ДокументРезультат.КоличествоСтраниц() > 1 Тогда
В МодулеОбъекта, Процедура ПриКомпоновкеРезультата
Для того, чтобы если количество страниц больше одной выводить Колонтитулы и копировать Шапку на другие страницы.
В ответ на это условие мне сейчас выводится Ложь.
Я не знаю может Настройки какие-нибудь кто-то поменял? Принтер, он узнает и выводит как основной, ТолстыйКлиент
1С 8.2.15


Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Re: Сбой
« Ответ #1: 02 Июл 2015, 15:22 »
Проверяете после вывода в макет или перед?

Оффлайн dasha4

  • **
  • Сообщений: 62
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-03-10
  • Сайт: 
  • Профессия: Программист 1С
Re: Сбой
« Ответ #2: 03 Июл 2015, 11:06 »
Проверяете после вывода в макет или перед?
Я не понимаю отчего это зависит? Неужели от порядка в котором создаешь? Я в Отчете убрала МакетОформления и Макет. И все пошло! Потом заново создала два этих макета, и все заработало!
Добавлено: 03 Июл 2015, 11:48

Блин. Я условие забыла поменять. У меня стояло =Ложь. А как только я сделала >1 - все перестало работать.
И когда я убрала макеты, тоже не заработало.

Последний раз редактировалось: dasha4; 03 Июл 2015, 11:48. Причина: Объединение сообщений

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Re: Сбой
« Ответ #3: 03 Июл 2015, 11:53 »
Вам помощь нужна? или просто поговорить? ответе на вопрос
Проверяете после вывода в макет или перед?


Оффлайн dasha4

  • **
  • Сообщений: 62
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-03-10
  • Сайт: 
  • Профессия: Программист 1С
Re: Сбой
« Ответ #4: 03 Июл 2015, 13:15 »
Вам помощь нужна? или просто поговорить? ответе на вопрос
Проверяете после вывода в макет или перед?
И после и перед

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Re: Сбой
« Ответ #5: 03 Июл 2015, 13:23 »
Покажите код

Оффлайн Kironten

  • *****
  • Сообщений: 906
  • РЕПУТАЦИЯ: 185
  • КПД: 20%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Re: Сбой
« Ответ #6: 03 Июл 2015, 13:29 »
Вам помощь нужна? или просто поговорить? ответе на вопрос
Проверяете после вывода в макет или перед?
И после и перед
А какой смысл?
Проверять надо в самом конце, после заполнения и вывода областей в табличный документ, но перед возвратом на показ. Примерно так:
ТабДок.Вывести(ОбластьПодписи);

Если ТабДок.КоличествоСтраниц > 1 Тогда
    ТабДок.НижнийКолонтитул.НачальнаяСтраница = 1;
    ТабДок.НижнийКолонтитул.ВертикальноеПоложение = ВертикальноеПоложение.Низ;
    ТабДок.НижнийКолонтитул.ТекстВЦентре = "Страниц " + "[&НомерСтраницы]" + " из " + "[&СтраницВсего]";
    ТабДок.НижнийКолонтитул.Выводить = Истина;
КонецЕсли;

Возврат ТабДок;

Оффлайн dasha4

  • **
  • Сообщений: 62
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-03-10
  • Сайт: 
  • Профессия: Программист 1С
Re: Сбой
« Ответ #7: 03 Июл 2015, 15:41 »
Вам помощь нужна? или просто поговорить? ответе на вопрос
Проверяете после вывода в макет или перед?
И после и перед
А какой смысл?
Проверять надо в самом конце, после заполнения и вывода областей в табличный документ, но перед возвратом на показ. Примерно так:
ТабДок.Вывести(ОбластьПодписи);

Если ТабДок.КоличествоСтраниц > 1 Тогда
    ТабДок.НижнийКолонтитул.НачальнаяСтраница = 1;
    ТабДок.НижнийКолонтитул.ВертикальноеПоложение = ВертикальноеПоложение.Низ;
    ТабДок.НижнийКолонтитул.ТекстВЦентре = "Страниц " + "[&НомерСтраницы]" + " из " + "[&СтраницВсего]";
    ТабДок.НижнийКолонтитул.Выводить = Истина;
КонецЕсли;

Возврат ТабДок;
У меня Отчет строится через СКД, а не ручным кодом. Поэтому когда я добавляю в Модуль Менеджера эти строчки, ничего не происходит.
Колонтитулы и повтор сирок у меня записаны в МодулеОбъекта:
Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
 ДокументРезультат.ПолеСлева=35;
 ДокументРезультат.ПолеСнизу=30;
 ДокументРезультат.ПолеСверху=20;
 ДокументРезультат.ПолеСправа=7;
 ДокументРезультат.Автомасштаб = Истина;
 Если ДокументРезультат.КоличествоСтраниц() > 1 Тогда
  ДокументРезультат.ПовторятьПриПечатиСтроки = ДокументРезультат.Область("R3:R4");
  ДокументРезультат.НижнийКолонтитул.Выводить = ИСТИНА;
  ДокументРезультат.НижнийКолонтитул.ТекстСлева = "-------------------------------------------------------------------------------------------------------------------------------------------"+Символы.ПС+"Лист [&НомерСтраницы] [&Дата]         [&Время]";
  ДокументРезультат.НижнийКолонтитул.Шрифт = Новый Шрифт("Times",10,,Ложь);                                                                                                                                                                                                                         
 КонецЕсли; 
КонецПроцедуры
Все вроде правильно, а вылает число ноль

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Re: Сбой
« Ответ #8: 03 Июл 2015, 15:48 »
Нет конечно, неправильно.
У вас всегда будет 0, потому-что вы проверяете пустой документ и после этого СКД формирует результат.
Поэтому когда я добавляю в Модуль Менеджера эти строчки,

А причем тут модуль менеджера?

Оффлайн Kironten

  • *****
  • Сообщений: 906
  • РЕПУТАЦИЯ: 185
  • КПД: 20%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Re: Сбой
« Ответ #9: 03 Июл 2015, 16:09 »
У меня Отчет строится через СКД, а не ручным кодом.
Ну и делайте через СКД, кто мешает?
Выводите программно.
Просто проведите проверку после:
ПроцессорВывода.Вывести(ПроцессорКомпоновкиДанных)
Тогда у Вас будет количество страниц получено из заполненного табличного документа.


Теги:
 

Если произошел технический сбой сервера, и форма 4-ФСС не во время была доставлена, компанию нельзя оштрафовать

Автор topicsРаздел Статьи

Ответов: 0
Просмотров: 1528
Последний ответ 18 Ноя 2014, 14:25
от topics
1с 8.3: Бухгалтерия.базовая платформа 8.3.6.2152 (отрицательного сальдо быть не должно-сбой системы)

Автор LyonaРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1516
Последний ответ 10 Окт 2015, 09:39
от Lyona
Сбой в программе, можно ли решить проблему?

Автор assol_07Раздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 4131
Последний ответ 20 Окт 2010, 22:20
от progmikon
Сбой при подборе товара в накладной или заказе

Автор ЕвгенийСПБРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1273
Последний ответ 17 Янв 2011, 12:48
от ЕвгенийСПБ
Сбой пользовательского интерфейса: обычное приложение

Автор НэкосанРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 762
Последний ответ 14 Июл 2015, 12:10
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 185
  • Точка Скрытых: 1
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal