Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Май 2018, 12:37
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Пример работы с временным хранилищем [временное хранилище]  (Прочитано 15966 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6642
  • РЕПУТАЦИЯ: 783
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Начиная с версии 8.2 в 1С:Предприятии появился новый объект: временное хранилище. Этот объект позволяет решать многие проблемы при передаче данных между различными формами. Как известно, начиная с версии 8.2 1С поддерживает работу через тонкий и веб клиент (браузер), что накладывает на разработчиков программных решений ряд ограничений. А объект временное хранилище помогает эти ограничения снимать.

&НаКлиенте
Процедура ОтобратьКонтрагентов(Команда)

АдресВХ = "";
ОтобратьКонтрагентовСервер(АдресВХ);
СтруктураВыбора = Новый Структура;
СтруктураВыбора.Вставить("Контрагенты",АдресВХ);
ОповеститьОВыборе(СтруктураВыбора);
//ЭтаФорма.Закрыть();

КонецПроцедуры


&НаСервере
Процедура ОтобратьКонтрагентовСервер(АдресВХ)

ОбработкаОбъект = РеквизитФормыВЗначение("Объект");
ТаблицаЗначений = Новый ТаблицаЗначений;
СхемаКомпоновкиДанных = ОбработкаОбъект.ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных");
СтруктураПараметров = Новый Структура();
//ПолучитьДанныеНаОснованииСКД(СхемаКомпоновкиДанных, ТаблицаЗначений, КонрагентыСписок.КомпоновщикНастроек.Настройки, СтруктураПараметров);
ПолучитьДанныеНаОснованииСКД(СхемаКомпоновкиДанных, ТаблицаЗначений, Неопределено, СтруктураПараметров);

АдресВХ = ПоместитьВоВременноеХранилище(ТаблицаЗначений,Новый УникальныйИдентификатор());

КонецПроцедуры

//Обработка в другой форме
&НаКлиенте
Процедура КонтрагентыОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
КонтрагентыОбработкаВыбораНаСервере(ВыбранноеЗначение);
СтандартнаяОбработка = Ложь;
КонецПроцедуры

&НаСервере
Процедура КонтрагентыОбработкаВыбораНаСервере(ВыбранноеЗначение)

Если ТипЗнч(ВыбранноеЗначение) = Тип("Структура") Тогда

АдресВХ = ВыбранноеЗначение.Контрагенты;
ТаблицаЗначений = ПолучитьИзВременногоХранилища(АдресВХ);
Объект.Контрагенты.Очистить();
Для каждого Элемент из ТаблицаЗначений Цикл
НоваяСтрока = Объект.Контрагенты.Добавить();
НоваяСтрока.Контрагент = Элемент.Ссылка;
КонецЦикла;

КонецЕсли;

КонецПроцедуры


Последний раз редактировалось: MuI_I_Ika; 19 Авг 2015, 15:41


Теги:
 

Куда сохраняются данные в режиме работы клиент при выгрузке данных обработкой "Универсальный обмен данными в формате XML"

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 7693
Последний ответ 13 Ноя 2014, 08:23
от cska-fanat-kz
Не активен документ "Договоры (работы услуги)"

Автор DancevaРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 2123
Последний ответ 17 Апр 2015, 16:18
от Danceva
Дистанционный сотрудник, который является нерезидентом страны и выполняет работы по договору, поможет сэкономить на налогах и взносах

Автор newsРаздел Новости

Ответов: 0
Просмотров: 2326
Последний ответ 01 Авг 2014, 11:39
от news
Когда расходы на транспортировку сотрудников до места работы могут быть учтены в налоговой базе?

Автор topicsРаздел Статьи

Ответов: 0
Просмотров: 1910
Последний ответ 07 Май 2014, 13:11
от topics
Как рассчитать пособие по временной нетрудоспособности, если работник не принес справку с прошлого места работы?

Автор topicsРаздел Статьи

Ответов: 0
Просмотров: 1959
Последний ответ 09 Июл 2014, 16:55
от topics

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
159 Сообщений
alex0402
71 Сообщений
oleg-x
68 Сообщений
AIFrame AIFrame
59 Сообщений
buketov.av buketov.av
41 Сообщений
wise wise
39 Сообщений
KOI8-R
34 Сообщений
ilyay ilyay
29 Сообщений
Alter
28 Сообщений
trialex3
25 Сообщений

* Кто онлайн

  • Точка Гостей: 847
  • Точка Скрытых: 0
  • Точка Пользователей: 14
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal