Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 16:08
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Регистр Бухгалтерии  (Прочитано 3369 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн MagistrPavel

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-06-30
  • Сайт: 
  • Профессия: Консультант 1С
Подскажите как получить список счетов и документов по этим счетам, обращаться к регистру бухгалтерии?
Пример вывода:

10
поступление 12-3493 от 13.12.12
реализация 3478574387 от 5.12.12
20
26
41
реализация 212344 от 6.04.15

...


Оффлайн Rasty

  • *****
  • Сообщений: 989
  • РЕПУТАЦИЯ: 139
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
запросом по регистру бухгалтерии, с параметрами счетдт и счеткт
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн MagistrPavel

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-06-30
  • Сайт: 
  • Профессия: Консультант 1С
с запросом не получается у меня, видимо нужно к конкретному регистру бухгалтерии хозрасчетный обращаться?

Оффлайн Rasty

  • *****
  • Сообщений: 989
  • РЕПУТАЦИЯ: 139
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
ну как бы да=)
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн MagistrPavel

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-06-30
  • Сайт: 
  • Профессия: Консультант 1С
Ну как бы запрос не получается выдает кучу ошибок, как будто не видит параметры счетДт и счетКт

Оффлайн Rasty

  • *****
  • Сообщений: 989
  • РЕПУТАЦИЯ: 139
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
скиньте код
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн MagistrPavel

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-06-30
  • Сайт: 
  • Профессия: Консультант 1С
Обработка выводит все документы по регистрам в данном случае регистру бухгалтерии, мне необходимо чтобы она выводила по номерам счетов документы.

&НаСервере
Процедура ВыполнитьНаСервере()
   Если Не ЗначениеЗаполнено(ДатаНачало) Тогда
   Сообщить("Дата Начало не заполнена!");      
   Возврат;
Конецесли;
Если Не ЗначениеЗаполнено(ДатаКонец) Тогда
   Сообщить("Дата Конец не заполнена!");      
   Возврат;
Конецесли;
//ТЗ = Новый ТаблицаЗначений;
//ТЗ.Колонки.Добавить("Регистр",,"Наименование Регистра");
//ТЗ.Колонки.Добавить("Регистратор",,"Наименование Документа");
//ТЗ.Колонки.Добавить("Количество",,"Количество документов");

Для каждого Регистр Из Метаданные.РегистрыБухгалтерии Цикл
   Колво=0;
   Настоящий="";
   НастоящийСиноним="";
   НоваяСтрока = ТабличноеПоле1.Добавить();
    НоваяСтрока.Регистр = Регистр.Имя;
   Запрос = Новый Запрос;
   Запрос.УстановитьПараметр("ДатаНачало", ДатаНачало);
    Запрос.УстановитьПараметр("ДатаКонец", ДатаКонец);
   Запрос.Текст = "ВЫБРАТЬ
   |   ТоварыНаСкладах.Регистратор
   |ИЗ
   |   РегистрБухгалтерии.ТоварыНаСкладах КАК ТоварыНаСкладах
   |ГДЕ
    |ТоварыНаСкладах.Регистратор.Дата МЕЖДУ НАЧАЛОПЕРИОДА(&ДатаНачало, ДЕНЬ) И КОНЕЦПЕРИОДА(&ДатаКонец, ДЕНЬ)
   |СГРУППИРОВАТЬ ПО
    |ТоварыНаСкладах.Регистратор
   |УПОРЯДОЧИТЬ ПО
    |ТоварыНаСкладах.Регистратор";
   Запрос.Текст = СтрЗаменить(Запрос.Текст, "ТоварыНаСкладах", Регистр.Имя);
   Результат = Запрос.Выполнить();
   Выборка = Результат.Выбрать();
   
   Пока Выборка.Следующий() Цикл
      Колво=Колво+1;
      Если Колво > 1 Тогда
         Если НЕ Настоящий = Выборка.Регистратор.Метаданные().Имя Тогда
            НоваяСтрока = ТабличноеПоле1.Добавить();
            НоваяСтрока.Регистратор =Символы.Таб + Настоящий;
            НоваяСтрока.СинонимРегистратора =Символы.Таб + НастоящийСиноним;
            НоваяСтрока.Количество =Колво-1;
            Колво=1;
         КонецЕсли;
      КонецЕсли;   
      Настоящий=Выборка.Регистратор.Метаданные().Имя;
      НастоящийСиноним=Выборка.Регистратор.Метаданные().Синоним;
   КонецЦикла;
   Если НЕ Колво=0 Тогда
      НоваяСтрока = ТабличноеПоле1.Добавить();
      НоваяСтрока.Регистратор =Символы.Таб + Настоящий;
      НоваяСтрока.СинонимРегистратора =Символы.Таб + НастоящийСиноним;
      НоваяСтрока.Количество =Колво;
   КонецЕсли;
КонецЦикла;

КонецПроцедуры

&НаКлиенте
Процедура ВыполнитьКоманду(Команда)
   ВыполнитьНаСервере();
КонецПроцедуры

P.S. буквально вчера вывел им регистры накопления

Оффлайн Rasty

  • *****
  • Сообщений: 989
  • РЕПУТАЦИЯ: 139
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
а по какому именно счету ДТ или КТ?
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн MagistrPavel

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-06-30
  • Сайт: 
  • Профессия: Консультант 1С
Достаточно по счетДТ потом сам разберусь мне главное понять что изменить

Оффлайн Rasty

  • *****
  • Сообщений: 989
  • РЕПУТАЦИЯ: 139
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
Запрос.Текст =  
"ВЫБРАТЬ
| Хозрасчетный.Регистратор,
| Хозрасчетный.СчетДт
|ИЗ
| РегистрБухгалтерии.Хозрасчетный КАК Хозрасчетный"
Таблица = Запрос.Выполнить().Выгрузить();
Таблица.Сортировать("СчетДт Возр");
В итоге будет таблица с колонками СчетДТ и Регистратор сортированная по счету дебита
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)


Теги:
 

Регистр сведений "Версии объектов"

Автор ЕвгенийЗерноРаздел Пользователям "1С - Предприятие 8"

Ответов: 4
Просмотров: 536
Последний ответ 20 Июл 2017, 17:00
от ЕвгенийЗерно
Не формируется регистр НУ "Расходы на оплату труда"

Автор DOKA@Раздел Пользователям "1С - Предприятие 8"

Ответов: 14
Просмотров: 10473
Последний ответ 23 Дек 2013, 17:22
от LordWizard
регистр "Данные о времени для расчета среднего"

Автор AlexRasmusРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2689
Последний ответ 15 Сен 2015, 19:14
от Дмитрий@
Регистр накоплений - себестоимость, не записываются движения документа "Реализация товаров"

Автор ekaterinka87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2831
Последний ответ 20 Июл 2015, 11:10
от ferrari314
Как В Запрос=Новый Запрос Из Регистр Накопление Остати Выбрать СуммаПриход По Нужный Реквизитам

Автор Samir OmarovРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 1548
Последний ответ 17 Ноя 2016, 08:34
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 257
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal