Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 20:06
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Раскрытие группировки в табличном документе  (Прочитано 1154 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Бак Хрени

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-20
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день.
В обработке имеется поле табличного документа в которое загружаю файл *.mxl. В документе 5 уровней группировок. открываю на 4.
Нужно организовать поиск в данном документе программно. В задумке он должен находить поле и раскрывать группировку только по 1 позиции.
Вот что имею:

Процедура ПриОткрытии()
   ТабличныйДокумент = Новый ТабличныйДокумент;
   ТабличныйДокумент.Прочитать("Файло.mxl");
   ЭтаФорма.ЭлементыФормы.Остатки.Вывести(ТабличныйДокумент);
КонецПроцедуры

Процедура НоменклатураПриИзменении(Элемент)
   Если ЗначениеЗаполнено(Элемент.Значение) Тогда
      СтрокаПоиска = Элемент.Значение.Наименование;
      ОбластьЯчеек = ЭтаФорма.ЭлементыФормы.Остатки.НайтиТекст(СтрокаПоиска);
      Если ОбластьЯчеек <> Неопределено Тогда
         Линия = Новый Линия(ТипЛинииЯчейкиТабличногоДокумента.Сплошная,2);
         ОбластьЯчеек.Обвести(Линия, Линия, Линия, Линия);
         ЭтаФорма.ЭлементыФормы.Остатки.ТекущаяОбласть = ОбластьЯчеек;
      КонецЕсли;
   
   КонецЕсли;
КонецПроцедуры

Научился пока находить нужную строку и переходить к ней. Но найденная строка отображается в конце поля табличного документ и раскрыть ее на 1 уровень группировки не получается.


Теги:
 

заполнение закладки "Материалы" в документе "Поступление из переработки"

Автор Sasa1CРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3594
Последний ответ 10 Июн 2013, 22:34
от Sasa1C
Заполнение табличной части при выборе реквизита другой табличной части в документе.

Автор Vlad-93Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 314
Последний ответ 25 Окт 2017, 14:15
от Vlad-93
УТ 11.В документе "Заявка на расходование денежных средств" нет кнопки "Печать"!

Автор Valery3103Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3759
Последний ответ 29 Июн 2012, 18:37
от LexaK
Как сделать, чтобы поле в документе имело тип "ссылка на поле справочника"?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2034
Последний ответ 05 Мар 2017, 14:36
от Igor100500
Не активно поле ПОЛУЧАТЕЛЬ в документе "выдача наличных" и в "кассовых документах"

Автор Masik777Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 918
Последний ответ 31 Авг 2016, 16:02
от Masik777

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
184 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
50 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 350
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal