Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 10:57
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как программно проставить номенклатуру в проводки бгу редакция 1.0  (Прочитано 725 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн notaSS

  • *
  • Сообщений: 29
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-11-22
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте.Скажите, пожалуйста,нужно программно проставить номенклатуру в записи регистра бухгалтерии,которые создает документ "требование на выдачу продуктов питания". Вопрос в том, что у нас номенклатура берется из табличной части этого документа,но я не могу проставить номенклатуру, так как обработка берет одну номенклатуру, которая первая  в списке в табл части, и проставляет всем позициям одну и ту же номенклатуру в регистре!



   Запрос = Новый Запрос;
   Запрос.Текст =
   "ВЫБРАТЬ
   |   УППБУ_ТребованиеПродуктыПитания.Номенклатура,
   |   УППБУ_ТребованиеПродуктыПитания.Ссылка.МестоХранения,
   |   УППБУ_ТребованиеПродуктыПитания.КОСГУСчетДебета,
   |   УППБУ_ТребованиеПродуктыПитания.КОСГУСчетКредита,
   |   УППБУ_ТребованиеПродуктыПитания.Ссылка.Ссылка
   |ИЗ
   |   Документ.УППБУ_Требование.ПродуктыПитания КАК УППБУ_ТребованиеПродуктыПитания
   |ГДЕ
   |   УППБУ_ТребованиеПродуктыПитания.Ссылка.Ссылка = &Ссылка";
   //   
   //Запрос.УстановитьПараметр("Дата", Датанач);
   //Запрос.УстановитьПараметр("Дата", ДатаКон);
   Запрос.УстановитьПараметр("Ссылка", СсылкаНаОбъект);
   РезультатЗапроса = Запрос.Выполнить();
   
   ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл   
        ДвиженияДокумента = РегистрыБухгалтерии.ЕПСБУ.СоздатьНаборЗаписей();
        ДвиженияДокумента.Отбор.Регистратор.Установить(ВыборкаДетальныеЗаписи.ссылка);
        ДвиженияДокумента.Прочитать();
       
        Для каждого проводка из ДвиженияДокумента Цикл
            Если Не ЗначениеЗаполнено(Проводка.СубконтоКт.Номенклатура) Тогда
               
                    Проводка.СубконтоКт.Номенклатура = ВыборкаДетальныеЗаписи.Номенклатура;
                    Проводка.СубконтоКт.ЦМО = ВыборкаДетальныеЗаписи.МестоХранения;
                    Проводка.СубконтоКт.КОСГУ = ВыборкаДетальныеЗаписи.КОСГУСчетКредита;
                    Проводка.СубконтоДт.КОСГУ = ВыборкаДетальныеЗаписи.КОСГУСчетДебета;
                КонецЕсли;
        КонецЦикла;
        ДвиженияДокумента.Записать();
     
    КонецЦикла;


Оффлайн ppkmlite

  • **
  • Сообщений: 78
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-11-06
  • Сайт: 
  • Профессия: Ученик 1С
с этим вопросом разобрались,сделали условие по номеру документа, но теперь такой вопрос
если в табл части документа позиции повторяются,напрмер
1- апельсины
2 -апельсины
3-яблоки
4-груши
то обработка проставляет след образом
1- апельсины
2-яблоки
3-груши
то есть пропускает повторяющуюся позицию
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл   
        ДвиженияДокумента = РегистрыБухгалтерии.ЕПСБУ.СоздатьНаборЗаписей();
        ДвиженияДокумента.Отбор.Регистратор.Установить(ВыборкаДетальныеЗаписи.ссылка);
        ДвиженияДокумента.Прочитать();
       
        Для каждого проводка из ДвиженияДокумента Цикл
            Если Не ЗначениеЗаполнено(Проводка.СубконтоКт.Номенклатура) и проводка.НомерСтроки = ВыборкаДетальныеЗаписи.НомерСтроки  Тогда
           
                    Проводка.СубконтоКт.Номенклатура = ВыборкаДетальныеЗаписи.Номенклатура;
                    Проводка.СубконтоКт.ЦМО = ВыборкаДетальныеЗаписи.МестоХранения;
                    Проводка.СубконтоКт.КОСГУ = ВыборкаДетальныеЗаписи.КОСГУСчетКредита;
                    Проводка.СубконтоДт.КОСГУ = ВыборкаДетальныеЗаписи.КОСГУСчетДебета;
                КонецЕсли;
        КонецЦикла;
        ДвиженияДокумента.Записать();
     
    КонецЦикла;


Теги:
 

Формирование отчёта "Задолженость по контрагентам" 1С:Предприятие 8.2 "Торговля для частных предпринимателей базовая", редакция 1.0

Автор casper009Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 3007
Последний ответ 27 Май 2015, 10:02
от casper009
Добрый вечер! Прошу помочь, кто знает, подскажите пож. В счете не выводит грузоотправителя и грузополучаетля. Куда их внести ? Как сделать что бы выводило ? У меня 1с 8.3 редакция 11.1 управление торговлей Спасибо!

Автор Farid GasimliРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1978
Последний ответ 07 Фев 2016, 14:34
от pavl_vs
1c 8.2 Розница 2.0 (редакция 2.0) литература из "коробки"- в поисках.

Автор 384842Раздел Закрытые темы

Ответов: 0
Просмотров: 3798
Последний ответ 23 Фев 2012, 16:01
от 384842
бгу,редакция 2.0,отчет "опись электронных докуметов"

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1665
Последний ответ 23 Янв 2015, 21:34
от ppkmlite
Управление небольшой фирмой, редакция 1.4 (1.4.9.44) / отчет по Заказу покупателя закупочные цены - цены продажи

Автор dlenaРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2320
Последний ответ 04 Дек 2014, 10:49
от Eugeneer

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
52 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 238
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal