Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
28 Май 2018, 04:07
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Добавление динамических колонок в ТЗ  (Прочитано 3928 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mashencev_anton

  • ****
  • Сообщений: 315
  • РЕПУТАЦИЯ: 6
  • КПД: 2%
  • Регистрация: 2012-12-05
  • Сайт: 
  • Профессия: Программист 1С
Подскажите плиз.. создал реквизит формы с типом Таблица значений, добавил в нее две колонки. как мне по команде добавить еще n-колонок?? УФ


Оффлайн Rasty

  • *****
  • Сообщений: 997
  • РЕПУТАЦИЯ: 141
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
ТЗ.Колонки.Добавить()
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн mashencev_anton

  • ****
  • Сообщений: 315
  • РЕПУТАЦИЯ: 6
  • КПД: 2%
  • Регистрация: 2012-12-05
  • Сайт: 
  • Профессия: Программист 1С
ТЗ.Колонки.Добавить()
если бы было так, то я бы не обращался за помощью... не подходит

Оффлайн Rasty

  • *****
  • Сообщений: 997
  • РЕПУТАЦИЯ: 141
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
нууу, создайте тогда как реквизит формы
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн mashencev_anton

  • ****
  • Сообщений: 315
  • РЕПУТАЦИЯ: 6
  • КПД: 2%
  • Регистрация: 2012-12-05
  • Сайт: 
  • Профессия: Программист 1С
нууу, создайте тогда как реквизит формы
при таком раскладе
&НаКлиенте
Процедура КонтрагентПриИзменении(Элемент)
КонтрагентПриИзмененииНаСервере();
КонецПроцедуры

&НаСервере
Процедура КонтрагентПриИзмененииНаСервере()

А=СписокТиповЦенКонтрагента();

ТТ=РеквизитФормыВЗначение("Таблица");

Массив=Новый Массив;

Для каждого стр из а Цикл
Массив.Добавить(Строка(стр.Наименование));
КонецЦикла;

Для каждого строка из Массив Цикл
тт.Колонки.Добавить(,,Строка);
КонецЦикла;


         
КонецПроцедуры

&НаСервере
Функция СписокТиповЦенКонтрагента()

СписокДобавленныхТиповЦен = Новый СписокЗначений;

Массив= Новый Массив;

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ТипыЦенНоменклатурыКонтрагентов.Ссылка
|ИЗ
| Справочник.ТипыЦенНоменклатурыКонтрагентов КАК ТипыЦенНоменклатурыКонтрагентов
|ГДЕ
| ТипыЦенНоменклатурыКонтрагентов.Владелец = &Владелец";

Запрос.УстановитьПараметр("Владелец", Объект.Контрагент);

РезультатЗапроса = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
Массив.Добавить(ВыборкаДетальныеЗаписи.ссылка);
КонецЦикла;

Возврат Массив;

КонецФункции
Вот что получается при отладке (рисунок)

т.е. они добавляются но на форме не показываются

Колонки "Номенклатура" и "Ссылка" созданы вручную в конструкторе.

Оффлайн Rasty

  • *****
  • Сообщений: 997
  • РЕПУТАЦИЯ: 141
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
А имя кто колонке будет давать?
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн mashencev_anton

  • ****
  • Сообщений: 315
  • РЕПУТАЦИЯ: 6
  • КПД: 2%
  • Регистрация: 2012-12-05
  • Сайт: 
  • Профессия: Программист 1С
А имя кто колонке будет давать?
правильное замечание!!!! но если называю колонку, то он ругается, что не верное имя колонки
Добавлено: 23 Июн 2015, 09:12

Добавил имя но ничего не поменялось

Последний раз редактировалось: mashencev_anton; 23 Июн 2015, 09:12. Причина: Объединение сообщений

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Не, так дело не пойдет.
Нужно добавлять реквизиты формы, т.е. программно создавать реквизиты и привязывать их к данным.
А что потом будет с этой ТЗ?
Не проще ли изначально создать все нужные колонки и заполнять ТЗ построчно?

Оффлайн Rasty

  • *****
  • Сообщений: 997
  • РЕПУТАЦИЯ: 141
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
Нужно добавлять реквизиты формы
Истину глоголит

Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн mashencev_anton

  • ****
  • Сообщений: 315
  • РЕПУТАЦИЯ: 6
  • КПД: 2%
  • Регистрация: 2012-12-05
  • Сайт: 
  • Профессия: Программист 1С
Не, так дело не пойдет.
Нужно добавлять реквизиты формы, т.е. программно создавать реквизиты и привязывать их к данным.
А что потом будет с этой ТЗ?
Не проще ли изначально создать все нужные колонки и заполнять ТЗ построчно?
да конечно было бы проще....но я заранее не знаю сколько будет добавлено колонок...


Теги:
 

Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 8281
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
Добавление столбца "РРЦ" в отчёт "Валовая прибыли по поставщикам"

Автор kuzmich110Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2055
Последний ответ 17 Мар 2016, 15:23
от kuzmich110
Добавление строки и заполнение строки в ТЗ на форме

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 753
Последний ответ 25 Сен 2017, 09:00
от Св Ч
Добавление пункта в меню "печать"

Автор FlamencoРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 1286
Последний ответ 30 Авг 2016, 07:46
от alex0402
Добавление выбора аналитики в отчет "Закупки"

Автор ValentusРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 6998
Последний ответ 31 Май 2010, 15:55
от Valentus

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
139 Сообщений
alex0402
64 Сообщений
oleg-x
54 Сообщений
AIFrame AIFrame
53 Сообщений
buketov.av buketov.av
47 Сообщений
ilyay ilyay
39 Сообщений
wise wise
37 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
alexandr_ll
30 Сообщений

* Кто онлайн

  • Точка Гостей: 174
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal