Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 15:59
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проверка в документе реализации  (Прочитано 1504 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн progaoff1

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-06-22
  • Сайт: 
  • Профессия: Ученик 1С
Конфигурация 8.2, Салон красоты.
Есть необходимость, что бы пользователь создавал документ, в котором указываются дата проведения акции, номенклатуру соответствующую и ставит галочку "Бесплатные товары". Документ я создал, регистр под этот документ я создал. У меня вопрос, как сделать что бы по всей этой информации из документа, в продажном документе, цены на товары указанные в документе акции, становились нулевыми. Или была скидка 100%.


Онлайн Rasty

  • *****
  • Сообщений: 989
  • РЕПУТАЦИЯ: 139
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
нужно при заполнении продажного документа сверять данные из вашего регистра и если есть акция, то ставить сумму 0 руб.
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн progaoff1

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-06-22
  • Сайт: 
  • Профессия: Ученик 1С
нужно при заполнении продажного документа сверять данные из вашего регистра и если есть акция, то ставить сумму 0 руб.
вот для меня самый глобальный вопрос, как это реализовать в коде

Онлайн Rasty

  • *****
  • Сообщений: 989
  • РЕПУТАЦИЯ: 139
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
в табличной части документа, куда вы забиваете товары, есть событие ПриИзменении, лучше в ПриИзменении номенклатуры, там и делайте сверку
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн progaoff1

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-06-22
  • Сайт: 
  • Профессия: Ученик 1С
в табличной части документа, куда вы забиваете товары, есть событие ПриИзменении, там и делайте сверку
Запрос этот как будет выглядеть? Если не тяжело, можно шаблон??

Онлайн Rasty

  • *****
  • Сообщений: 989
  • РЕПУТАЦИЯ: 139
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
какие у вас реквизиты регистра сведений?
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн progaoff1

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-06-22
  • Сайт: 
  • Профессия: Ученик 1С
какие у вас реквизиты регистра сведений?
Регистр сведений Акции, там хранятся дата акции, организация и товары, цены в регистре ЦеныНоменклатуры

Онлайн Rasty

  • *****
  • Сообщений: 989
  • РЕПУТАЦИЯ: 139
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
а регистратор у вашего регистра сведений есть?
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн progaoff1

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-06-22
  • Сайт: 
  • Профессия: Ученик 1С
а регистратор у вашего регистра сведений есть?
Да, это документ, день акции, там указываются организация дата акции и заводится товар.

Онлайн Rasty

  • *****
  • Сообщений: 989
  • РЕПУТАЦИЯ: 139
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
сделайте регистратором номенклатуру так будет проще искать, тогда это будет выглядеть так
&НаКлиенте
Процедура ВашаТЧНоменклатураПриИзменении(Элемент)
Строка = Элементы.Товары.ТекущиеДанные;
ЕстьАкция = ПолучитьАкцию(Строка.Номенклатура);
Если ЕстьАкция Тогда
Строка.Цена = 0;
КонецЕсли;
....
....
....
КонецПроцедуры;
&НаСервере
Функция ПолучитьАкцию(Номенклатура)
Выборка = РегситрыСведений.Акции.ВыбратьПоРегистратору(Номенклатура);
Возврат Выборка.Следующий()
КонецФункции;
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)


Теги:
 

заполнение закладки "Материалы" в документе "Поступление из переработки"

Автор Sasa1CРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3594
Последний ответ 10 Июн 2013, 22:34
от Sasa1C
Заполнение табличной части при выборе реквизита другой табличной части в документе.

Автор Vlad-93Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 313
Последний ответ 25 Окт 2017, 14:15
от Vlad-93
УТ 11.В документе "Заявка на расходование денежных средств" нет кнопки "Печать"!

Автор Valery3103Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3759
Последний ответ 29 Июн 2012, 18:37
от LexaK
Как сделать, чтобы поле в документе имело тип "ссылка на поле справочника"?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2033
Последний ответ 05 Мар 2017, 14:36
от Igor100500
Не активно поле ПОЛУЧАТЕЛЬ в документе "выдача наличных" и в "кассовых документах"

Автор Masik777Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 918
Последний ответ 31 Авг 2016, 16:02
от Masik777

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
184 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 754
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal