Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
22 Май 2018, 06:52
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вызов COMОбъекта на клиенте и сервере  (Прочитано 2584 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Golickoff

  • ****
  • Сообщений: 383
  • РЕПУТАЦИЯ: 41
  • КПД: 11%
  • НЕ Есть Null после шести
  • Регистрация: 2015-02-05
  • Сайт: 
  • Профессия: Ученик 1С
Всем привет.
Я столкнулся с новой проблемой при работе с COMОбъектом.

Есть форма, при открытии которой создаётся COMОбъект.
&НаКлиенте
Процедура ПриОткрытии(Отказ)

бла бла бла
СоздатьДрайвер();

КонецПроцедуры
&НаСервере
Процедура СоздатьДрайвер()
obj = Новый COMОбъект("COMRFID.RFID");
СтруктураДрайвера = Новый Структура("Драйвер", obj); //Начитавшись умных статей, я помещаю его в структуру чтобы не вызывать каждый раз заново
ПараметрыСеанса.Obj = ПоместитьВоВременноеХранилище(СтруктураДрайвера, Новый УникальныйИдентификатор()); //По советам тех же статей, структура помещается в параметры сеанса
КонецПроцедуры
Всё здорово, COMОбъект в структуре и его можно не вызывать.
Теперь нам необходимо обратиться к этому COMОбъекту и я жму на кнопку:
&НаКлиенте
Процедура ДобавитьМетки(Команда)

Obj = ВК();
Obj = Obj.Драйвер;
obj.StartReading();
  ДобавитьОбработчик obj.TagReading, OK;
Счетчик = 0;

КонецПроцедуры

//Т.к. обратиться к параметрам сеанса с клиента мы не можем, создаём функцию на сервере

&НаСервере
Функция ВК()

obj = ПолучитьИзВременногоХранилища(ПараметрыСеанса.Obj);
Возврат obj;

КонецФункции


Функция отрабатывает и возвращает пустое значение, ибо COMОбъект между клиентом и сервером не передаётся.
Подскажите, как мне передать COMОбъект.
___________________________________________________________________________________________________________
Пробовал по-другому:

&НаКлиенте
Процедура ДобавитьМетки(Команда)

Obj = ВК();

КонецПроцедуры

&НаСервере
Функция ВК()

obj = Новый COMОбъект("COMRFID.RFID");
obj.StartReading();
  ДобавитьОбработчик obj.TagReading, OK; //Отработала
Счетчик = 0; //Отработала

КонецФункции //Отработала и вернулась в процедуру ДобавитьМетки, вместо того чтобы отправиться в процедуру ОК

&НаСервере
Процедура ОК()

мОбъект = РеквизитФормыВЗначение("Объект");
мОбъект.Проверка(Объект.Ссылка);

КонецПроцедуры

Обратите внимание на комментарии. Есть два варианта решения одной и той же задачи, оба не работают. Мне нужно либо передать компоненту с сервера на клиент в первом варианте, либо заставить работать обработчик во втором варианте. Помогите, пожалуйста.
Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.


Оффлайн LexaK

  • *****
  • Сообщений: 1295
  • РЕПУТАЦИЯ: 356
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
зарегистрируйте ваш КОМ объект на машине с клиентом, переведите режим работы Приложения в Толстый клиент создавайте и используйте КОМ объект на клиенте.
Сам тоже сталкивался несколько раз что на тонком клиенте не работает КОМ объект внешнего соединения, когда СП пишет что должен работать.
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн Golickoff

  • ****
  • Сообщений: 383
  • РЕПУТАЦИЯ: 41
  • КПД: 11%
  • НЕ Есть Null после шести
  • Регистрация: 2015-02-05
  • Сайт: 
  • Профессия: Ученик 1С
...переведите режим работы Приложения в Толстый клиент...
Спасибо, всё работает!
Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.


 

Расчете на сервере с формы. Как вы передаёте реквизиты формы .

Автор andron81_81Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 314
Последний ответ 31 Янв 2018, 14:40
от Norfolk
Есть ли возможность открыть форму на сервере или как передать команду с сервера на клент

Автор KerbertРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 351
Последний ответ 07 Ноя 2017, 16:18
от Kerbert
Конфиг ЗиК Гос 3.1 Когда нажим на стаж вых ошибка - Метод не найден на сервере

Автор Рашид777Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 467
Последний ответ 12 Мар 2017, 22:30
от Рашид777
Установлю 1с на Linux сервере с Web-публикацией с доступом через браузер

Автор village_coderРаздел Резюме

Ответов: 0
Просмотров: 2085
Последний ответ 11 Дек 2014, 16:17
от village_coder
Как уменьшить расход памяти при создании/редактировании документов на сервере

Автор wpostaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1514
Последний ответ 17 Авг 2015, 16:06
от wposta

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
147 Сообщений
oleg-x
66 Сообщений
alex0402
63 Сообщений
AIFrame AIFrame
52 Сообщений
wise wise
37 Сообщений
KOI8-R
34 Сообщений
buketov.av buketov.av
34 Сообщений
Alter
25 Сообщений
trialex3
20 Сообщений
BuhRust
20 Сообщений

* Кто онлайн

  • Точка Гостей: 363
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal