Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 14:47
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Округление в документе реализации  (Прочитано 2584 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Конст_007

  • *
  • Сообщений: 37
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2015-05-25
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день!

Помогите пожалуйста с округлением в документе "РеализацияТоваровУслуг".
УТ 11.1
Необходимо иногда округлять сумму по каждой позиции и Итоговую по документу до рубля. Пробую такую процедуру навешать на кнопку:

&НаКлиенте
//округление суммы по каждой позиции, внесение ручной скидки по позициям и итоговой суммы по округленным суммам
Процедура ОкруглениеСуммПоПозициям(Элемент, ДанныеВыбора, СтандартнаяОбработка)
ТекСтрокаНоменклатура = Элементы.Товары.ТекущиеДанные;
СуммаСОкр = 0;
Для Каждого ТекСтрокаНоменклатура Из Объект.Товары Цикл
ТекСтрокаНоменклатура.Сумма = Окр(ТекСтрокаНоменклатура.Сумма , 0);
ТекСтрокаНоменклатура.СуммаРучнойСкидки =  ТекСтрокаНоменклатура.КоличествоУпаковок * ТекСтрокаНоменклатура.Цена - ТекСтрокаНоменклатура.Сумма ;
СуммаСОкр =  ТекСтрокаНоменклатура.Сумма + СуммаСОкр;
  КонецЦикла;
Объект.СуммаДокумента = СуммаСОкр;
КонецПроцедуры

в табличной части суммы по позициям округляет и копеечные расхождения по позициям ставит правильно, при закрытии все сохраняется.
А вот итоговая сумма по документу не меняется, хотя считается в цикле правильно, проверил.
Если добавляю в конец процедуры:
	ЭтаФорма.СуммаВсего = СуммаСОкр;
Сумма по документу конечно округляется как надо, но не сохраняется :D
Куда все же эту сумму присвоить, помогите плиз.


Оффлайн Rasty

  • *****
  • Сообщений: 989
  • РЕПУТАЦИЯ: 139
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
так может не этаформа, а объект?
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн Конст_007

  • *
  • Сообщений: 37
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2015-05-25
  • Сайт: 
  • Профессия: Ученик 1С
так может не этаформа, а объект?

В том то и дело что в объекте документа нету СуммаВсего,
там есть только СуммаДокумента...
Подскажите куда дальше копать плиз

Оффлайн ilyay

  • 1С:Специалист, 1С:Эксперт
  • ****
  • Сообщений: 473
  • РЕПУТАЦИЯ: 85
  • КПД: 18%
  • Регистрация: 2011-06-09
  • Сайт: 
  • Профессия: Разработчик 1С
Нужно проверить, как называется поле, на которое ссылается элемент формы "СуммаВсего". Скорее всего, он ссылается на "Объект.СуммаДокумента".

Вообще говоря, сумма документа должна всегда присваиваться в ПередЗаписью в модуле объекта.

Оффлайн Конст_007

  • *
  • Сообщений: 37
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2015-05-25
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо за ответы! подтолкнули на правильную мысль.

В общем проблема была как я понял в том, что сумма пересчитывалась еще и с учетом НДС.
Т.к. по факту товар продается без НДС сделал так:

&НаСервере
//Получение значение "ПродажаНеОблагаетсяНДС" для процедуры округления
Функция ФункцНДС()
Возврат Перечисления.ТипыНалогообложенияНДС.ПродажаНеОблагаетсяНДС;
КонецФункции

&НаКлиенте
//округление суммы по каждой позиции, внесение ручной скидки по позициям и итоговой суммы по округленным суммам
Процедура ОкруглениеСуммПоПозициям(Элемент, ДанныеВыбора, СтандартнаяОбработка)
ТекСтрокаНоменклатура = Элементы.Товары.ТекущиеДанные;
СуммаСОкр = 0;
Для Каждого ТекСтрокаНоменклатура Из Объект.Товары Цикл
ТекСтрокаНоменклатура.Сумма = Окр(ТекСтрокаНоменклатура.Сумма , 0);
ТекСтрокаНоменклатура.СуммаРучнойСкидки =  ТекСтрокаНоменклатура.КоличествоУпаковок * ТекСтрокаНоменклатура.Цена - ТекСтрокаНоменклатура.Сумма ;
СуммаСОкр =  ТекСтрокаНоменклатура.Сумма + СуммаСОкр;
  КонецЦикла;
ЭтаФорма.СуммаВсего = СуммаСОкр;
Объект.НалогообложениеНДС = ФункцНДС();
СуммаВсего = СуммаСОкр;
Объект.СуммаДокумента = СуммаСОкр;
НалогообложениеНДСПриИзменении(Элемент);
КонецПроцедуры

Т.е. при запуске процедуры в документе меняется признак учета НДС, после чего проставляется сумма по документу,
после чего прогоняется стандартная процедура НалогообложениеНДСПриИзменении.
Как то так, в общем работает.
 


Теги:
 

заполнение закладки "Материалы" в документе "Поступление из переработки"

Автор Sasa1CРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3594
Последний ответ 10 Июн 2013, 22:34
от Sasa1C
Заполнение табличной части при выборе реквизита другой табличной части в документе.

Автор Vlad-93Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 323
Последний ответ 25 Окт 2017, 14:15
от Vlad-93
УТ 11.В документе "Заявка на расходование денежных средств" нет кнопки "Печать"!

Автор Valery3103Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3760
Последний ответ 29 Июн 2012, 18:37
от LexaK
Как сделать, чтобы поле в документе имело тип "ссылка на поле справочника"?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2037
Последний ответ 05 Мар 2017, 14:36
от Igor100500
Не активно поле ПОЛУЧАТЕЛЬ в документе "выдача наличных" и в "кассовых документах"

Автор Masik777Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 918
Последний ответ 31 Авг 2016, 16:02
от Masik777

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
177 Сообщений
ilyay ilyay
69 Сообщений
alex0402
49 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
41 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal