Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 11:45
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проблема с расчетом суммой.  (Прочитано 1016 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн axial23

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-06-14
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте. Большая просьба помочь мне.... Через неделю диплом защищаю, а у меня в базе проблема серьезная. Не рассчитывается автоматически сумма. Я и код записывал, со всех сайтом и методичек брал пытался под себя подстроить, и модуль дополнительный создавал. ничего не помогает... Прошу помочь, прикреплю скриншот, чтоб было проще объяснить какие реквизиты и табличные части у меня там. Заранее спасибо


Оффлайн crow1983

  • Глобальный модератор
  • *****
  • Сообщений: 438
  • РЕПУТАЦИЯ: 43
  • КПД: 10%
  • Регистрация: 2010-04-26
  • Сайт: 
  • Профессия: Программист 8.1
По моему проблема детская. На картинке видны только реквизиты. Обработчики в студию пожалуйста.
Преподаватель, программист...и просто хороший человек

Оффлайн axial23

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-06-14
  • Сайт: 
  • Профессия: Ученик 1С
По моему проблема детская. На картинке видны только реквизиты. Обработчики в студию пожалуйста.
не делал я никаких обработчиков

Оффлайн crow1983

  • Глобальный модератор
  • *****
  • Сообщений: 438
  • РЕПУТАЦИЯ: 43
  • КПД: 10%
  • Регистрация: 2010-04-26
  • Сайт: 
  • Профессия: Программист 8.1
А как Вы тогда хотите, чтобы сумма сама рассчитывалась? Возьмите книжку Практическое пособие разработчика, там все расписано.
Преподаватель, программист...и просто хороший человек

Оффлайн Prosper

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-15
  • Сайт: 
&НаКлиенте
Процедура ТабличнаяЧасть1КоличествоПриИзменении(Элемент)
   
    ТД = Элементы.ТабличнаяЧасть1.ТекущиеДанные;
    ТД.Сумма     = ТД.Количество*ТД.Цена;   

КонецПроцедуры
Аналогично при изменении цены и, если нужно, то и суммы. Но при изменении суммы нужно учитывать, что не 0 делить нельзя и делать проверку.

&НаКлиенте
Процедура ТабличнаяЧасть1СуммаПриИзменении(Элемент)
   
    ТД = Элементы.ТабличнаяЧасть1.ТекущиеДанные;
    Если ТД.Количество <>0 Тогда
        ТД.Цена = ТД.Сумма /ТД.Количество;
    Инача
        ТД.Цена =0;
    КонецЕсли;
КонецПроцедуры

Оффлайн crow1983

  • Глобальный модератор
  • *****
  • Сообщений: 438
  • РЕПУТАЦИЯ: 43
  • КПД: 10%
  • Регистрация: 2010-04-26
  • Сайт: 
  • Профессия: Программист 8.1
Я в шоке. Человек диплом защищает, а не имеет понятие про элементарный код. Или он думает, что 1С Предприятие это конструктор, который сам должен читать мысли разработчика))
Преподаватель, программист...и просто хороший человек

Оффлайн pavl_vs

  • *****
  • Сообщений: 1069
  • РЕПУТАЦИЯ: 168
  • КПД: 16%
  • Регистрация: 2011-05-09
  • Сайт: 
  • Профессия: Программист 7.7
axial23, во-первых, какая-то незаконченность ТЧ.

Во-вторых, когда появится строка в ТЧ, станьте на реквизит, допустим, "Цена" и правой клавишей мыши выберите "Свойство";
затем перейдите в окно свойств, спуститесь вниз в раздел "События", выберите "ПриИзменении", нажмите значок "лупа" -
будет создана заготовка процедуры обработки события, т.е. изменения реквизита.

Эту процедуру Вам предстоит записать своими ручками, воспользовавшись советом Prosper #4, либо
http://1c-pro.ru/threads/problema-s-raschetom-summy.54516/ (Ваша тема).


Теги:
 

Проблема с выгрузкой НН в "Звит" Не найдено соответствие для схемы "J1201008"

Автор AldemaHРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1179
Последний ответ 06 Июл 2016, 09:19
от AldemaH
проблема с "ЗагрузкаДанныхИзТабличногоДокумента"

Автор bratmaratРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4706
Последний ответ 08 Янв 2014, 14:30
от LordWizard
Проблема с развертыванием окон и сохранением окон

Автор SokresРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2432
Последний ответ 09 Дек 2015, 14:09
от pavl_vs
Проблема с отчетом "Перемещение товаров"

Автор sailРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3325
Последний ответ 14 Дек 2010, 20:27
от progmikon
1C 8.2 УПП проблема с отчетом "Задолженость по контрагентам"

Автор LeonidLeonidРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3586
Последний ответ 26 Сен 2011, 20:42
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
177 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
alex0402
44 Сообщений
andron81_81
38 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 822
  • Точка Скрытых: 0
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal