Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
16 сен 2021, 18:48

Как добраться - программно! - до стандартной команды Удаление помеченных объектов?

Автор ПростоБосс, 11 июн 2015, 18:06

0 Пользователей и 1 гость просматривают эту тему.

ПростоБосс

Собственно весь вопрос в теме. Лень писать обработку, но, поскольку для ряда пользователей не желательно открывать доступ к "все функции", хотелось бы как-то программным путем добраться до стандартной команды самой платформы. Вот и вопрос: возможно это сделать?

Rasty

Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

ПростоБосс

Цитата: Rasty от 11 июн 2015, 18:52
Есть роль ВсеФункции
И что? Как это мне поможет программно, из кода до нее добраться? Смысл, повторяю, в том, что пользователю доступ ко "всем функциям" закрыт, а удалять помеченные на удаление нужно? Можно, конечно написать обработку по типу, как в БСП, но лениво - есть ведь нормальный механизм самой платформы. А вот как до него добраться не мышкой, а из кода - не пойму.:dfbsdfbsdf:

LexaK

саму обработку, удаление помеченных объектов, выведите в интерфейс пользователя,
в какую нибудь из областей
в справочники,
в сервис,
в администрирование
т.д.
в виде команды оформите.
Добавлено: 13 июн 2015, 09:08


сделайте по примеру как в УТ11
ответ Понравился? (в смысле пригодился?)

ПростоБосс

LexaK, Как разместить команду, обработку или справочник в командном интерфейсе я прекрасно знаю. Тот пример, что вы привели - это пример использования БСП (библиотеки стандартных подсистем). Там имеется соответствующая обработка. Я же написал - и пишу еще раз - что требуется программно добраться до системного, т.е. самой платформы!, механизма удаления. Именно до того, который можно вызвать через [все функции - стандартные - удаление помеченных объектов], но программно. Нигде в документации этот механизм не описан, к моему большому сожалению.:( 

MelAR

а что мешает использовать процедуры и функции глобального контекста?

// удаление помеченных объектов с контролем ссылочной целостности
Помеченные = НайтиПомеченныеНаУдаление();
Найденные = 0;
УдалитьОбъекты(Помеченные, Истина, Найденные);
Для каждого Ссылка из Найденные Цикл
    СтрСообщения = "Объект не удален: " + СокрЛП(Ссылка[0]);
    СтрСсылка = ", используется в " + СокрЛП(Ссылка[1]);
    Сообщить (СтрСообщения + СтрСсылка);
КонецЦикла;


ПростоБосс

MelAR, Ничего не мешает. Просто все это нужно оформлять обработкой, а как уже сказал - лениво, т.к. другой писанины выше крыши. Но раз уж никто не знает - придется писать обработку как положено - с выводом списков помеченных, списком ссылок на них и т.д. и т.п.

AIFrame

Побуду некропостером, таки ссылка в гугле первая по запросу.
&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
    ПодключитьВнешнююОбработкуНаСервере();
    ОткрытьФорму("ВнешняяОбработка.StandardDeleteMarkedObjects.Форма");
КонецПроцедуры

&НаСервере
Процедура ПодключитьВнешнююОбработкуНаСервере()
    ВнешниеОбработки.Подключить("v8res://mngbase/StandardDeleteMarkedObjects.epf", "StandardDeleteMarkedObjects", false);
КонецПроцедуры

//1. Активные пользователи - "v8res://mngbase/StandardActiveUsers.epf";
//2. Журнал регистрации - "v8res://mngbase/StandardEventLog.epf";
//3. Поиск ссылок на объект - "v8res://mngbase/StandardFindByRef.epf";
//4. Проведение документов - "v8res://mngbase/StandardDocumentsPosting.epf";
//5. Удаление помеченных объектов - "v8res://mngbase/StandardDeleteMarkedObjects.epf";
//6. Управление внешними источниками данных - "v8res://mngbase/StandardExternalDataSourcesManagement.epf";
//7. Управление итогами - "v8res://mngbase/StandardTotalsManagement.epf";
//8. Управление полнотекстовым поиском - "v8res://mngbase/StandardFullTextSearchManagement.epf";
//9. Управление расширениями конфигурации - "v8res://mngbase/StandardExtensionsManagement.epf";

Вот так они открываются.

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск