Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 21:02
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Стандартная процедура печати в 1С8.2  (Прочитано 1990 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн LavrS

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-25
  • Сайт: 
  • Профессия: Программист 8.1
Здравствуйте, есть справочник Инвентаризация (список оборудования с инв. номерами, ценами и тд.) с реквизитами, после формирования стандартной процедуры печати​ каждая запись выводится отдельно с заголовком. Подскажите пожалуйста способ вывода на печать в виде таблицы?


&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
 //{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)
ТабДок = Новый ТабличныйДокумент;
Печать(ТабДок, ПараметрКоманды);

ТабДок.ОтображатьСетку = Ложь;
ТабДок.Защита = Ложь;
ТабДок.ТолькоПросмотр = Ложь;
ТабДок.ОтображатьЗаголовки = Ложь;
ТабДок.Показать();
 //}}
КонецПроцедуры

&НаСервере
Процедура Печать(ТабДок, ПараметрКоманды)
Справочники.Инвентаризация.Печать(ТабДок, ПараметрКоманды);
КонецПроцедуры




Процедура Печать(ТабДок, Ссылка) Экспорт
   //{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)
   Макет = Справочники.Инвентаризация.ПолучитьМакет("Печать");
   Запрос = Новый Запрос;
   Запрос.Текст =
   "ВЫБРАТЬ
   |   Инвентаризация.Амортизация,
   |   Инвентаризация.БалансоваяСтоимость,
   |   Инвентаризация.ДатаПриобретения,
   |   Инвентаризация.ИнвентарныйНомер,
   |   Инвентаризация.МатериальноеЛицо,
   |   Инвентаризация.НаименованиеОС,
   |   Инвентаризация.НаименованиеФилиала,
   |   Инвентаризация.ПодразделениеФилиала,
   |   Инвентаризация.Стоимость
   |ИЗ
   |   Справочник.Инвентаризация КАК Инвентаризация
   |ГДЕ
   |   Инвентаризация.Ссылка В (&Ссылка)";
   Запрос.Параметры.Вставить("Ссылка", Ссылка);
   Выборка = Запрос.Выполнить().Выбрать();

   ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
   Шапка = Макет.ПолучитьОбласть("Шапка");
   ТабДок.Очистить();

   ВставлятьРазделительСтраниц = Ложь;
   Пока Выборка.Следующий() Цикл
      Если ВставлятьРазделительСтраниц Тогда
         ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
      КонецЕсли;

      ТабДок.Вывести(ОбластьЗаголовок);

      Шапка.Параметры.Заполнить(Выборка);
      ТабДок.Вывести(Шапка, Выборка.Уровень());

      ВставлятьРазделительСтраниц = Истина;
   КонецЦикла;
   //}}
КонецПроцедуры


Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
...    
ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
   Шапка = Макет.ПолучитьОбласть("Шапка");
   ТабДок.Очистить();

     ТабДок.Вывести(ОбластьЗаголовок);

   Пока Выборка.Следующий() Цикл
       

      Шапка.Параметры.Заполнить(Выборка);
      ТабДок.Вывести(Шапка, Выборка.Уровень());     
   КонецЦикла;
   //}}
КонецПроцедуры

Ну и конечно макет подправить под таблицу

Оффлайн LavrS

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-25
  • Сайт: 
  • Профессия: Программист 8.1
Благодарю за помощь, сделал так:
Процедура Печать(ТабДок, Ссылка) Экспорт
   //{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)
   Макет = Справочники.Инвентаризация.ПолучитьМакет("Печать");
   Запрос = Новый Запрос;
   Запрос.Текст =
   "ВЫБРАТЬ
   |   Инвентаризация.Амортизация,
   |   Инвентаризация.БалансоваяСтоимость,
   |   Инвентаризация.ДатаПриобретения,
   |   Инвентаризация.ИнвентарныйНомер,
   |   Инвентаризация.МатериальноеЛицо,
   |   Инвентаризация.НаименованиеОС,
   |   Инвентаризация.НаименованиеФилиала,
   |   Инвентаризация.ПодразделениеФилиала,
   |   Инвентаризация.Стоимость
   |ИЗ
   |   Справочник.Инвентаризация КАК Инвентаризация
   |ГДЕ
   |   Инвентаризация.Ссылка В (&Ссылка)";
   Запрос.Параметры.Вставить("Ссылка", Ссылка);
   Выборка = Запрос.Выполнить().Выбрать();

   ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
   ОбластьШапка = Макет.ПолучитьОбласть("Шапка");
   Шапка = Макет.ПолучитьОбласть("Таблица");
   ТабДок.Очистить();
    ТабДок.Вывести(ОбластьЗаголовок);
   ТабДок.Вывести(ОбластьШапка);
   ВставлятьРазделительСтраниц = Ложь;
   Пока Выборка.Следующий() Цикл
            

      Шапка.Параметры.Заполнить(Выборка);
      ТабДок.Вывести(Шапка, Выборка.Уровень());

      КонецЦикла;
   //}}
КонецПроцедуры


Теги:
 

Синтаксическая ошибка "ИЗ" <<?>>ИЗ при печати счета ут 10.3

Автор romanprogrammistРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4028
Последний ответ 02 Дек 2013, 14:42
от romanprogrammist
В при печати формы не заполняется поле "заказчик"

Автор senqsРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 3720
Последний ответ 02 Окт 2013, 12:03
от LordWizard
Ошибка печати "Метод объекта не обнаружен"

Автор Роза ГамильтоновнаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3812
Последний ответ 06 Июн 2014, 10:32
от wise
Ошибка при печати внешней формы "Поле объекта не обнаружено" папка Сотрудники

Автор sershovaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 4185
Последний ответ 14 Окт 2014, 16:43
от leksv
Печать штрих кодов на форму печати выводятся 3 штрих кода на принтер выходит только 2.

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 508
Последний ответ 15 Май 2017, 08:59
от ZSS

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
69 Сообщений
alex0402
54 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 268
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal