Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 05:42
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Открытие формы выбора с выделенным выбором  (Прочитано 892 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Andersen1313

  • *
  • Сообщений: 17
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-24
  • Сайт: 
Здравствуйте!

Суть задачи:

Через открытие формы выбора в режиме множественного выбора, заполняю табличную часть справочника.

Вот код:

&НаКлиенте
Процедура ЖанрыНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
ПараметрыФормы = Новый Структура;
ПараметрыФормы.Вставить("МножественныйВыбор", Истина);
ОткрытьФорму("Справочник.Жанры.ФормаВыбора", ПараметрыФормы, Элементы.Жанры);
КонецПроцедуры

&НаКлиенте
Процедура ЖанрыОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
ЖанрыОбработкаВыбораНаСервере(ВыбранноеЗначение);
КонецПроцедуры

&НаСервере
Процедура ЖанрыОбработкаВыбораНаСервере(ВыбранноеЗначение)
Для Каждого ВыбранныйЭлемент Из ВыбранноеЗначение Цикл
ВыбранныйЭлементОбъект = ВыбранныйЭлемент.ПолучитьОбъект();
Жанры = Жанры + ВыбранныйЭлементОбъект.Наименование;
ПараметрыОтбора = Новый Структура;
ПараметрыОтбора.Вставить("Название", ВыбранныйЭлемент);
Если (Объект.Жанры.НайтиСтроки(ПараметрыОтбора).Количество() = 0) Тогда
СтрокаЖанры = Объект.Жанры.Добавить();
СтрокаЖанры.Название = ВыбранныйЭлемент;
КонецЕсли;
КонецЦикла;
КонецПроцедуры

Суть проблемы:

Как при повторном открытии формы выбора, выделить в ней строки, которые уже были выбраны ранее в табличную часть?



Оффлайн Дмитрий@

  • *****
  • Сообщений: 735
  • РЕПУТАЦИЯ: 134
  • КПД: 18%
  • Ссылка на примеры работ https://yadi.sk/d/ksVluPMB
  • Регистрация: 2015-02-27
    • Skype: ShuplecovDima
  • Сайт: 
  • Профессия: Программист 1С
Воспользуйтесь в "Списке" свойством "ВыделенныеСтроки".
Ссылка на примеры работ https://yadi.sk/d/ksVluPMB

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
ВыбранныйЭлементОбъект = ВыбранныйЭлемент.ПолучитьОбъект();
Жанры = Жанры + ВыбранныйЭлементОбъект.Наименование;

объясните ЭТО

Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
передать в форму выбора текущий массив жанров из ТЧ
и потом программно настроить условное оформление.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Andersen1313

  • *
  • Сообщений: 17
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-24
  • Сайт: 
ВыбранныйЭлементОбъект = ВыбранныйЭлемент.ПолучитьОбъект();
Жанры = Жанры + ВыбранныйЭлементОбъект.Наименование;

объясните ЭТО

Тут я текстовое представление всех жанров получаю. Чтобы просто в текстовое поле через запятую вывести все жанры. Тут как видно все жанры просто слепятся в одно слово, я уже исправил это..


Теги:
 

Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 291
Последний ответ 21 Сен 2017, 10:33
от Insider
Редактирование формы "Настройки пользователя".

Автор t955938Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4814
Последний ответ 03 Авг 2011, 11:45
от t955938
получаю значение реквизита формы, дает значение 0

Автор mikel10Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3410
Последний ответ 12 Июл 2013, 15:35
от mikel10
Как обратиться к функции модуля формы из модуля Менеджера?

Автор TreeDogNightРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4993
Последний ответ 10 Июл 2014, 14:05
от cska-fanat-kz
Настройка формы "Заполнение товаров"

Автор ЖаннаРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 585
Последний ответ 10 Мар 2017, 21:00
от Жанна

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
175 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
AIFrame
39 Сообщений
andron81_81
38 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 282
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal