Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 19:42
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проблема с выгрузкой периодического реквизита  (Прочитано 1326 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн slimuz

  • *
  • Сообщений: 28
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-06-02
  • Сайт: 
Здравствуйте!
Необходимо выгрузить Основные средства в DBF, написаной обработкой выгружаю код, наименование, дата приобретения, дата ввода в эксплуатацию, дата выбытия, но первоначальная стоимость выгружается с нулевым значением.
Процедура ПриОткрытии()
ДатаПер=РабочаяДата(); Загрузка=1;
КонецПроцедуры

Процедура ВыгрузкаОС()
Перем Запрос, ТекстЗапроса, Таб;
Каталог ="d:\";
ИмяФайла = "OC.dbf";
ДБФ = СоздатьОбъект("XBase");
ДБФ.ДобавитьПоле("kod","s",10,0);
ДБФ.ДобавитьПоле("name","s",63,);
ДБФ.ДобавитьПоле("p_stoim","n",15,);
ДБФ.ДобавитьПоле("d_preobr","s",12,);
ДБФ.ДобавитьПоле("d_vvoda","s",12,);
ДБФ.ДобавитьПоле("spisanie","s",12,);

Если ПустоеЗначение(Каталог)=1 Тогда
Сообщить("Ошибка! Не выбран каталог!");
Возврат;
КонецЕсли;

ДБФ.СоздатьФайл(Каталог+"\"+ИмяФайла);
Если ДБФ. Открыта() = 0 Тогда
Предупреждение("Невозможно создать файл!!!",60);
Возврат;
КонецЕсли;

ДБФ.АвтоСохранение(1);

СпрОС=СоздатьОбъект("Справочник.ОсновныеСредства");

// СпрОС.ИспользоватьДату(ТекущаяДата()); 
СпрОС.ИспользоватьДату(ДатаПер,1);

Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)
|спОС = Справочник.ОсновныеСредства.ТекущийЭлемент;
|Группировка спОС Без Групп;
|"//}}ЗАПРОС
;
// Если ошибка в запросе, то выход из процедуры
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Сообщить("Запрос не выполнен");
Возврат;
КонецЕсли;

ТЗ = СоздатьОбъект("ТаблицаЗначений");
Запрос.Выгрузить(ТЗ);


ТЗ.ВыбратьСтроки();
К=1;
Пока ТЗ.ПолучитьСтроку()=1 Цикл
Если (ТЗ.спОС.ЭтоГруппа()=1) ИЛИ (ПустоеЗначение(ТЗ.спОС)=1)  Тогда
Продолжить;
КонецЕсли;

ДБФ.Добавить();
ДБФ.kod=СокрЛП(ТЗ.спОС.Код);
ДБФ.name =СокрЛП(ТЗ.спОС.Наименование); 
ДБФ.p_stoim =СокрЛП(ТЗ.спОС.ПервоначальнаяСтоимость);
ДБФ.d_preobr =СокрЛП(ТЗ.спОС.ДатаПриобретения);
ДБФ.d_vvoda =СокрЛП(ТЗ.спОС.ДатаВводаВЭксплуатацию);
ДБФ.spisanie =СокрЛП(ТЗ.спОС.ДатаВыбытия);

К=К+1;
КонецЦикла; 

ДБФ.ЗакрытьФайл(); 

Сообщить("ОС выгружены успешно!");
Сообщить("Выгружено: " + К + " (а)(ов)");
КонецПроцедуры


Оффлайн slimuz

  • *
  • Сообщений: 28
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-06-02
  • Сайт: 
Оказывается надо было написать: ТЗ.спОС.ПервоначальнаяСтоимость.Получить()
или ТЗ.спОС.ПервоначальнаяСтоимость.Получить(НужнаяДата)

Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
Ну и еще в  гору тогда :
ты получишь ПервоначальнаяСтоимость на дату ТА тогда,
т.к. дату в получении не указываешь, а тебе надо судя по тексту "ДатаПер"
тобишь   типа    :         Получить(ДатаПер)


э-э-э- я так думаю...      <_<


Теги: выгрузка dbf 
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
141 Сообщений
AIFrame
71 Сообщений
ilyay ilyay
65 Сообщений
alex0402
52 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
31 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 347
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal