Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
27 Май 2018, 18:38
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: изменение шрифта в отдельной ячейке табличной части  (Прочитано 1614 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Sandi

  • Hit any key to continue
  • **
  • Сообщений: 65
  • РЕПУТАЦИЯ: 7
  • КПД: 11%
  • Регистрация: 2015-02-25
  • Сайт: 
Добрый день, форумчане!

снова нужна ваша помощь.

дано:
управляемая форма с табличной частью.

надо:
в табличной части нужно в зависимости от условий выделить жирным шрифтом отдельные ячейки.


То что получилось у меня (см. ниже) делает жирным шрифт во всем столбце "Коэффициент"

&НаКлиенте
Процедура КоэффициентОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
        СтандартнаяОбработка = Ложь;
МинимальноеЗначение =  РассчитатьМинимальноеЗначение();
Если ВыбранноеЗначение < МинимальноеЗначение Тогда
Если Вопрос ("Не рекомедуется использовать значение меньше, чем "+Строка(Окр(МинимальноеЗначение,2,1))+". Все равно продолжить?",РежимДиалогаВопрос.ДаНет)=КодВозвратаДиалога.Да Тогда; 
   Элементы.Таблица.ТекущиеДанные.Коэффициент = ВыбранноеЗначение;
                   ЖирныйШрифт = Истина;
Иначе
Элементы.Таблица.ТекущиеДанные.Коэффициент = Неопределено;
         ЖирныйШрифт=Ложь;
КонецЕсли;
Иначе

Элементы.Таблица.ТекущиеДанные.Коэффициент = ВыбранноеЗначение;
        ЖирныйШрифт=Ложь;
КонецЕсли;

 Элементы.Таблица.ТекущийЭлемент.Шрифт = ПолучитьШрифт(ЖирныйШрифт);
КонецПроцедуры


&НаСервереБезКонтекста
Функция ПолучитьШрифт(ЖирныйШрифт)
ШрифтЭлемента = Новый Шрифт(,,ЖирныйШрифт,,,,);
Возврат ШрифтЭлемента;
КонецФункции

Вопрос: Как ограничить выбор шрифта только для конкретной строки этого столбца?
Пробовала  такой вариант:
Элементы.Таблица.ТекущаяСтрока.ТекущийЭлемент.Шрифт = ПолучитьШрифт(ЖирныйШрифт);
и такой:
 Элементы.Таблица.ТекущиеДанные.ТекущийЭлемент.Шрифт = ПолучитьШрифт(ЖирныйШрифт);

выдает ошибку.:dfbbdrfb:
 


Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
А чем условное оформление не подходит? В зависимости от вашего минимального значение накладываете условное оформлению по шрифту.

Оффлайн Sandi

  • Hit any key to continue
  • **
  • Сообщений: 65
  • РЕПУТАЦИЯ: 7
  • КПД: 11%
  • Регистрация: 2015-02-25
  • Сайт: 
А чем условное оформление не подходит? В зависимости от вашего минимального значение накладываете условное оформлению по шрифту.
а про условное оформление я  как-то не подумала, пойду смотреть.
Спасибо!


Теги:
 

"Уникальность" строки таблиной части документа

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2374
Последний ответ 20 Авг 2014, 12:22
от has
Работа с табличной частью в документе. Или Работа с ШАПКОЙ документа

Автор gorbach178500Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3328
Последний ответ 30 Сен 2011, 20:01
от gorbach178500
Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 525
Последний ответ 12 Окт 2017, 14:02
от wise
Как запретить пользователям с интерфейсом "Ввод табеля" изменение графы профессия у подобранного сотрудника в сдельном наряде и табеле учета рабочего времени

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1352
Последний ответ 15 Сен 2016, 02:46
от ksander-fars
УТ 11ред. Есть ли возможность указать серии в заказе покупателя?( в табл. части)

Автор tsaboevРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3434
Последний ответ 02 Июл 2012, 13:11
от totutotam

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
alex0402
67 Сообщений
oleg-x
56 Сообщений
AIFrame AIFrame
56 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
41 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
alexandr_ll
30 Сообщений

* Кто онлайн

  • Точка Гостей: 225
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal