Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
27 Май 2018, 22:34
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Форма документа Реализация товаров и услуг УПП  (Прочитано 861 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Iric28

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 2
  • КПД: 20%
  • Регистрация: 2014-11-07
  • Сайт: 
  • Профессия: Ученик 1С
Помогите разобраться.Процедура
&НаКлиенте
Процедура УстановитьОграничениеТипаСделки()
   Если ДоговорПоСчетам Тогда
      ОписаниеТипаСделки = Новый ОписаниеТипов("ДокументСсылка.СчетНаОплатуПокупателю");
   Иначе
      ОписаниеТипаСделки = Новый ОписаниеТипов("ДокументСсылка.ЗаказПокупателя");
   КонецЕсли;
   Элементы.Сделка.ОграничениеТипа = ОписаниеТипаСделки;
   Если НЕ ОписаниеТипаСделки.СодержитТип(ТипЗнч(Объект.Сделка)) Тогда
      Объект.Сделка = ОписаниеТипаСделки.ПривестиЗначение(Объект.Сделка);
   КонецЕсли;
КонецПроцедуры

Выходит ошибка, что поле "Сделка" недоступно для записи. Проверка идет при открытии формы.
У пользователя права только на чтение/просмотр. Что необходимо сделать, чтобы форма открылась?


Оффлайн Rasty

  • *****
  • Сообщений: 997
  • РЕПУТАЦИЯ: 141
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
хню написал, не прочитал до конца, может документ не доступен для редактирования?
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4862
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 17259
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4778
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1202
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 8281
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
alex0402
67 Сообщений
AIFrame AIFrame
57 Сообщений
oleg-x
56 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
41 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
KOI8-R
30 Сообщений

* Кто онлайн

  • Точка Гостей: 253
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal