Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 07:30
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Не пересчитывается сумма в документе "Акт выполненных работ"  (Прочитано 1241 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Yurdmis

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-06-01
  • Сайт: 
  • Профессия: Программист 1С
Здравствуйте! Надеюсь кто-нибудь сможет помочь, или направить в нужную сторону... :)

1С 8.3, УТ 11. Нужно что-бы автоматически, программно, создавался документ - Акт выполненных работ.
Сделал, создаётся. Но возникает проблемка - сумма справа внизу при таком способе создания документа почему-то не пересчитывается. :(

При этом стоит только поменять что-то в документе опять вручную, как сразу же всё пересчитывается нормально. Уже голову сломал, не могу понять где что искать :(

Заранее спасибо!


Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
там где создаете документ вставьте примерно такие строки, (посмотрите в своем конфигураторе)

   СуммаДокумента = ЦенообразованиеКлиентСервер.ПолучитьСуммуДокумента(Услуги, ЦенаВключаетНДС);
   ЗаполнитьСуммуВзаиморасчетов();
   Ценообразование.РассчитатьСуммыВзаиморасчетовВТабличнойЧасти(ЭтотОбъект, "Услуги");

Добавлено: 02 Июн 2015, 17:44

я имел ввиду можно и самому расчитать и заполнить реквизиты документа, такие как
СуммаДокумента,
СуммаВзаиморасчетов,
и другие нужные

Услуги.Итог...

при изменении формы отрабатывает эта функция
Процедура РассчитатьИтоговыеПоказателиАктовВыполненныхРабот(Форма)

СуммаВсего = Форма.Объект.Услуги.Итог("Сумма");
Форма.СуммаАвтоСкидки   = Форма.Объект.Услуги.Итог("СуммаАвтоматическойСкидки");
Форма.СуммаРучнойСкидки = Форма.Объект.Услуги.Итог("СуммаРучнойСкидки");
Форма.СуммаСкидки       = Форма.СуммаАвтоСкидки + Форма.СуммаРучнойСкидки;

Если СуммаВсего > 0 Тогда

Форма.ПроцентАвтоСкидки   = Форма.СуммаАвтоСкидки * 100 / (СуммаВсего + Форма.СуммаСкидки);
Форма.ПроцентРучнойСкидки = Форма.СуммаРучнойСкидки * 100 / (СуммаВсего + Форма.СуммаСкидки);
Форма.ПроцентСкидки       = Форма.ПроцентАвтоСкидки + Форма.ПроцентРучнойСкидки;

ИначеЕсли Форма.СуммаСкидки > 0 Тогда

Форма.ПроцентАвтоСкидки   = Форма.СуммаАвтоСкидки * 100 / Форма.СуммаСкидки;
Форма.ПроцентРучнойСкидки = Форма.СуммаРучнойСкидки * 100 / Форма.СуммаСкидки;
Форма.ПроцентСкидки       = Форма.ПроцентАвтоСкидки + Форма.ПроцентРучнойСкидки;

Иначе

Форма.ПроцентАвтоСкидки   = 0;
Форма.ПроцентРучнойСкидки = 0;
Форма.ПроцентСкидки       = 0;

КонецЕсли;

Форма.СуммаВсего = Форма.Объект.Услуги.Итог("СуммаСНДС");

Если Форма.Объект.НалогообложениеНДС = ПредопределенноеЗначение("Перечисление.ТипыНалогообложенияНДС.ПродажаНеОблагаетсяНДС") Тогда
Форма.Элементы.ГруппаСтраницыНДС.ТекущаяСтраница   = Форма.Элементы.СтраницаБезНДС;
Форма.Элементы.ГруппаСтраницыВсего.ТекущаяСтраница = Форма.Элементы.СтраницаВсегоБезНДС;
Иначе
Форма.Элементы.ГруппаСтраницыНДС.ТекущаяСтраница   = Форма.Элементы.СтраницаСНДС;
Форма.Элементы.ГруппаСтраницыВсего.ТекущаяСтраница = Форма.Элементы.СтраницаВсегоСНДС;
КонецЕсли;

КонецПроцедуры // РассчитатьИтоговыеПоказателиАктовВыполненныхРабот()
Помогло? - Нажми СПАСИБО!!!
                       :)

Последний раз редактировалось: LexaK; 02 Июн 2015, 17:44. Причина: Объединение сообщений

Оффлайн Yurdmis

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-06-01
  • Сайт: 
  • Профессия: Программист 1С
Спасибо за ответ!
Но, к сожалению, не помогло. :(
Сделал как вы написали, но ничего так и не изменилось...

Онлайн Golickoff

  • ****
  • Сообщений: 357
  • РЕПУТАЦИЯ: 35
  • КПД: 10%
  • Регистрация: 2015-02-05
  • Сайт: 
  • Профессия: Ученик 1С
Открой форму в конфигураторе, посмотри как называется реквизит с суммой. После этого открой модуль формы и поищи этот реквизит в нём. Скорее всего, он будет в какой-нибудь процедуре типа ПриИзменении, или ПередЗаписью. Если нашёл -- перепиши код расчёта суммы в процедуру формирования этого документа. Если не нашёл, тогда ищи в модуле документа, а не формы.
Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.

Оффлайн Yurdmis

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-06-01
  • Сайт: 
  • Профессия: Программист 1С
Открой форму в конфигураторе, посмотри как называется реквизит с суммой. После этого открой модуль формы и поищи этот реквизит в нём. Скорее всего, он будет в какой-нибудь процедуре типа ПриИзменении, или ПередЗаписью. Если нашёл -- перепиши код расчёта суммы в процедуру формирования этого документа. Если не нашёл, тогда ищи в модуле документа, а не формы.

Это понятно. Проблема как раз и заключается в том, что ничего подходящего найти не получается, в том числе и там. :(
Добавлено: 04 Июн 2015, 05:52

Разобрался, всем спасибо :)

Последний раз редактировалось: Yurdmis; 04 Июн 2015, 05:52. Причина: Объединение сообщений


Теги: Сумма итого УТ 11 
 

Заполнение табличной части при выборе реквизита другой табличной части в документе.

Автор Vlad-93Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 313
Последний ответ 25 Окт 2017, 14:15
от Vlad-93
Работа с табличной частью в документе. Или Работа с ШАПКОЙ документа

Автор gorbach178500Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3054
Последний ответ 30 Сен 2011, 20:01
от gorbach178500
Если в платежном документе не указан период оплаты, Пенсионный фонд закроет старые долги

Автор newsРаздел Новости

Ответов: 0
Просмотров: 1554
Последний ответ 24 Июл 2014, 13:42
от news
Необходимо изменить поле Номенклатурная группа у каждого товара в каждом документе Реализация товаров.

Автор Эдуард МагаданРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2450
Последний ответ 09 Ноя 2015, 07:18
от cska-fanat-kz
1c 8.2: управляемое приложение: как вызвать свою процедуру в документе при событии выбора значения из справочника

Автор jhd235Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1715
Последний ответ 13 Сен 2014, 14:00
от TreeDogNight

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 379
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal