Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 18:31
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Свойства Констант  (Прочитано 674 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн neromont

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-06-02
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте.
Только начал изучать 1С.
Помогите разобраться, почему не выводится сообщение?

Процедура Выполнить()	
Для i=1 По Метаданные.Константа() Цикл   
    Если ВводИмени = Метаданные.Константа(i).Синоним Тогда
Сообщить("СОВПАЛО");      
КонецЕсли;
КонецЦикла;
КонецПроцедуры


Оффлайн neromont

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-06-02
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте.
Только начал изучать 1С.
Помогите разобраться, почему не выводится сообщение?

Процедура Выполнить()	
Для i=1 По Метаданные.Константа() Цикл   
    Если ВводИмени = Метаданные.Константа(i).Синоним Тогда
Сообщить("СОВПАЛО");      
КонецЕсли;
КонецЦикла;
КонецПроцедуры

Сам разобрался

 Если СокрЛП(ВводИмени) = СокрЛП(Метаданные.Константа(i).Синоним)


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
163 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 451
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal