Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 10:29
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Не заполняет внешний набор данных  (Прочитано 981 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mashencev_anton

  • ****
  • Сообщений: 315
  • РЕПУТАЦИЯ: 6
  • КПД: 2%
  • Регистрация: 2012-12-05
  • Сайт: 
  • Профессия: Программист 1С
у меня тупняк((( выручайте подскажите плиз. Внешняя обработка с двумя формами. В первой заполняется ТЧ,потом по кнопке открывается вторая форма с табличным документом (Отчет). проблема в том что Номенклатура не передается.
код с первой формы
&НаКлиенте
Процедура СформироватьОтчет(Команда)
КомандаНаСервере();
структура=Новый Структура;
Структура.Вставить("ТипЦен",Объект.ТипЦен);
Форм = ПолучитьФорму("ВнешняяОбработка.АнализПрайсаПоставщика.Форма.ФормаОтчета",Структура,ЭтотОбъект);
Форм.Открыть();
   
КонецПроцедуры

&НаСервере
Процедура КомандаНаСервере()

ОбъектОбработка = РеквизитФормыВЗначение("Объект");
    ОбъектОбработка.СформироватьОтчетНаСервере();
   
КонецПроцедуры
Код из модуля объекта
Процедура  СформироватьОтчетНаСервере()   Экспорт 

ТЗ = товары.Выгрузить(,"Атрикул,Номенклатура,ЦенаИзПрайса");

    ВнешниеНаборыДанных = Новый Структура;
ВнешниеНаборыДанных.Вставить("ТЗ",ТЗ);
         
СхемаКомпоновкиДанных =ЭтотОбъект.ПолучитьМакет("МакетОбработки");
НайденныйПараметр=СхемаКомпоновкиДанных.Параметры.Найти("ТипЦен");
НайденныйПараметр.Значение=ТипЦен;
Настройки = СхемаКомпоновкиДанных.НастройкиПоУмолчанию;

ПользовательскиеНастройкиКД=Новый ПользовательскиеНастройкиКомпоновкиДанных;
ДопНастройки=ПользовательскиеНастройкиКД.ДополнительныеНастройки;

КомпоновщикНастроекДанных = Новый КомпоновщикНастроекКомпоновкиДанных;
КомпоновщикНастроекДанных.Инициализировать(Новый ИсточникДоступныхНастроекКомпоновкиДанных(СхемаКомпоновкиДанных));
КомпоновщикНастроекДанных.ЗагрузитьНастройки(СхемаКомпоновкиДанных.НастройкиПоУмолчанию);
КомпоновщикНастроекДанных.ЗагрузитьПользовательскиеНастройки(ДопНастройки);

КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, Настройки);

ПроцессорКомпоновкиДанных = Новый ПроцессорКомпоновкиДанных;
ПроцессорКомпоновкиДанных.Инициализировать(МакетКомпоновки,ВнешниеНаборыДанных);

ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
ПроцессорВывода.УстановитьДокумент(ЭтотОбъект.ТабДок);
ПроцессорВывода.Вывести(ПроцессорКомпоновкиДанных);

КонецПроцедуры
Код из второй формы(отчет):
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
Если Параметры.Свойство("ТипЦен")  Тогда
    Объект.ТипЦен = Параметры.ТипЦен;
КонецЕсли;

Рек = РеквизитФормыВЗначение("Объект");
Рек.СформироватьОтчетНаСервере();

КонецПроцедуры


Оффлайн Дмитрий@

  • *****
  • Сообщений: 735
  • РЕПУТАЦИЯ: 134
  • КПД: 18%
  • Ссылка на примеры работ https://yadi.sk/d/ksVluPMB
  • Регистрация: 2015-02-27
    • Skype: ShuplecovDima
  • Сайт: 
  • Профессия: Программист 1С
СхемаКомпоновкиДанных =ЭтотОбъект.ПолучитьМакет("МакетОбработки");
В макете обработки что у вас?
Добавлено: 01 Июн 2015, 19:02

И сделайте точку останова после строчки
ТЗ = товары.Выгрузить(,"Атрикул,Номенклатура,ЦенаИзПрайса");
и посмотрите что в переменной ТЗ
Ссылка на примеры работ https://yadi.sk/d/ksVluPMBkiRzX

Последний раз редактировалось: Дмитрий@; 01 Июн 2015, 19:02. Причина: Объединение сообщений

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
На первый взгляд: у вас разные объекты

 КомандаНаСервере(); -Это объект 1
    структура=Новый Структура;
    Структура.Вставить("ТипЦен",Объект.ТипЦен);
    Форм = ПолучитьФорму("ВнешняяОбработка.АнализПрайсаПоставщика.Форма.ФормаОтчета",Структура,ЭтотОбъект);   /Это Объект 2 форму, которую вы получаете не имеет отношения к тому объекту, в котором выполнялся отчет.
    Форм.Открыть();
Ну и во вторых очень сильно сомневаюсь, что "ТипЦен"  заполняется.


Теги:
 

Перенос данных из 1с 82 БП (базовая) в 1с 82 БГУ (базовая)

Автор Владимир87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7459
Последний ответ 06 Дек 2014, 17:40
от дфтын
Поиск по бае данных,(полнотекстовый поиск)

Автор kot_ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3893
Последний ответ 19 Май 2014, 15:40
от kot_oo
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2132
Последний ответ 01 Янв 2017, 20:27
от Геннадий ОбьГЭС
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 7388
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
Куда сохраняются данные в режиме работы клиент при выгрузке данных обработкой "Универсальный обмен данными в формате XML"

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 6977
Последний ответ 13 Ноя 2014, 08:23
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
136 Сообщений
AIFrame
66 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 776
  • Точка Скрытых: 0
  • Точка Пользователей: 14
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal