Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 10:21
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Конструктор печати  (Прочитано 952 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн WarBoot

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-10
  • Сайт: 
  • Профессия: Ученик 1С
Доброго времени суток.
Возникла такая проблема, На документе использовал конструктор печати, но при попытке печати у меня выдаёт ошибку
{Документ.Оплата.МодульМенеджера(23)}: Ошибка при вызове метода контекста (Выполнить)
Выборка = Запрос.Выполнить().Выбрать();
по причине:
{(14, 2)}: Неоднозначное поле "Оплата.Ссылка"
<<?>>Оплата.Ссылка В (&Ссылка)



Код в модуле менеджера документа
Процедура Печать(ТабДок, Ссылка) Экспорт
//{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)
Макет = Документы.Оплата.ПолучитьМакет("Печать");
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| Оплата.Дата,
| Оплата.Марка,
| Оплата.НомерМашины,
| Оплата.Оплата,
| Оплата.Регион,
| Оплата.ТипМеста,
| Оплата.ТабличнаяЧасть1.(
| Владелец
| )
|ИЗ
| Документ.Оплата КАК Оплата
|ГДЕ
| Оплата.Ссылка В (&Ссылка)";
Запрос.Параметры.Вставить("Ссылка", Ссылка);
Выборка = Запрос.Выполнить().Выбрать();

ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
Шапка = Макет.ПолучитьОбласть("Шапка");
ОбластьТабличнаяЧасть1Шапка = Макет.ПолучитьОбласть("ТабличнаяЧасть1Шапка");
ОбластьТабличнаяЧасть1 = Макет.ПолучитьОбласть("ТабличнаяЧасть1");
ТабДок.Очистить();

ВставлятьРазделительСтраниц = Ложь;
Пока Выборка.Следующий() Цикл
Если ВставлятьРазделительСтраниц Тогда
ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
КонецЕсли;

ТабДок.Вывести(ОбластьЗаголовок);

Шапка.Параметры.Заполнить(Выборка);
ТабДок.Вывести(Шапка, Выборка.Уровень());

ТабДок.Вывести(ОбластьТабличнаяЧасть1Шапка);
ВыборкаТабличнаяЧасть1 = Выборка.ТабличнаяЧасть1.Выбрать();
Пока ВыборкаТабличнаяЧасть1.Следующий() Цикл
ОбластьТабличнаяЧасть1.Параметры.Заполнить(ВыборкаТабличнаяЧасть1);
ТабДок.Вывести(ОбластьТабличнаяЧасть1, ВыборкаТабличнаяЧасть1.Уровень());
КонецЦикла;

ВставлятьРазделительСтраниц = Истина;
КонецЦикла;
//}}
КонецПроцедуры


Оффлайн Дмитрий@

  • *****
  • Сообщений: 735
  • РЕПУТАЦИЯ: 134
  • КПД: 18%
  • Ссылка на примеры работ https://yadi.sk/d/ksVluPMB
  • Регистрация: 2015-02-27
    • Skype: ShuplecovDima
  • Сайт: 
  • Профессия: Программист 1С
В запросе полю "оплата" дайте другое название.
Или измените псевдоним таблицы.
Ссылка на примеры работ https://yadi.sk/d/ksVluPMB


 

Синтаксическая ошибка "ИЗ" <<?>>ИЗ при печати счета ут 10.3

Автор romanprogrammistРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4028
Последний ответ 02 Дек 2013, 14:42
от romanprogrammist
В при печати формы не заполняется поле "заказчик"

Автор senqsРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 3720
Последний ответ 02 Окт 2013, 12:03
от LordWizard
Ошибка печати "Метод объекта не обнаружен"

Автор Роза ГамильтоновнаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3812
Последний ответ 06 Июн 2014, 10:32
от wise
Ошибка при печати внешней формы "Поле объекта не обнаружено" папка Сотрудники

Автор sershovaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 4186
Последний ответ 14 Окт 2014, 16:43
от leksv
Печать штрих кодов на форму печати выводятся 3 штрих кода на принтер выходит только 2.

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 508
Последний ответ 15 Май 2017, 08:59
от ZSS

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 234
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal