Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Ноя 2017, 01:11
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Автор документа  (Прочитано 2894 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Smokez

  • *
  • Сообщений: 32
  • РЕПУТАЦИЯ: 0
  • Smokez
  • Регистрация: 2015-05-13
  • Сайт: 
  • Профессия: Ученик 1С
Доброго времени суток.
Интересует такой вопрос. Требуется чтобы при создании документа в реквизит "Автор" подставлялось имя пользователя создавшего документ.
Создал справочник "Пользователи",  параметр сеанса "ТекущийПользователь", в модуль сеанса поместил код:
Процедура УстановкаПараметровСеанса(ТребуемыеПараметры)
ТекПользователь = Справочники.Пользователи.НайтиПоНаименованию(ИмяПользователя());
Если ТекПользователь.Пустая() Тогда
НовПользователь = Справочники.Пользователи.СоздатьЭлемент();
НовПользователь.Наименование = ИмяПользователя();
НовПользователь.Записать();
ТекПользователь = НовПользователь.Ссылка;
КонецЕсли;
ПараметрыСеанса.ТекущийПользователь = ТекПользователь;
КонецПроцедуры

В документе "Приходная накладная" код:
 &НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
Объект.Автор = ПараметрыСеанса.ТекущийПользователь();
КонецПроцедуры

ошибок не выдает, но и реквизит "автор" пуст
Подскажите в чем проблема??


Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
ПараметрыСеанса.ТекущийПользователь(); 
на
ПараметрыСеанса.ТекущийПользователь;
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн Smokez

  • *
  • Сообщений: 32
  • РЕПУТАЦИЯ: 0
  • Smokez
  • Регистрация: 2015-05-13
  • Сайт: 
  • Профессия: Ученик 1С
ПараметрыСеанса.ТекущийПользователь(); 
на
ПараметрыСеанса.ТекущийПользователь;

Тогда пишет что переменная "ПараметрСеанса" не определена
Добавлено: 31 Май 2015, 19:19

Ошибся... Сделал как вы посоветовали, но реквизит все равно пустой

Последний раз редактировалось: Smokez; 31 Май 2015, 19:19. Причина: Объединение сообщений

Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
Эм
ок
а что такое по вашему ТекущийПользователь ?
Вы его где сделали?
Добавлено: 31 Май 2015, 19:54

Вы точно уверены что оно в параметре сеанса? мне даже интересно стало. давайте доступ гляну. все равно скучно
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
значит типы у Автора и параметры сеанса - не совпадают...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн AnnaSnova

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-27
  • Сайт: 
  • Профессия: Консультант 1С
&НаСервере Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка) Объект.Автор = ПараметрыСеанса.ТекущийПользователь; КонецПроцедуры

Доброе время суток!
Воспользовалась кодом. Мне нужно, чтобы на форме отображался автор бизнес-процесса. На деле выходит, автор1 создает процесс, я его открываю-вижу себя автором, другой чел открывает-он отображается как автор процесса,хотя в списке процессов отображается автор1.

Конфа Управление торговлей для Казахстана 3.0
Что делаю не так? Может есть другой вариант?

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Для начала предлагаю сначала думать, потом делать, потом спрашивать. У вас с первым пунктом пока не складывается.
ПриСозданииНаСервере (почитайте хотя бы в СП в каких случаях этот обработчик вызывается) - вызывается при создании формы, не объекта - а формы. Поэтому у вас всегда при открытии формы, как вы и прописали, значится в качестве автора пользователь который открыл форму.
Нужно в том же обработчике анализировать объект на предмет новый/не новый и прописывать автора только в случае нового объекта.

Оффлайн AnnaSnova

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-27
  • Сайт: 
  • Профессия: Консультант 1С
Вопрос решился таким путем.

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
   Если НЕ ЗначениеЗаполнено(Объект.Автор) Тогда
      Объект.Автор=Пользователи.ТекущийПользователь();
   КонецЕсли;

КонецПроцедуры

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
можно и так но обычно проверяют
    Если Параметры.Ключ.Пустая() Тогда
    ...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
можно и так но обычно проверяют
    Если Параметры.Ключ.Пустая() Тогда
    ...

Однозначно.


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4430
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15749
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4145
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 578
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7680
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
164 Сообщений
MuI_I_Ika MuI_I_Ika
96 Сообщений
oleg-x
67 Сообщений
alex0402
66 Сообщений
ilyay ilyay
58 Сообщений
Dmitry Qwe Dmitry Qwe
32 Сообщений
Sy4a
22 Сообщений
Dima Dddd Dima Dddd
20 Сообщений
BuhRust
19 Сообщений
Kironten
12 Сообщений

* Кто онлайн

  • Точка Гостей: 204
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal