Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 16:28
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Картинка в управляемой форме  (Прочитано 2868 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Sergspectr

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-29
  • Сайт: 
  • Профессия: Ученик 1С
Доброго времени суток.  Уважаемые форумчане, не могли бы помочь, как вывести картинку на форму.
В конфигурации БП3 было создано дополнительное сведение «Картинка» с типом значения файл. Была создана обработка и  форма со строковым реквизитом «Картинка»  с видом «поле картинки». В модуле формы производится выборка объекта из регистра дополнительные свойства. В итоге получается получить навигационную ссылку значения (Картинка = ПолучитьНавигационнуюСсылку (Значение)), но по данной ссылке ни чего не отображается на форме. Не могли бы помочь в решении данной проблемы.


Оффлайн Дмитрий@

  • *****
  • Сообщений: 735
  • РЕПУТАЦИЯ: 134
  • КПД: 18%
  • Ссылка на примеры работ https://yadi.sk/d/ksVluPMB
  • Регистрация: 2015-02-27
    • Skype: ShuplecovDima
  • Сайт: 
  • Профессия: Программист 1С
Наверно так
Картинка = ПолучитьНавигационнуюСсылку (Объект.ССылка,"НаименованиеРеквизита")
Ссылка на примеры работ https://yadi.sk/d/ksVluPMB

Оффлайн Sergspectr

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-29
  • Сайт: 
  • Профессия: Ученик 1С
Наверно так
Картинка = ПолучитьНавигационнуюСсылку (Объект.ССылка,"НаименованиеРеквизита")

На сколько я понимаю под "НаименованиеРеквизита" имеется в виду Реквизит, в котором хранится картинка, если это так, то не могли бы подсказать реквизит хранения картинки в регистре ДополнительныеСведения

Оффлайн Дмитрий@

  • *****
  • Сообщений: 735
  • РЕПУТАЦИЯ: 134
  • КПД: 18%
  • Ссылка на примеры работ https://yadi.sk/d/ksVluPMB
  • Регистрация: 2015-02-27
    • Skype: ShuplecovDima
  • Сайт: 
  • Профессия: Программист 1С
Цитировать
На сколько я понимаю под "НаименованиеРеквизита" имеется в виду Реквизит, в котором хранится картинка, если это так
Да это так.


Добавлено: 29 Май 2015, 23:11

Цитировать
то не могли бы подсказать реквизит хранения картинки в регистре ДополнительныеСведения
Для этого нужно иметь на руках вашу конфигурацию.
Ссылка на примеры работ https://yadi.sk/d/ksVluPMB

Оффлайн Sergspectr

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-29
  • Сайт: 
  • Профессия: Ученик 1С
Цитировать
На сколько я понимаю под "НаименованиеРеквизита" имеется в виду Реквизит, в котором хранится картинка, если это так
Да это так.


Добавлено: 29 Май 2015, 23:11

Цитировать
то не могли бы подсказать реквизит хранения картинки в регистре ДополнительныеСведения
Для этого нужно иметь на руках вашу конфигурацию.

Типовая БП3

Процедура в модуле :
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    |    ДополнительныеСведения.Значение,
    |    ДополнительныеСведения.Свойство.Наименование
    |ИЗ
    |    РегистрСведений.ДополнительныеСведения КАК ДополнительныеСведения
    |ГДЕ
    |    ДополнительныеСведения.Объект = &Объект";
    Запрос.УстановитьПараметр("Объект",Объект.Ссылка );
    РезультатЗапроса = Запрос.Выполнить();
     Выборка = РезультатЗапроса.Выбрать();
     Пока Выборка.Следующий()    ЦИКЛ
        Если Выборка.СвойствоНаименование = "Картинка (Номенклатура)" Тогда
    Картинка = ПолучитьНавигационнуюСсылку(Выборка.Значение);
Элементы.Картинка.РазмерКартинки = РазмерКартинки.АвтоРазмер;
      КонецЕсли;
         КонецЦикла;
         
    КонецПроцедуры

Дополнительное Сведение добавлялось через Администрирование - Общие настройки - Дополнительные сведения

Последний раз редактировалось: Sergspectr; 29 Май 2015, 23:23

Оффлайн Дмитрий@

  • *****
  • Сообщений: 735
  • РЕПУТАЦИЯ: 134
  • КПД: 18%
  • Ссылка на примеры работ https://yadi.sk/d/ksVluPMB
  • Регистрация: 2015-02-27
    • Skype: ShuplecovDima
  • Сайт: 
  • Профессия: Программист 1С
Цитировать
Типовая БП3
К сожалению после этого у меня конфигурация не появилась. Шутка.

А почему вы сами не можете посмотреть название реквизита, вроде там ничего сложного. Что вас смущает.
Ссылка на примеры работ https://yadi.sk/d/ksVluPMB

Оффлайн Sergspectr

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-29
  • Сайт: 
  • Профессия: Ученик 1С
Цитировать
Типовая БП3
К сожалению после этого у меня конфигурация не появилась. Шутка.

А почему вы сами не можете посмотреть название реквизита, вроде там ничего сложного. Что вас смущает.

Дело в том, что по указанному мною листингу ссылка получается, но насколько я понял, когда разбирал отладчиком форму дополнительныхсведений, там присутствует два вида ссылок НавигационнаяСсылка и НавигационнаяСсылкаТекущейВерсии. Может конечно я и не прав. Вот и появились сомнения.

Оффлайн Дмитрий@

  • *****
  • Сообщений: 735
  • РЕПУТАЦИЯ: 134
  • КПД: 18%
  • Ссылка на примеры работ https://yadi.sk/d/ksVluPMB
  • Регистрация: 2015-02-27
    • Skype: ShuplecovDima
  • Сайт: 
  • Профессия: Программист 1С
У меня таких ссылок нет, видимо у вас что-то дописано.
Цитировать
В конфигурации БП3 было создано дополнительное сведение «Картинка» с типом значения файл.
Вам нужно указать реквизит картинка.
Добавлено: 30 Май 2015, 19:45

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
      Отбор = Новый Структура;
   Отбор.Вставить("Объект",Объект.Ссылка);
   Отбор.Вставить("Свойство",Свойство);
   КлючЗаписи = РегистрыСведений.ДополнительныеСведения.СоздатьКлючЗаписи(Отбор);
   
    Картинка = ПолучитьНавигационнуюСсылку(КлючЗаписи,"Картинка");
Элементы.Картинка.РазмерКартинки = РазмерКартинки.АвтоРазмер;
              
    КонецПроцедуры
Ссылка на примеры работ https://yadi.sk/d/ksVluPMB

Последний раз редактировалось: Дмитрий@; 30 Май 2015, 19:45. Причина: Объединение сообщений

Оффлайн Sergspectr

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-29
  • Сайт: 
  • Профессия: Ученик 1С
У меня таких ссылок нет, видимо у вас что-то дописано.
Цитировать
В конфигурации БП3 было создано дополнительное сведение «Картинка» с типом значения файл.
Вам нужно указать реквизит картинка.
Добавлено: 30 Май 2015, 19:45

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
      Отбор = Новый Структура;
   Отбор.Вставить("Объект",Объект.Ссылка);
   Отбор.Вставить("Свойство",Свойство);
   КлючЗаписи = РегистрыСведений.ДополнительныеСведения.СоздатьКлючЗаписи(Отбор);
   
    Картинка = ПолучитьНавигационнуюСсылку(КлючЗаписи,"Картинка");
Элементы.Картинка.РазмерКартинки = РазмерКартинки.АвтоРазмер;
              
    КонецПроцедуры

Не выводится по данному варианту картинка. Не могли бы  подсказать у Вас данный вариант работает без проблем?

Оффлайн Дмитрий@

  • *****
  • Сообщений: 735
  • РЕПУТАЦИЯ: 134
  • КПД: 18%
  • Ссылка на примеры работ https://yadi.sk/d/ksVluPMB
  • Регистрация: 2015-02-27
    • Skype: ShuplecovDima
  • Сайт: 
  • Профессия: Программист 1С
Я не проверял, но по идее в в вашем случае это делается так.
Скиньте полностью код как вы написали по моему шаблону.
Ссылка на примеры работ https://yadi.sk/d/ksVluPMB


Теги: картинка 
 

Группа "СписокКомпоновщикНастроекПользовательскиеНастройки" в форме "Перечисления"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1760
Последний ответ 12 Ноя 2016, 18:08
от Азамат Хубиев
Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 270
Последний ответ 12 Окт 2017, 14:02
от wise
Как настроить отображение на форме "группа плательщика единого налога" при выборе системы налогообложения "Единый налог"?

Автор Nicolayci91Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2274
Последний ответ 17 Авг 2015, 07:48
от cska-fanat-kz
Добавление строки и заполнение строки в ТЗ на форме

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 294
Последний ответ 25 Сен 2017, 09:00
от Св Ч
Ребята, срочно нужна помощь. Какую процедуру нужно написать в форме справочника, чтобы таблица заполнялась данными из другого справочника?

Автор Олька БякинаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2758
Последний ответ 27 Май 2016, 15:19
от Олька Бякина

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
184 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 685
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal