Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 16:06
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите доделать запрос  (Прочитано 1458 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн макс

  • ****
  • Сообщений: 305
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2010-06-15
  • Сайт: 
ТекстЗапроса =
   "ВЫБРАТЬ
   |   ФизическиеЛица.Ссылка,
   |   ФизическиеЛица.Пол,
   |   ФизическиеЛица.ДатаРождения,
   |   СУММА(СтраховыеВзносыСведенияОДоходах.Результат) КАК Начислено,
   |   СтраховыеВзносыИсчисленные.ФСС КАК ФСС,
   |   СтраховыеВзносыИсчисленные.ФФОМС КАК ФФОМС,
   |   СтраховыеВзносыИсчисленные.ТФОМС КАК ТФОМС,
   |   СтраховыеВзносыИсчисленные.ПФРСтраховая КАК ПФРСтраховая,
   |   СтраховыеВзносыИсчисленные.ПФРНакопительная КАК ПФРНакопительная,
   |   Облагаемая.Результат КАК Облагаемая
   |ИЗ
   |   (ВЫБРАТЬ
   |      ФизическиеЛица.Ссылка КАК Ссылка,
   |      ФизическиеЛица.Пол КАК Пол,
   |      ФизическиеЛица.ДатаРождения КАК ДатаРождения
   |   ИЗ
   |      Справочник.ФизическиеЛица КАК ФизическиеЛица
   |   ГДЕ
   |      ФизическиеЛица.ЭтоГруппа = ЛОЖЬ) КАК ФизическиеЛица
   |      ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрНакопления.СтраховыеВзносыСведенияОДоходах КАК СтраховыеВзносыСведенияОДоходах
   |      ПО ФизическиеЛица.Ссылка = СтраховыеВзносыСведенияОДоходах.ФизЛицо
   |      ВНУТРЕННЕЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
   |         СтраховыеВзносыСведенияОДоходах.ФизЛицо КАК Физлицо,
   |         СУММА(СтраховыеВзносыСведенияОДоходах.Результат) КАК Результат
   |      ИЗ
   |         РегистрНакопления.СтраховыеВзносыСведенияОДоходах КАК СтраховыеВзносыСведенияОДоходах
   |      ГДЕ
   |         СтраховыеВзносыСведенияОДоходах.Организация = &Организация
   |         И СтраховыеВзносыСведенияОДоходах.Период МЕЖДУ &ДатаНач И &ДатаКон
   |          И СтраховыеВзносыСведенияОДоходах.ВидРасчета.КодДоходаСтраховыеВзносы В (&КодДохода)
   |           И СтраховыеВзносыСведенияОДоходах.ВидРасчета.КодДоходаЕСН В (&КодДоходаЕСН)
   |           
   |       СГРУППИРОВАТЬ ПО
   |         СтраховыеВзносыСведенияОДоходах.ФизЛицо) КАК Облагаемая
   |      ПО ФизическиеЛица.Ссылка = Облагаемая.Физлицо
   |      ВНУТРЕННЕЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
   |         СтраховыеВзносыИсчисленные.ФизЛицо КАК ФизЛицо,
   |         СУММА(СтраховыеВзносыИсчисленные.ФСС) КАК ФСС,
   |         СУММА(СтраховыеВзносыИсчисленные.ФФОМС) КАК ФФОМС,
   |         СУММА(СтраховыеВзносыИсчисленные.ТФОМС) КАК ТФОМС,
   |         СУММА(СтраховыеВзносыИсчисленные.ПФРСтраховая) КАК ПФРСтраховая,
   |         СУММА(СтраховыеВзносыИсчисленные.ПФРНакопительная) КАК ПФРНакопительная
   |      ИЗ
   |         РегистрНакопления.СтраховыеВзносыИсчисленные КАК СтраховыеВзносыИсчисленные
   |      ГДЕ
   |         СтраховыеВзносыИсчисленные.Активность = ИСТИНА
   |         И СтраховыеВзносыИсчисленные.Период МЕЖДУ &ДатаНач И &ДатаКон
   |         И СтраховыеВзносыИсчисленные.Организация = &Организация
   |         
   |      СГРУППИРОВАТЬ ПО
   |         СтраховыеВзносыИсчисленные.ФизЛицо) КАК СтраховыеВзносыИсчисленные
   |      ПО ФизическиеЛица.Ссылка = СтраховыеВзносыИсчисленные.ФизЛицо
   |ГДЕ
   |   СтраховыеВзносыСведенияОДоходах.Организация = &Организация
   |   И СтраховыеВзносыСведенияОДоходах.Период МЕЖДУ &ДатаНач И &ДатаКон
   |   
   |   И Облагаемая.Результат > 0";
Если ТипОтчета = 2 Тогда
      ТекстЗапроса = ТекстЗапроса + "
   |   И ФизическиеЛица.ДатаРождения < &ГодРождения";
КонецЕсли;
Если  ТипОтчета = 3 Тогда
      ТекстЗапроса = ТекстЗапроса + "
   |   И ФизическиеЛица.ДатаРождения > &ГодРождения";
КонецЕсли;
Если Не ПодразделенияОрганизаций.Пустая() Тогда
       ТекстЗапроса = ТекстЗапроса + "
   |   И СтраховыеВзносыСведенияОДоходах.ОбособленноеПодразделение = &ПодразделенияОрганизаций";
КонецЕсли;
ТекстЗапроса = ТекстЗапроса + "
   |
   |СГРУППИРОВАТЬ ПО
   |   ФизическиеЛица.Пол,
   |   ФизическиеЛица.ДатаРождения,
   |   ФизическиеЛица.Ссылка,
   |   СтраховыеВзносыИсчисленные.ФСС,
   |   СтраховыеВзносыИсчисленные.ФФОМС,
   |   СтраховыеВзносыИсчисленные.ТФОМС,
   |   СтраховыеВзносыИсчисленные.ПФРСтраховая,
   |   СтраховыеВзносыИсчисленные.ПФРНакопительная,
   |   Облагаемая.Результат
   |
   |УПОРЯДОЧИТЬ ПО
   |   ФизическиеЛица.Ссылка.Наименование
   |ИТОГИ
   |   СУММА(Начислено),
   |   СУММА(ФСС),
   |   СУММА(ФФОМС),
   |   СУММА(ТФОМС),
   |   СУММА(ПФРСтраховая),
   |   СУММА(ПФРНакопительная),
   |   СУММА(Облагаемая)
   |ПО
   |   ОБЩИЕ";
   //,
   
               ;//,
   //,
   //|   Ссылка";
   Запрос.Текст = ТекстЗапроса;
   
    Запрос.УстановитьПараметр("ПодразделенияОрганизаций",ПодразделенияОрганизаций);
   Запрос.УстановитьПараметр("ГодРождения", Дата("19670101"));
   Запрос.УстановитьПараметр("ДатаНач",ДатаНач);
   Запрос.УстановитьПараметр("ДатаКон",ДатаКон);
   Запрос.УстановитьПараметр("Организация",Организация);
   Запрос.УстановитьПараметр("КодДохода", КодДохода);
   Запрос.УстановитьПараметр("КодДоходаЕСН", КодДоходаЕСН);
   Запрос.УстановитьПараметр("ПолМужской", Перечисления.ПолФизическихЛиц.Мужской);


Оффлайн макс

  • ****
  • Сообщений: 305
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2010-06-15
  • Сайт: 
Мне нужно сделать отбор по подразделениям организаций, есть РегистрСведений.РаботникиОрганизаций там все сотрудники распределены по подразделениям, вот и не знаю как связать его с запросом, есть условие
Если Не ПодразделенияОрганизаций.Пустая() Тогда
       ТекстЗапроса = ТекстЗапроса + "
   ?;
КонецЕсли;
это условие когда выбрано подразделение

Оффлайн макс

  • ****
  • Сообщений: 305
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2010-06-15
  • Сайт: 
Все сам сделал:)


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4296
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5554
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5892
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4379
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1981
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 253
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal