Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 16:46
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проблема с отображением номера счет-фактуры  (Прочитано 3415 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Bitard

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-27
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте.
Бухгалтерия предприятия, редакция 3.0
В документе СчетФактураВыданный, в форме списка, в поле номер почему-то отображается только 4 последних цифры, при том что в форме документа на реализацию номер счет-фактуры отображается полностью.
Поле не ограниченно 4 символами, не могу найти где теряются цифры :dfbsdfbsdf:
Может быть кто поможет. Спасибо заранее.


Оффлайн Bitard

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-27
  • Сайт: 
  • Профессия: Ученик 1С

Добавил скриншот, для наглядности.

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Вы уверены, что это один и тот же реквизит?

Оффлайн Bitard

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-27
  • Сайт: 
  • Профессия: Ученик 1С
Вы уверены, что это один и тот же реквизит?
Уверен, другово нет)

Добавлено: 28 Май 2015, 11:32

Нашел зависимость этой проблемы с наличием знака "-" в номере, но как пофиксить пока не понятно.
Может попробовать вывести номер счет-фактуры в отдельный реквизит, в обход номера:dfbbdrfb:

Последний раз редактировалось: Bitard; 28 Май 2015, 11:32. Причина: Объединение сообщений

Оффлайн Kironten

  • *****
  • Сообщений: 906
  • РЕПУТАЦИЯ: 185
  • КПД: 20%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
В список, подбирается не сам номер, а реквизит документа "ПредставлениеНомера" который формируется при записи документа.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
В форме списка колонка "Номер" - это на самом деле реквизит "ПредставлениеНомера".
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Процедура УстановитьПредставлениеНомера()
   
   Если НЕ ЗначениеЗаполнено(Номер) Тогда
      ЭтотОбъект.УстановитьНовыйНомер();   
   КонецЕсли;
   
   Если Исправление Тогда
      Если ВидСчетаФактуры = Перечисления.ВидСчетаФактурыВыставленного.Корректировочный Тогда
         ПредставлениеНомера = НомерИсправляемогоКорректировочногоДокумента + " (испр. "+ НомерИсправления+")";
      Иначе
         ПредставлениеНомера = НомерИсходногоДокумента + " (испр. "+ НомерИсправления+")";
      КонецЕсли;
   Иначе
      ПредставлениеНомера = ПрефиксацияОбъектовКлиентСервер.ПолучитьНомерНаПечать(Номер, Истина, Ложь);      
   КонецЕсли;
   
КонецПроцедуры

Где-то настройка есть печати которая убирает для печати префикс и лидирующие нули...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Kironten

  • *****
  • Сообщений: 906
  • РЕПУТАЦИЯ: 185
  • КПД: 20%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Где-то настройка есть печати которая убирает для печати префикс и лидирующие нули...

Ну раз уж человек не против выводить номер в отдельный реквизит, что подразумевает внесение изменений, то почему бы просто не залезть в динамический  список и заменить строку запроса:
ДокументСчетФактураВыданный.ПредставлениеНомера КАК Номер,

Оффлайн Bitard

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-05-27
  • Сайт: 
  • Профессия: Ученик 1С
Всем спасибо. Проблема решена.:ooifh:
Закомментил строку про получитьномернапечать и заработало вроде как надо.
Процедура УстановитьПредставлениеНомера()
Если НЕ ЗначениеЗаполнено(Номер) Тогда
ЭтотОбъект.УстановитьНовыйНомер();
КонецЕсли;

Если Исправление Тогда
Если ВидСчетаФактуры = Перечисления.ВидСчетаФактурыВыставленного.Корректировочный Тогда
ПредставлениеНомера = НомерИсправляемогоКорректировочногоДокумента + " (испр. "+ НомерИсправления+")";
Иначе
ПредставлениеНомера = НомерИсходногоДокумента + " (испр. "+ НомерИсправления+")";
КонецЕсли;
Иначе
   ПредставлениеНомера=Номер;
//ПредставлениеНомера = ПрефиксацияОбъектовКлиентСервер.ПолучитьНомерНаПечать(Номер, Истина, Ложь);
КонецЕсли;
КонецПроцедуры
Добавлено: 28 Май 2015, 15:21

Как вариант можно еще в функции ПолучитьНомерНаПечать в ПрефиксацияОбъектовКлиентСервер поставить параметр СтандартнаяОбработка = Ложь;
Правда почему-то на формирование отчетов(Книга Продаж например) это не подействовало. Видимо там используется какая-то другая функция.

Последний раз редактировалось: Bitard; 28 Май 2015, 15:21. Причина: Объединение сообщений

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Как вариант можно еще в функции ПолучитьНомерНаПечать в ПрефиксацияОбъектовКлиентСервер поставить параметр СтандартнаяОбработка = Ложь;

смысл?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Проблема с выгрузкой НН в "Звит" Не найдено соответствие для схемы "J1201008"

Автор AldemaHРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1179
Последний ответ 06 Июл 2016, 09:19
от AldemaH
проблема с "ЗагрузкаДанныхИзТабличногоДокумента"

Автор bratmaratРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4707
Последний ответ 08 Янв 2014, 14:30
от LordWizard
Проблема с развертыванием окон и сохранением окон

Автор SokresРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2435
Последний ответ 09 Дек 2015, 14:09
от pavl_vs
Проблема с отчетом "Перемещение товаров"

Автор sailРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3325
Последний ответ 14 Дек 2010, 20:27
от progmikon
1C 8.2 УПП проблема с отчетом "Задолженость по контрагентам"

Автор LeonidLeonidРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3587
Последний ответ 26 Сен 2011, 20:42
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
179 Сообщений
ilyay ilyay
69 Сообщений
alex0402
54 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 613
  • Точка Скрытых: 1
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal