Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 00:06
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Подстановка имени  (Прочитано 1167 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Smokez

  • *
  • Сообщений: 32
  • РЕПУТАЦИЯ: 0
  • Smokez
  • Регистрация: 2015-05-13
  • Сайт: 
  • Профессия: Ученик 1С
Доброго времени суток, пишу конфигурацию и интересует такой вопрос.
Есть документ "Приходная накладная",
как сделать чтобы в поле "Автор" автоматический подставлялось имя бухгалтера который создал этот документ.
Имя прописано в роли Бухгалтер под которой зашел пользователь.
Если можно развернутый ответ, а то я новичек.


Оффлайн Rasty

  • *****
  • Сообщений: 988
  • РЕПУТАЦИЯ: 139
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
ПользователиИнформационнойБазы.ТекущийПользователь()
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн Smokez

  • *
  • Сообщений: 32
  • РЕПУТАЦИЯ: 0
  • Smokez
  • Регистрация: 2015-05-13
  • Сайт: 
  • Профессия: Ученик 1С
В если поточнее можно, код при создании документа нужно или как?

Оффлайн Rasty

  • *****
  • Сообщений: 988
  • РЕПУТАЦИЯ: 139
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
ПриСоздании ПередЗаписью ПослеЗаписи,как угодно, но &НаСервере
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
обычно существует:
1. справочник Пользователи, каждому элементу которого соответствует пользователь информационной базы.
2. параметр сеанса ТекущийПользователь типа СправочникСсылка.Пользователи куда при начале работы системы помещается ссылка на справочник, которая соответствует текущему пользователю ИБ.
3. в самом документе реквизит Автор можно заполнить например в ОбработкаЗаполнения()

хотя на самом деле вариантов реализации - масса.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Rasty

  • *****
  • Сообщений: 988
  • РЕПУТАЦИЯ: 139
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
cska-fanat-kz, вариантов правда масса, но у автора вроде конфа самописная
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
cska-fanat-kz, вариантов правда масса, но у автора вроде конфа самописная

вот поэтому и есть место для полета фантазии )
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Smokez

  • *
  • Сообщений: 32
  • РЕПУТАЦИЯ: 0
  • Smokez
  • Регистрация: 2015-05-13
  • Сайт: 
  • Профессия: Ученик 1С
Большое спасибо, буду думать
Добавлено: 28 Май 2015, 16:21

Воспользовался вашим советом

Создал справочник пользователи,
Создал параметр сеанса "ТекущийПользователь" с кодом:


Процедура УстановкаПараметровСеанса(ТребуемыеПараметры)
   ТекПользователь = Справочники.Пользователи.НайтиПоНаименованию(ИмяПользователя());
Если ТекПользователь.Пустая() Тогда
   НовПользователь = Справочники.Пользователи.СоздатьЭлемент();
   НовПользователь.Наименование = ИмяПользователя();
   НовПользователь.Записать();
   ТекПользователь = НовПользователь.Ссылка;
КонецЕсли;
   ПараметрыСеанса.ТекущийПользователь = ТекПользователь;
КонецПроцедуры

После в документе "Приходная накладная" в форме

 &НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
Объект.Автор = ПараметрыСеанса.ТекущийПользователь();
КонецПроцедуры

Но реквизит автор все равно не заполняется
Добавлено: 28 Май 2015, 16:43

и ошибок не выдает

Последний раз редактировалось: Smokez; 28 Май 2015, 16:43. Причина: Объединение сообщений


Теги:
 

Определение текущего Пользователя в ИБ, подстановка пользователя в справочник

Автор LavrSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 939
Последний ответ 28 Апр 2016, 07:33
от LavrS
Если компания перевозила груз от имени разных фирм одним транспортом, сделки считаются фиктивными

Автор newsРаздел Новости

Ответов: 0
Просмотров: 515
Последний ответ 08 Авг 2014, 15:53
от news
Одно и тоже доверенное лицо может подписывать счет-фактуры от имени руководителя и главного бухгалтера

Автор newsРаздел Новости

Ответов: 0
Просмотров: 860
Последний ответ 27 Ноя 2014, 13:56
от news
Автоматический выбор имени файла, даты начала и данные для выгрузки

Автор Дима РодненокРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 971
Последний ответ 14 Янв 2016, 13:55
от Vladimir_Sh
Можно ли оформлять документы в конфигурации от имени различных юридических лиц к

Автор DDDРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 3032
Последний ответ 25 Ноя 2008, 10:31
от DDD

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
166 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 272
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal